This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 716354 - pango uses deprecated G_CONST_RETURN
pango uses deprecated G_CONST_RETURN
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: pango (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: F16FTBFS 716140
  Show dependency treegraph
 
Reported: 2011-06-24 01:59 EDT by Milan Crha
Modified: 2012-01-11 08:55 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 716140
Environment:
Last Closed: 2012-01-11 08:55:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Milan Crha 2011-06-24 01:59:15 EDT
+++ This bug was initially created as a clone of Bug #716140 +++

evolution-data-server-3.1.2-1.fc16.src.rpm Failed To Build From Source against the rawhide tree.

--- Additional comment from mcrha on 2011-06-24 01:56:13 EDT ---

As I wrote to the mailing list, this is because pango isn't ready for the deprecation of G_CONST_RETURN. From the build log:
> /usr/include/pango-1.0/pango/pango-renderer.h:252:1: error: unknown type
> name 'G_CONST_RETURN'

This is not available, because evolution-data-server defines couple deprecated flags:
	G_DISABLE_DEPRECATED
	PANGO_DISABLE_DEPRECATED
	GDK_PIXBUF_DISABLE_DEPRECATED
	G_DISABLE_SINGLE_INCLUDES
	GTK_DISABLE_SINGLE_INCLUDES
	GSEAL_ENABLE

Thus this is a transitive failure, due to a library which is not ready for the recent GLib deprecation.
Comment 1 Fedora Admin XMLRPC Client 2012-01-10 10:43:38 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Matthias Clasen 2012-01-11 08:55:57 EST
This has been fixed upstream

Note You need to log in before you can comment on or make changes to this bug.