Bug 716572

Summary: gnome-shell-3.0.2.-3.fc15.x86_64 built with rpath, breaks on nvidia rpmfusion drivers
Product: [Fedora] Fedora Reporter: Jonathan Abbey <jonabbey>
Component: gnome-shellAssignee: Owen Taylor <otaylor>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 15CC: awilliam, belegdol, chrisudeussen, craig48, edosurina, eric.tanguy, gabe, gtmkramer, kevin, kraymond, mail, maxamillion, mike, mike.walton33, otaylor, robatino, samkraju, sangu.fedora, tim, walters
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: gnome-shell-3.0.2-4.fc15 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 716669 (view as bug list) Environment:
Last Closed: 2011-06-25 15:56:35 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
xsession-errors file none

Description Jonathan Abbey 2011-06-24 20:48:41 EDT
Description of problem:

gnome-shell 3.0.2-3.fc15.x86_64 was built with RPATH set, which causes gnome shell to ignore /etc/ld.so.conf.d when looking for libGL.

This causes a Clutter-CRITICAL message in .xsession-errors, followed by

Unable to initialize clutter unable to find suitable fbconfig for the GLX context

Version-Release number of selected component (if applicable):

As above, with the binary nvidia driver module (akmod-nvidia) from rpmfusion installed.

How reproducible:

Always.

Steps to Reproduce:
1. Attempt to login via gdm.  Find the gnome-shell missing.
2.
3.
  
Actual results:

Gnome shell does not start, the above clutter error is in .xsession-errors

Expected results:

A clean login.

Additional info:

http://fedoraproject.org/wiki/Packaging:Guidelines#Beware_of_Rpath

I was able to work around the problem by doing

chrpath -d /usr/bin/gnome-shell
LD_LIBRARY_PATH=/usr/lib64/gnome-shell:/usr/lib64/gnome-bluetooth /usr/bin/gnome-shell
Comment 1 Jonathan Abbey 2011-06-24 20:51:44 EDT
My initial entry lacks some clarity.

Without taking the RPATH out of the /usr/bin/gnome-shell, ld.so ignores the ld.so.conf.d directory, and so doesn't properly find the binary nvidia GL driver which is clutter compatible.

Due to the RPATH set (/usr/lib64:/usr/lib64/gnome-shell:/usr/lib64/gnome-bluetooth), gnome-shell doesn't properly find the nvidia GL library, and is thus
unable to initialize clutter due to the inadequacies of the Mesa GL library in /usr/lib64.
Comment 2 Jurgen Kramer 2011-06-25 04:10:20 EDT
I've set the severity and priority to medium but I think they should be higher. Everybody using the nvidia binairy driver and gnome-shell seems to be bitten by this (including me). 

I managed to get thinks working again by downgrading a few packages.
Comment 3 Jonathan Abbey 2011-06-25 06:11:53 EDT
Upon reading http://fedoraproject.org/wiki/Packaging:Guidelines#Beware_of_Rpath more closely, it appears the problem is not that any RPATH is set on gnome-shell, but rather that /usr/lib64 is part of the RPATH.

You can see the RPATH encoded into the gnome-shell binary by running

chrpath -l /usr/bin/gnome-shell

I had to do a 'yum install chrpath' before this worked, of course.
Comment 4 Jonathan Abbey 2011-06-25 06:17:08 EDT
This also means that the problem can be fixed / worked around by the end user by running

chrpath -r /usr/lib64/gnome-shell:/usr/lib64/gnome-bluetooth /usr/bin/gnome-shell

as root, to take the system standard /usr/lib64 out of gnome-shell's RPATH.
Comment 5 Jonathan Abbey 2011-06-25 06:18:41 EDT
This can't be done while gnome-shell is running, however.
Comment 6 Kevin Raymond 2011-06-25 06:50:23 EDT
the chrpath work around was not working for me, I had also to 
yum downgrade xulrunner gnome-python2-extras gnome-python2-gtkmozembed gnome-shell firefox xulrunner-devel
as explained there: http://www.fedoraforum.org/forum/showthread.php?p=1488976
Comment 7 Kevin Fenzi 2011-06-25 09:44:20 EDT
Does this scratch build fix the issue for people? 

ie, yum update to the latest everything, then update this gnome-shell version: 

http://koji.fedoraproject.org/koji/taskinfo?taskID=3160496
Comment 8 Kevin Fenzi 2011-06-25 09:50:28 EDT
Oops. Missed an rpath there. Don't try that one. Will do another here in a few.
Comment 9 Kevin Fenzi 2011-06-25 09:59:17 EDT
ok, try: 

http://koji.fedoraproject.org/koji/taskinfo?taskID=3160533
Comment 10 Kevin Fenzi 2011-06-25 10:04:42 EDT
...and that one doesn't work either. ;( Back to the drawing board.
Comment 11 Kevin Fenzi 2011-06-25 10:36:25 EDT
ok. I had to be selective which rpath's to remove. 

Try: 

http://koji.fedoraproject.org/koji/taskinfo?taskID=3160601
Comment 12 Jurgen Kramer 2011-06-25 10:55:31 EDT
Yep, installing gnome-shell-3.0.2-4.fc15.x86_64.rpm from koji fixed the problem for me (i.e. I get the normal desktop after I login).
Comment 13 Michael Walton 2011-06-25 11:00:38 EDT
Thank you very much. The last effort by Kevin Fenzi did the trick. (My desktop is also back to normal)
Comment 14 Kevin Fenzi 2011-06-25 11:04:13 EDT
http://koji.fedoraproject.org/koji/taskinfo?taskID=3160632 should be the final fixed one that works on 32bit and 64bit. 

I'll look at pushing an update to testing with this fix in a bit here with more feedback.
Comment 15 Christian D 2011-06-25 11:12:20 EDT
The latest works very well for me on a 64bit machine.
Comment 16 Fedora Update System 2011-06-25 11:22:44 EDT
gnome-shell-3.0.2-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gnome-shell-3.0.2-4.fc15
Comment 17 edo 2011-06-25 11:48:15 EDT
(In reply to comment #16)
> gnome-shell-3.0.2-4.fc15 has been submitted as an update for Fedora 15.
> https://admin.fedoraproject.org/updates/gnome-shell-3.0.2-4.fc15

After starting Gnome Shell cannot seeing/using main upper Activity bar.
Comment 18 Kevin Fenzi 2011-06-25 12:19:21 EDT
Did you see this same behavior with previous gnome-shell versions? 

Also, are you using the nvidia binary only video drivers?
Comment 19 edo 2011-06-25 12:41:25 EDT
(In reply to comment #18)
> Did you see this same behavior with previous gnome-shell versions? 

Yes, with 3.0.2-3

> Also, are you using the nvidia binary only video drivers?

Yes, NVIDIA bin driver from RPMFusion.
Comment 20 Kevin Fenzi 2011-06-25 12:47:02 EDT
ok, so this is not a new regression in -4. 

If you 'yum downgrade gnome-shell' back to the orig release does it work? 
Did it ever work on that machine? if so, when?
Comment 21 Jonathan Abbey 2011-06-25 13:00:11 EDT
(In reply to comment #17)
> (In reply to comment #16)
> > gnome-shell-3.0.2-4.fc15 has been submitted as an update for Fedora 15.
> > https://admin.fedoraproject.org/updates/gnome-shell-3.0.2-4.fc15
> 
> After starting Gnome Shell cannot seeing/using main upper Activity bar.

How did you start Gnome Shell?  I found that if I started gnome-shell from a console tty (alt-F2, etc.) rather than from a terminal window started in the X session, the upper activity bar did not function properly and gnome-shell reported errors at start up not related to the rpath issue.

Are you able to get a clean login after rebooting?  Alternatively, can you do ctrl-backspace in your X session to get back to the login screen, followed by a successful login and gnome-shell session?
Comment 22 Jonathan Abbey 2011-06-25 13:10:51 EDT
That should have been ctrl-alt-backspace, of course.

It seems that gnome-shell doesn't function quite right if it is started outside of the X session by using DISPLAY=, etc.  I'm not sure that's a bug.
Comment 23 Steve Bryant 2011-06-25 13:39:10 EDT
Installing gnome-shell-3.0.2-4.fc15.x86_64 fixed it for me - running with kmod-nvidia-2.6.38.8-32.fc15.x86_64-275.09.07-1.fc15.1.x86_64 from RPMfusion

Thanks Kevin!
Comment 24 edo 2011-06-25 14:34:19 EDT
(In reply to comment #20)
> ok, so this is not a new regression in -4. 
> 
> If you 'yum downgrade gnome-shell' back to the orig release does it work? 
> Did it ever work on that machine? if so, when?

Yes, worked fine with version 3.0.2-1 .

But now, after downgrade to version 3.0.2-1 upper activity bar not seeing and Gnome3 session freezing.
Comment 25 Fedora Update System 2011-06-25 15:56:29 EDT
gnome-shell-3.0.2-4.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 26 gabe@codehaus.org 2011-06-25 23:41:20 EDT
I just recieved the -4 update from stable.

I have a Geforce Go 7300 (G72M) using the rpmfusion kmod-nvidia.

While I can now see gnome-shell on login (the top bar appears), it does not respond to the mouse or keyboard events. The mouse moves around just fine but the shell is frozen solid - the clock doesn't even move.

When I revert back to nouveau with -4, the shell now freezes immediately after login. I get a screen with wallpaper and a moving mouse, no more. -3 and earlier worked with nouveau to some extent, but were slow.

At this time I am using GNOME 3 in fallback mode with kmod-nvidia.
Comment 27 edo 2011-06-26 08:01:00 EDT
Created attachment 509957 [details]
xsession-errors file

xsession-errors file from starting Gnome Shell 3.0.2.-3
Comment 28 Tim Cuthbertson 2011-06-26 08:03:28 EDT
*** Bug 716669 has been marked as a duplicate of this bug. ***
Comment 29 Kevin Fenzi 2011-06-26 10:46:26 EDT
Gabe: If you make a new user and login as them does it work? If not, can you file a new bug on this?

edo: yes, thats the failure mode of -3 with the nvidia binary only driver. Thats what the -4 update should have fixed. Can you update to -4 and try making a new user and see if it works there? If not, can you file a new bug on this? 

Thanks.
Comment 30 edo 2011-06-30 11:53:16 EDT
Fresh new user doesn't works also.

Creating new bug:

https://bugzilla.redhat.com/show_bug.cgi?id=717994
Comment 31 Adam Williamson 2011-07-04 19:58:56 EDT
Just to note - I did a local build of gnome-shell 3.1.3 and it doesn't require this any more (in fact, the chrpath commands are now too long and cause the build to fail). so they should be dropped for 3.1.3 in rawhide, I think.