Bug 725259

Summary: nfs-utils-1.2.4-2.fc16 from rawhide refuses to start
Product: [Fedora] Fedora Reporter: Michal Jaegermann <michal>
Component: nfs-utilsAssignee: Steve Dickson <steved>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: bfields, jlayton, steved
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-08-03 07:11:43 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Michal Jaegermann 2011-07-24 15:55:45 EDT
Description of problem:

An attempt to enable nfs on the current rawhide results in the following:

kernel: [   42.872322] svc: failed to register nfsdv2 RPC service (errno 111).
kernel: [   42.905873] svc: failed to register nfsaclv2 RPC service (errno 111).
kernel: [   42.939476] nfsd: last server has exited, flushing export cache
kernel: [   43.012038] svc: failed to register nfsdv2 RPC service (errno 97).
kernel: [   43.012043] svc: failed to register nfsaclv2 RPC service (errno 97).
kernel: [   43.012058] nfsd: last server has exited, flushing export cache
systemd[1]: nfs.service: control process exited, code=exited status=1
systemd[1]: Unit nfs.service entered failed state.

'systemctl status nfs.service' is not much more illuminating:

nfs.service - LSB: Start up the NFS server sevice
          Loaded: loaded (/etc/rc.d/init.d/nfs)
          Active: failed since Sun, 24 Jul 2011 13:11:14 -0600; 38min ago
         Process: 1202 ExecStart=/etc/rc.d/init.d/nfs start (code=exited, status=1/FAILURE)
          CGroup: name=systemd:/system/nfs.service

Version-Release number of selected component (if applicable):
nfs-utils-1.2.4-2.fc16
kernel-3.0.0-1.fc16.x86_64

Additional info:

I cannot really tell when this service started to fail.  It worked in the past but it was not enabled on my test system for quite a while.  I tried to enable it to see what it will happen when I noticed that nfslock reported failures
(cf. bug 722795).
Comment 1 Steve Dickson 2011-07-28 15:37:18 EDT
I bet this has to with changes I made to rpcbind.... 
I converted rpcbind to use systemd but not nfs-utils...

nfslock or nfs is being started before rpcbind...
Comment 2 Steve Dickson 2011-08-03 07:11:43 EDT

*** This bug has been marked as a duplicate of bug 699040 ***