Bug 722795 - Doesn't start in Rawhide
Doesn't start in Rawhide
Status: CLOSED DUPLICATE of bug 699040
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-17 17:18 EDT by Matěj Cepl
Modified: 2011-08-03 07:11 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-03 07:11:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2011-07-17 17:18:37 EDT
Description of problem:
After upgrade to Rawhide nfslock doesn't start:

bradford:~# systemctl status nfslock.service
nfslock.service - LSB: Start up the NFS file locking sevice
	  Loaded: loaded (/etc/rc.d/init.d/nfslock)
	  Active: failed since Sun, 17 Jul 2011 23:16:20 +0200; 3s ago
	 Process: 2523 ExecStart=/etc/rc.d/init.d/nfslock start (code=exited, status=1/FAILURE)
	  CGroup: name=systemd:/system/nfslock.service
bradford:~# tail /var/log/messages
Jul 17 23:15:41 bradford NetworkManager[1049]: <info>   nameserver '192.168.1.13'
Jul 17 23:15:41 bradford dbus[1079]: [system] Activating service name='org.freedesktop.nm_dispatcher' (using servicehelper)
Jul 17 23:15:41 bradford dbus[1079]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'
Jul 17 23:15:43 bradford nm-dispatcher.action: Script '/etc/NetworkManager/dispatcher.d/90-ipv6-tunnel' exited with error status 127.
Jul 17 23:15:43 bradford NMdispatch-dnsmasq: INTERFACE=wlan0, UPDOWN=dhcp4-change
Jul 17 23:16:20 bradford rpc.statd[2537]: Version 1.2.4 starting
Jul 17 23:16:20 bradford sm-notify[2538]: Version 1.2.4 starting
Jul 17 23:16:20 bradford rpc.statd[2537]: failed to create RPC listeners, exiting
Jul 17 23:16:20 bradford systemd[1]: nfslock.service: control process exited, code=exited status=1
Jul 17 23:16:20 bradford systemd[1]: Unit nfslock.service entered failed state.
bradford:~# 

Version:
nfs-utils-1.2.4-2.fc16.x86_64
Comment 1 Michal Jaegermann 2011-07-24 15:43:28 EDT
Checking 'systemctl status nfslock.service' shows that this tries to run:
...
Process: 1211 ExecStart=/etc/rc.d/init.d/nfslock start ...
...
and fails.  OTOH tracing '/etc/rc.d/init.d/nfslock start' one can see that
sourcing from that file /etc/rc.d/init.d/functions results in an attempt to run 'systemctl_redirect /etc/init.d/nfslock start' which ends up with a circular run of '/bin/systemctl start nfslock.service' and we are back when we started.

It seems to me that this is very unlikely to run.
Comment 2 Lennart Poettering 2011-07-28 09:35:04 EDT
Michal: we actually guard against that and forward things to systemctl only if the PPID is not 1. So this is not the explanation here.
Comment 3 Michal Jaegermann 2011-07-28 10:04:39 EDT
(In reply to comment #2)

> ... and forward things to systemctl only if the PPID is not 1.

I am not entirely sure what is "the PPID" but we are not running here init so it will be not 1.

>  So this is not the explanation here.

In such case maybe this is related to bug 725259?  In the current rawhide attempts to start NFS just failed.  Yes, I know that nfslock should be able to run independently.
Comment 4 Matěj Cepl 2011-07-28 14:28:13 EDT
(In reply to comment #3)
> I am not entirely sure what is "the PPID" but we are not running here init so
> it will be not 1.

Parent PID. Every process (aside from process 1) has some parent.
Comment 5 Steve Dickson 2011-07-28 15:36:31 EDT
Hmm... I bet this has to with changes I made to rpcbind.... 
I converted rpcbind to use systemd but not nfs-utils...
Comment 6 Zdenek Kabelac 2011-07-29 11:38:48 EDT
I've started manually 

systemctl start rpcbind.service

systemctl restart nfs.service 

And it now works for me.
Comment 7 Steve Dickson 2011-07-29 11:51:00 EDT
(In reply to comment #6)
> I've started manually 
> 
> systemctl start rpcbind.service
> 
> systemctl restart nfs.service 
> 
> And it now works for me.

Ok... thanks for verifying that... I'm working
on the nfs-utils conversion atm...
Comment 8 Michal Jaegermann 2011-07-29 19:28:06 EDT
(In reply to comment #6)
> I've started manually 
> 
> systemctl start rpcbind.service
> 
> systemctl restart nfs.service 


That looks like pertinent to bug 725259 and not that one which was about nfslock. :-)  But indeed nfslock requires at least rpc.statd and starting rpcbind.service seems to help in case of nfslock.service too.  OTOH NFS would like to see rpc.mountd and rpc.rquotad running (and not necessarily rpc.statd, right?).
Comment 9 Steve Dickson 2011-08-03 07:11:35 EDT

*** This bug has been marked as a duplicate of bug 699040 ***

Note You need to log in before you can comment on or make changes to this bug.