This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 728193

Summary: preupgrade cannot retrieve repomd.xml
Product: [Fedora] Fedora Reporter: Hongqing Yang <hoyang>
Component: preupgradeAssignee: Kevin Fenzi <kevin>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 16CC: awilliam, birger, cpatrick08, jdulaney, john.ellson, jonathan, mattia.verga, richard, rmarko, tflink, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: AcceptedBlocker
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-09-13 21:45:41 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 713564    
Attachments:
Description Flags
preupgrade releases.txt none

Description Hongqing Yang 2011-08-04 06:49:54 EDT
Created attachment 516683 [details]
preupgrade releases.txt

Description of problem:
configure releases.txt as attachment, preupgrade from f14 to f16, the error occurs:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. install f14 i386
2. configure releases.txt
3. preupgrade
  
Actual results:


Expected results:


Additional info:
Comment 1 Hongqing Yang 2011-08-04 06:51:38 EDT
The error messages as below:

loaded plugins: blacklist, langpacks, whiteout
No plugin match for: rpm-warm-cache
No plugin match for: remove-with-leaves
No plugin match for: auto-update-debuginfo
Adding en_US to language list
preupgrade-main (baseurl)
  url: http://download.englab.nay.redhat.com/pub/fedora/linux/development/16/i386/os/
  now: http://download.englab.nay.redhat.com/pub/fedora/linux/development/16/i386/os/
preupgrade (baseurl)
  url: http://dl.fedoraproject.org/pub/alt/stage/16-Alpha.TC1/Fedora/i386/os/
  now: http://dl.fedoraproject.org/pub/alt/stage/16-Alpha.TC1/Fedora/i386/os/
unknown metadata being downloaded: repomdq9xNmOtmp.xml
unknown metadata being downloaded: MEMORY
Fetched treeinfo from http://dl.fedoraproject.org/pub/alt/stage/16-Alpha.TC1/Fedora/i386/os//.treeinfo
treeinfo timestamp: Mon Aug  1 18:02:11 2011
/boot/upgrade/vmlinuz checksum OK
/boot/upgrade/initrd.img checksum OK
Downloading 0.0bytes
Upgrade requires 500.0MB
Available disk space for /usr: 2.5GB
Kernel requires 26.0MB
Available disk space for /boot: 304.8MB
Traceback (most recent call last):
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 259, in on_assistant_apply
    self._do_main()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 278, in _do_main
    self.main_preupgrade()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 576, in main_preupgrade
    comps = self.pu.instrepo.retrieveMD("group")
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1511, in retrieveMD
    return self._retrieveMD(mdtype)
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1519, in _retrieveMD
    thisdata = self.repoXML.getData(mdtype)
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1413, in <lambda>
    repoXML = property(fget=lambda self: self._getRepoXML(),
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1409, in _getRepoXML
    raise Errors.RepoError, msg
yum.Errors.RepoError: Cannot retrieve repository metadata (repomd.xml) for repository: preupgrade. Please verify its path and try again
Comment 2 Chris Lumens 2011-08-04 09:52:26 EDT
Please file preupgrade bugs against preupgrade.
Comment 3 Hongqing Yang 2011-08-05 03:15:34 EDT
after I install the following plugins
rpm-warm-cache
remove-with-leaves
auto-update-debuginfo

run preupgrade - /releases.txt
it still looks for the mirrorlist instead of the baseurl and installurl specified in releases.txt
Comment 4 Hongqing Yang 2011-08-06 03:57:57 EDT
reproduced on f16-alpha-rc1
Comment 5 Hongqing Yang 2011-08-10 05:49:25 EDT
reproduced on f16-alpha-rc3
It should be Beta Blocker according article:

9. The installer must be able to successfully complete an upgrade installation from a clean, fully updated default installation (from any official install medium) of the previous stable Fedora release, either via preupgrade or by booting to the installer manually. The upgraded system must meet all release criteria
Comment 6 John Dulaney 2011-08-29 11:21:52 EDT
This should be fixed as of a week ago.
Comment 7 Hongqing Yang 2011-09-01 03:55:27 EDT
fixed in f15-beta-tc1
Comment 8 Tim Flink 2011-09-01 13:41:51 EDT
Discussed in the 2011-08-26 blocker review meeting. If this affected 15 -> 16 preupgrade, it will be accepted as a Fedora 16 beta blocker bug. If this only affects 14 -> 16 preupgrade, it will be accepted as NTH since that isn't explicitly covered in the beta release criteria [1].

Does this affect 15 -> 16 preupgrade or just 14 -> 16?

At this point, the question may be pointless as it appears to have been fixed.

[1] https://fedoraproject.org/wiki/Fedora_16_Beta_Release_Criteria
Comment 9 John Ellson 2011-09-01 16:12:29 EDT
It maybe fixed upstream, but I don't understand where the fix went, or what package it will show up in, and 15 -> 16 preupgrade still doesn't work for me.

There are no recent upgrades to preupgrade in koji.  (last was in March)

I support that this (or its related preupgrade bugs: #735016, #727832 I think) are fc16 blockers.
Comment 10 John Dulaney 2011-09-02 13:53:26 EDT
I just tested it again; it is still working for F15->F16 Preupgrade.
Comment 11 John Ellson 2011-09-02 14:23:41 EDT
Doesn't work for me on a fully update fc15   (not using updates-testing.  is that the issue?)

I get:

[root@halfpint ~]# preupgrade-cli "Fedora 16 (Verne)"
Loaded plugins: blacklist, langpacks, whiteout
No plugin match for: rpm-warm-cache
No plugin match for: remove-with-leaves
Loaded plugins: auto-update-debuginfo, langpacks, presto, refresh-packagekit
preupgrade-main (mirrorlist) 
  url: http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-16&arch=x86_64
  now: http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-16&arch=x86_64
preupgrade (mirrorlist) 
  url: http://mirrors.fedoraproject.org/mirrorlist?path=pub/fedora/linux/development/16/Fedora/x86_64/os/
  now: http://mirrors.fedoraproject.org/mirrorlist?path=pub/fedora/linux/development/16/Fedora/x86_64/os/
Error: Cannot find a valid baseurl for repo: preupgrade

This could be caused by a missing network connection or a bad mirror.
[root@halfpint ~]#
Comment 12 Adam Williamson 2011-09-02 14:31:20 EDT
Discussed at 2011-09-02 blocker review meeting. Accepted as a blocker per criterion "The installer must be able to successfully complete an upgrade installation from a clean, fully updated default installation (from any official install medium) of the previous stable Fedora release, either via preupgrade or by booting to the installer manually. The upgraded system must meet all release criteria". Anyone know why John E. isn't seeing the fix?
Comment 13 John Ellson 2011-09-02 16:20:17 EDT
What exactly has been fixed?  Should I be looking for a new release of preupgrade-*.fc15 ???    Still nothing new in koji.
Comment 14 John Dulaney 2011-09-03 11:52:18 EDT
What was fixed is a file on one of Infrastructure's servers that points to the mirrors from which you download the update.

preupgrade AND preupgrade-cli are both working fine for me.
Comment 15 John Dulaney 2011-09-03 11:53:14 EDT
Addition:
Preupgrade and Preupgrade-cli are both working as of five minutes prior to writing the previous post.
Comment 16 John Ellson 2011-09-03 16:17:41 EDT
Still not working here.  Is something getting cached that I need to clear?   Preupgrade seems to leave files all over the place!  I've tried:
   rm -rf /root/preupgrade*
   rm -rf /var/cache/yum/preupgrade*
   rm -rf /etc/yum.repos.d/preupgrade*
   yum clean all
   yum update
   yum reinstall preupgrade
   
then:

# preupgrade-cli "Fedora 16 (Verne)"
Loaded plugins: blacklist, langpacks, whiteout
No plugin match for: rpm-warm-cache
No plugin match for: remove-with-leaves
Loaded plugins: auto-update-debuginfo, langpacks, presto, refresh-packagekit
preupgrade-main (mirrorlist) 
  url: http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-16&arch=$basearch
  now: http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-16&arch=x86_64
preupgrade (mirrorlist) 
  url: http://mirrors.fedoraproject.org/mirrorlist?path=pub/fedora/linux/development/16/Fedora/$basearch/os/
  now: http://mirrors.fedoraproject.org/mirrorlist?path=pub/fedora/linux/development/16/Fedora/x86_64/os/
Error: Cannot find a valid baseurl for repo: preupgrade

This could be caused by a missing network connection or a bad mirror.
# 


Can anyone outside Redhat see the "file on one of Infrastructure's servers" ?
Comment 17 John Ellson 2011-09-04 12:43:43 EDT
I'm still trying this on two different fully updated fc15 machines, in two well separated networks (one at work, the other at home), and neither works for me.   See above.

I double checked that I do *not* have a local releases.txt.  Is that how others are getting this to work?
Comment 18 John Dulaney 2011-09-04 14:15:00 EDT
The releases.txt file is not local.  I'll get up with nirik at some point.
Comment 19 Hongqing Yang 2011-09-04 21:14:13 EDT
(In reply to comment #18)
> The releases.txt file is not local.  I'll get up with nirik at some point.

we can download releases.txt to local and point to it as preupgrade - /path/to/releases.txt
but the mirror is still not correct at http://mirrors.fedoraproject.org/releases.txt
after correcting the path, it works fine.

mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-16&arch=$basearch
installmirrorlist=http://mirrors.fedoraproject.org/mirrorlist?path=pub/fedora/linux/development/16/Fedora/$basearch/os/

at least in the development branch, no 'Fedora' after 16, it should be like
installmirrorlist=http://mirrors.fedoraproject.org/mirrorlist?path=pub/fedora/linux/development/16/$basearch/os/
Comment 20 birger 2011-09-07 15:17:57 EDT
This is what I get when running preupgrade on a freshly installed f15 workstation (+ some extra repos and packages)

# preupgrade
Loaded plugins: blacklist, langpacks, whiteout
No plugin match for: rpm-warm-cache
No plugin match for: remove-with-leaves
No plugin match for: auto-update-debuginfo
preupgrade-main (mirrorlist) 
  url: http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-16&arch=$basearch
  now: http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-16&arch=x86_64
preupgrade (mirrorlist) 
  url: http://mirrors.fedoraproject.org/mirrorlist?path=pub/fedora/linux/development/16/Fedora/$basearch/os/
  now: http://mirrors.fedoraproject.org/mirrorlist?path=pub/fedora/linux/development/16/Fedora/x86_64/os/
unknown metadata being downloaded: repomdvFDX15tmp.xml
Cannot find a valid baseurl for repo: preupgrade
Comment 21 birger 2011-09-07 16:10:23 EDT
preupgrade looks in the current directory for releases.txt before going to mirrors.fedoraproject.org.

To get around this bug, download the file from
http://mirrors.fedoraproject.org/releases.txt
saving it as releases.txt, edit it (change '16/Fedora' to '16') and then run preupgrade from the directory where the file is.
Comment 22 John Ellson 2011-09-07 16:17:57 EDT
Please can we have a fix instead of a workaround ?   You can't expect people to look through bugzilla before they can upgrade their systems.
Comment 23 Adam Williamson 2011-09-07 17:26:52 EDT
nirik (Kevin Fenzi) says he's updated the releases.txt file, but it hasn't yet propagated out to the public server. this should happen soon, though.
Comment 24 Adam Williamson 2011-09-07 17:33:03 EDT
note that the fix kevin put in was this:

-installmirrorlist=http://mirrors.fedoraproject.org/mirrorlist?path=pub/fedora/linux/development/16/Fedora/$basearch/os/
+installmirrorlist=http://mirrors.fedoraproject.org/mirrorlist?path=pub/fedora/linux/releases/test/16-Alpha/Fedora/$basearch/os/

which I'm not sure is correct, as it points to a frozen Alpha tree, not the latest F16 tree. But Kevin thinks preupgrade needs an installable tree. We're not entirely sure what's correct here; if Will or Richard could advise, that would help.

Have those of you who 'fixed' this by using http://mirrors.fedoraproject.org/mirrorlist?path=pub/fedora/linux/development/16/$basearch/os/ verified that preupgrade actually completes successfully after that change?
Comment 25 birger 2011-09-07 19:18:04 EDT
It downloads everything and creates the grub entry. Upon reboot it fails with dracut errors. I think I saw some error about a busy loop device scrolling off my screen. Perhaps that was the root cause for the dracut messages.

I can investigate more tomorrow.
Comment 26 birger 2011-09-09 03:37:30 EDT
yesterday preupgrade worked flawlessly!

Well. You didn't really believe that, did you? At least it did the upgrade job. Some weird artifacts, but this bug is definitely fixed now.

The primary problem I see is that brasero and tuxpaint icons are present in all categories in gnome-shell. In the categories I expect to find them I see them twice. Only one rpm of each installed as far as I can see. Not this bug, so I'll search bugzilla for a resolution.
Comment 27 Richard Marko 2011-09-09 10:35:30 EDT
*** Bug 728659 has been marked as a duplicate of this bug. ***
Comment 28 Richard Marko 2011-09-09 10:47:21 EDT
Doesn't work for me.


# preupgrade-cli "Fedora 16 (Verne)"
Loaded plugins: blacklist, fastestmirror, langpacks, whiteout
No plugin match for: rpm-warm-cache
No plugin match for: remove-with-leaves
No plugin match for: auto-update-debuginfo
Loaded plugins: fastestmirror, langpacks, presto, refresh-packagekit
preupgrade-main (mirrorlist) 
  url: http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-16&arch=$basearch
  now: http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-16&arch=x86_64

// other installed mirrors here

preupgrade (mirrorlist) 
  url: http://mirrors.fedoraproject.org/mirrorlist?path=pub/fedora/linux/development/16/Fedora/$basearch/os/
  now: http://mirrors.fedoraproject.org/mirrorlist?path=pub/fedora/linux/development/16/Fedora/x86_64/os/
Checking for new repos for mirrors
 * preupgrade-main: mirrors.ircam.fr
Error: Cannot find a valid baseurl for repo: preupgrade

This could be caused by a missing network connection or a bad mirror.

---
This links points to invalid location:
http://mirrors.fedoraproject.org/mirrorlist?path=pub/fedora/linux/development/16/Fedora/x86_64/os/

Should probably reed:
http://mirrors.fedoraproject.org/mirrorlist?path=pub/fedora/linux/development/16/x86_64/os/
Comment 29 Adam Williamson 2011-09-09 17:09:52 EDT
Richard: that's all already discussed in this bug, the file has already been changed, but the change has not yet propagated to the public mirror, apparently.
Comment 30 Adam Williamson 2011-09-12 20:38:01 EDT
So, nirik has gone with the change proposed in the bug, now, and releases.txt will point to /development/16 when it's updated, not the Alpha tree. I've tested today that a preupgrade using this releases.txt worked, modulo https://bugzilla.redhat.com/show_bug.cgi?id=737731 .
Comment 31 Adam Williamson 2011-09-13 21:45:41 EDT
the change has gone out to https://mirrors.fedoraproject.org/releases.txt now, so I believe we can close this.