Bug 729049

Summary: SELinux is preventing /usr/sbin/lircd from 'getattr' accesses on the file /sys/devices/pci0000:00/0000:00:1d.0/usb5/5-1/busnum.
Product: [Fedora] Fedora Reporter: Jan Willies <jan>
Component: selinux-policyAssignee: Miroslav Grepl <mgrepl>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 15CC: dominick.grift, dwalsh, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: setroubleshoot_trace_hash:aa75f683333c398adadafc47e977365f2f052c50aaefec126f62eebbc380f246
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-08-08 15:34:53 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jan Willies 2011-08-08 15:25:22 UTC
SELinux is preventing /usr/sbin/lircd from 'getattr' accesses on the file /sys/devices/pci0000:00/0000:00:1d.0/usb5/5-1/busnum.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that lircd should be allowed getattr access on the busnum file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep lircd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:lircd_t:s0
Target Context                system_u:object_r:sysfs_t:s0
Target Objects                /sys/devices/pci0000:00/0000:00:1d.0/usb5/5-1/busn
                              um [ file ]
Source                        lircd
Source Path                   /usr/sbin/lircd
Port                          <Unbekannt>
Host                          (removed)
Source RPM Packages           lirc-0.9.0-7.fc15
Target RPM Packages           
Policy RPM                    selinux-policy-3.9.16-35.fc15
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 2.6.40-4.fc15.x86_64 #1 SMP Fri Jul
                              29 18:46:53 UTC 2011 x86_64 x86_64
Alert Count                   41
First Seen                    Mo 08 Aug 2011 17:23:12 CEST
Last Seen                     Mo 08 Aug 2011 17:23:13 CEST
Local ID                      2748ae9c-1664-4f51-8afd-ec5ae0287213

Raw Audit Messages
type=AVC msg=audit(1312816993.426:817): avc:  denied  { getattr } for  pid=1065 comm="lircd" path="/sys/devices/pci0000:00/0000:00:1d.0/usb5/5-1/busnum" dev=sysfs ino=21037 scontext=system_u:system_r:lircd_t:s0 tcontext=system_u:object_r:sysfs_t:s0 tclass=file


type=SYSCALL msg=audit(1312816993.426:817): arch=x86_64 syscall=fstat success=no exit=EACCES a0=13 a1=7fffea4265c0 a2=7fffea4265c0 a3=34aca0a5c9 items=0 ppid=1 pid=1065 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=lircd exe=/usr/sbin/lircd subj=system_u:system_r:lircd_t:s0 key=(null)

Hash: lircd,lircd_t,sysfs_t,file,getattr

audit2allow

#============= lircd_t ==============
allow lircd_t sysfs_t:file getattr;

audit2allow -R

#============= lircd_t ==============
allow lircd_t sysfs_t:file getattr;

Comment 1 Daniel Walsh 2011-08-08 15:34:53 UTC

*** This bug has been marked as a duplicate of bug 728994 ***