This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 73026

Summary: gnome classic theme doesn't cover default panel icons
Product: [Retired] Red Hat Linux Reporter: Scott Russell <bugzilla>
Component: redhat-artworkAssignee: Havoc Pennington <hp>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0CC: garrett
Target Milestone: ---Keywords: MoveUpstream, Triaged
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 13:49:32 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Scott Russell 2002-08-29 20:40:50 EDT
Description of Problem:

Open Office icons differ in style. Draw, Math, and Printer don't match new
BlueCurve icon style.this is viewed from the default gnome desktop.

Version-Release number of selected component (if applicable):

redhat-artwork-0.39-1

How Reproducible:

100%

Steps to Reproduce:
1. Install null
2. update to current rawhide artwork
3. look at menus

Expected Results:

Make Open Office icons all match in style. It's quite confusing to lack a
centeral theme and style among icons that are related.

Additional Information:
	
There is alos no way to restore the default Open Office icons. The hacked in
versions remain in place even after removing the bluecurve icon theme in gconf
Comment 1 Havoc Pennington 2002-08-29 20:56:21 EDT
They look fairly similar to me?

The default icon theme doesn't have replacements for the icon filenames used for
those launchers. You can right click and manually change back, or you can 
create an icon theme that does provide icons for those names.
Comment 2 Scott Russell 2002-08-30 23:29:53 EDT
Um, no. Some are stock OO icons. Others are Red Hat enhanced icons. At least
that's what I'm seeing with redhat-artwork-0.39.1.

The original set of OO icons have a consistant look and theme that defines them
as all related in some way. (In this case all belonging to the OO suite.) Red
Hat has replaced some of the OO icons iwth it's own stylized versions. Even
those replaced icons are similar in artwork and colors. Again, this provides a
'visual connection' between the related icons.

The problem is that the icons I specify above retain the OO art while the rest
of the icons use the new Red Hat style art. They should all be one way or the
other, not mixed up. They also should all relate to each other in some way. That
can be done by using similar colors, themes, or emblems on the icon.


As for not being able to restore the original icon when setting icon_theme, it
just plain looks like a bug. From the point of view I'm looking at:

1) Remove icon_theme to get stock app and gnome2 icons back
2) huh, some didn't revert.
3) That's not expected behavior. Expected behavior is for all app and gnome2     
   icons to return to pkg defaults.


I understand the technical reason you offer but it still needs a fix. All apps
and gnome2 icons _should_ be able to return to their pkg defaults by undefining
icon_theme.
Comment 3 Havoc Pennington 2003-01-08 16:57:38 EST
The upstream GNOME icon theme should be modified to cover 
openoffice icons. Will file a gnome.org report to draw the missing ones, 
and copy the ones we have such as Evolution to new names.

For the style of the Bluecurve icons, that's up to garrett
whether he wants to change them; he doesn't really use bugzilla to track 
tasks though so I'm going to consider this bug just the
technical part (adding "classic gnome" icons for openoffice)
Comment 4 Havoc Pennington 2003-01-08 17:04:00 EST

*** This bug has been marked as a duplicate of 73029 ***
Comment 5 Red Hat Bugzilla 2006-02-21 13:49:32 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.