Bug 73029 - Default icon theme contains some Bluecurve icons, not just GNOME-style icons
Default icon theme contains some Bluecurve icons, not just GNOME-style icons
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-artwork (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
: Triaged
: 73026 74999 (view as bug list)
Depends On:
Blocks: 79578
  Show dependency treegraph
 
Reported: 2002-08-29 20:59 EDT by Scott Russell
Modified: 2008-05-01 11:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-17 16:44:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Russell 2002-08-29 20:59:00 EDT
Description of Problem:

Setting icon_theme to null in gconf does not restore all gnome2 icons and
application icons to their default values. This feature was discussed in a
previous bug.

Version-Release number of selected component (if applicable):

(null) + rehdat-artwork from rawhide

How Reproducible:

Always

Steps to Reproduce:
Use gonf to remove the bluecurve icon_theme value. Log out and then in to gnome2
desktop. Verify Mozilla and Open Office icons have not returned to their default
states.

Actual Results:

Mozilla and Open Office icons remain 'new age' bluecurve style icons

Expected Results:

Mozilla and Open Office should use their default icons.
Comment 1 Havoc Pennington 2002-10-01 14:41:46 EDT
The redhat-web-browser.png etc. icon names should use some gnome-looking icon
in the default theme, and the Bluecurve-style icon only in the Bluecurve theme.
Only problem here is when we do a new icon that is not present from upstream in 
gnome-looking form, there's not much to be done about that.
Comment 2 Havoc Pennington 2002-10-03 11:35:34 EDT
*** Bug 74999 has been marked as a duplicate of this bug. ***
Comment 3 Kenneth Rohde Christiansen 2002-10-03 12:10:45 EDT
My bug (just marked as duplicate) was not about seeing a few Bluecurvish icons.
I don't think Red Hat should be making GNOME quivalent icon to all of their
Bluecurvish icons. But since there exist menu folder icons that covers most if
not all of the menu folders used in Red Hat, then I think at least these should
be used in the GNOME/Default theme, and the redhat icons should "overwrite" them
when using Bluecurve.

From psyche mailing list

> The problem is as follows:
> 
>  - our "word processor" icon is added to the default icon theme
>    (/usr/share/pixmaps/redhat-word-processor.png) so it will be
>    available reliably and present in both gnome and kde
> 
>  - changing themes will only affect this icon if the new theme 
>    contains "redhat-word-processor.png"

why not call it openoffice-word-processor and then add the ximian
(jimmac-tigert/gnome style) openoffice icon to the gnome-icon-theme
theme in GNOME CVS?

If there is no available GNOMEish icon, then using the Bluecurve seems
like an okay choice.

But many of the menu folders used in Red Hat 8 has gnome equivalent
icon, which are not used in default. This seems like a real bug to me.
(Not that I care much as I am a happy Bluecurve user :) that theme just
rocks!)
Comment 4 Kenneth Rohde Christiansen 2002-10-03 12:21:07 EDT
GNOME-ism OpenOffice icons can be found here:

http://jimmac.musichall.cz/i.php3?ikony=59
Comment 5 Havoc Pennington 2002-10-03 12:41:40 EDT
Right, as I said in the email, the solution here will be to add GNOME and KDE
icon themes that contain icons by the same name as the one used by the panel
launchers and menu folders. I think your bug and this bug both have this solution, 
thus the duplicate.
Comment 6 Havoc Pennington 2002-10-03 12:49:17 EDT
Here is the mail for reference:

https://listman.redhat.com/pipermail/psyche-list/2002-October/000603.html
Comment 7 Havoc Pennington 2003-01-08 17:04:04 EST
*** Bug 73026 has been marked as a duplicate of this bug. ***
Comment 8 Havoc Pennington 2003-01-17 16:44:46 EST
I added symlinks for redhat-*.png to gnome-icon-theme 0.1.5-2
(you must set icon theme "gnome" not null).

Some icons still don't have gnome-icon-theme equivalents,
I can add more symlinks, but I can't draw gnome-style icons 
so don't bother asking unless you want something darn ugly. ;-)

http://bugzilla.gnome.org/show_bug.cgi?id=103778 remains, 
i.e. main menu icon will not track the theme.

Note You need to log in before you can comment on or make changes to this bug.