Bug 730758

Summary: ks fails to find ks file on nfs share
Product: Red Hat Enterprise Linux 6 Reporter: redhat <iain.morrison>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED DUPLICATE QA Contact: Release Test Team <release-test-team>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 6.1CC: rvykydal
Target Milestone: rc   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-08-16 07:56:16 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description redhat@mrc-epid.cam.ac.uk 2011-08-15 16:42:14 UTC
Description of problem:

When we kickstart a server with the ks file located on an NFS share, anaconda fails to find the file. [The same setup RHEL 4 dhcp server+NFS share works for RHEL 4 and 5.]

When the path is explicitly added on the command like, e.g. 

ks=nfs:a.b.c.d:/export/n_os/ks/e.f.g.h-kickstart

everything works.

in the dhcpd.conf file we have
 
         filename "/export/n_os/ks/";
         next-server A.B.C.D; 
 
 where A.B.C.D is the NFS host.



Version-Release number of selected component (if applicable):


How reproducible:

100%

Steps to Reproduce:
1. kickstart server
2. 
3.
  
Actual results:

09:24:29,540 INFO    : kernel command line: initrd=initrd.img ks ksdevice=eth2 BOOT_IMAGE=vmlinuz

09:24:29,540 DEBUG   : readNetInfo /tmp/s390net not found, early return
09:24:29,540 INFO    : anaconda version 13.21.117 on x86_64 starting
09:24:29,546 INFO    : 4055732 kB are available
09:24:32,736 DEBUG   : Saving module iscsi_ibft
09:24:32,736 DEBUG   : Saving module iscsi_boot_sysfs
09:24:32,736 DEBUG   : Saving module pcspkr
09:24:32,736 DEBUG   : Saving module edd
09:24:32,736 DEBUG   : Saving module mlx4_ib
09:24:32,736 DEBUG   : Saving module mlx4_en
09:24:32,736 DEBUG   : Saving module mlx4_core
09:24:32,736 DEBUG   : Saving module ib_ipoib
09:24:32,736 DEBUG   : Saving module ib_cm
09:24:32,736 DEBUG   : Saving module ib_sa
09:24:32,736 DEBUG   : Saving module ib_mad
09:24:32,736 DEBUG   : Saving module ib_core
09:24:32,736 DEBUG   : Saving module ipv6
09:24:32,736 DEBUG   : Saving module iscsi_tcp
09:24:32,736 DEBUG   : Saving module libiscsi_tcp
09:24:32,736 DEBUG   : Saving module libiscsi
09:24:32,736 DEBUG   : Saving module scsi_transport_iscsi
09:24:32,736 DEBUG   : Saving module squashfs
09:24:32,736 DEBUG   : Saving module cramfs
09:24:32,736 DEBUG   : probing buses
09:24:32,762 DEBUG   : waiting for hardware to initialize
09:24:36,480 INFO    : Trying to detect vendor driver discs
09:24:36,780 DEBUG   : probing buses
09:24:36,802 DEBUG   : waiting for hardware to initialize
09:24:38,277 INFO    : getting kickstart file
09:24:38,293 INFO    : doing kickstart... setting it up
09:24:38,293 DEBUG   : activating device eth2
09:24:45,305 INFO    : wait_for_iface_activation (2274): device eth2 activated
09:24:45,317 ERROR   : no bootserver was found

  - We entered the ks location here as it could not find it automatically

09:55:18,989 INFO    : url is A.B.C.D:/export/n_os/ks/E.F.G.H-kickstart
09:55:18,989 DEBUG   : parseNfsHostPathOpts url: |A.B.C.D:/export/n_os/ks/E.F.G.H-kickstart|
09:55:18,989 DEBUG   : parseNfsHostPathOpts host: |A.B.C.D|
09:55:18,989 DEBUG   : parseNfsHostPathOpts path: |/export/n_os/ks/E.F.G.H-kickstart|
09:55:18,989 DEBUG   : parseNfsHostPathOpts opts: |(null)|
09:55:18,989 INFO    : file location: nfs:A.B.C.D:/export/n_os/ks/E.F.G.H-kickstart
09:55:19,158 DEBUG   : marking first kickstart network command
09:55:19,158 INFO    : setting up kickstart
09:55:19,158 INFO    : kickstartFromNfs
09:55:19,158 INFO    : results of nfs, host is A.B.C.D, dir is /export/n_os/RHEL/Server/6.0, opts are '(null)'
09:55:19,158 INFO    : kickstart network command - device eth2
09:55:19,158 INFO    : activating first device from kickstart because network is needed
09:55:19,169 INFO    : device eth2 is already activated
09:55:19,169 INFO    : disconnecting device eth2
09:55:21,178 INFO    : wait_for_iface_disconnection (2351): device eth2 disconnected


Expected results:


Additional info:

Comment from Chris Lumens

Sent: 15 August 2011 15:33
To: kickstart-list@redhat.com
Subject: Re: ks file not found via dhcp

> 09:24:38,293 DEBUG   : activating device eth2
> 09:24:45,305 INFO    : wait_for_iface_activation (2274): device eth2
> activated
> 09:24:45,317 ERROR   : no bootserver was found

That's the problem right there.  This is printed out in the
getFileFromNfs function, specifically in the path of looking for the
implicit kickstart file location.  It means the following is failing:

            server_name = nm_dhcp4_config_get_one_option(dhcp, "server_name");
            if (!server_name) {
                logMessage(ERROR, "no bootserver was found");
                g_object_unref(client);
                return 1;
            }

I wonder if that DHCP option even exists, or if this is a problem with the NM
bindings, or what.  Could you file a bug about this?

Comment 1 redhat@mrc-epid.cam.ac.uk 2011-08-15 16:43:07 UTC
Problem exists in RHEL 6 and 6.1

Comment 3 Radek Vykydal 2011-08-16 07:56:16 UTC

*** This bug has been marked as a duplicate of bug 727874 ***