Bug 733789

Summary: Issue building el6 packages on el5 (CentOS 5.6) server
Product: [Fedora] Fedora Reporter: Jim Goddard <monkeys.typing>
Component: mockAssignee: Clark Williams <williams>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 16CC: mebrown, williams, yury
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-09-23 18:16:25 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jim Goddard 2011-08-26 21:15:23 UTC
Description of problem:
Attempting to use Mock Version: 1.0.19 on CentOS 5.6 (cr) to build an el6
version of rsyslog-5.8.4

the yum install of the chroot environment fails with a dependency check:
ERROR: Command failed: 
 # ['/usr/bin/yum', '--installroot', '/var/lib/mock/epel-6-x86_64/root/',
'groupinstall', 'buildsys-build'
<snip>
ERROR with rpm_check_debug vs depsolve:
rpmlib(FileDigests) is needed by elfutils-0.148-1.el6.x86_64
rpmlib(PayloadIsXz) is needed by elfutils-0.148-1.el6.x86_64
rpmlib(FileDigests) is needed by hwdata-0.233-1.el6.noarch
rpmlib(PayloadIsXz) is needed by hwdata-0.233-1.el6.noarch
<snip>

Doesn't matter if I pick i386 or x86_64 configs, I get the same error.  Same
server builds el5 packages just fine using mock. Similarly a CentOS6 x86_64 box
can successfully build el6 & el5 packages for either arch. CentOS6 box is
running Mock Version 1.1.12

Version-Release number of selected component (if applicable):
Mock Version: 1.0.19

How reproducible:
every time

Steps to Reproduce:
1. download or build srpm
2. mock -r epel-6-i386 --rebuild ~/rpm/SRPMS/rsyslog-5.8.4.src.rpm
3. error occurs

Actual results:
ERROR: Command failed: 
 # ['/usr/bin/yum', '--installroot', '/var/lib/mock/epel-6-x86_64/root/',
'groupinstall', 'buildsys-build'
<snip>
ERROR with rpm_check_debug vs depsolve:
rpmlib(FileDigests) is needed by elfutils-0.148-1.el6.x86_64
rpmlib(PayloadIsXz) is needed by elfutils-0.148-1.el6.x86_64
rpmlib(FileDigests) is needed by hwdata-0.233-1.el6.noarch
rpmlib(PayloadIsXz) is needed by hwdata-0.233-1.el6.noarch


Expected results:
el6 version of package is built

Additional info:
Accidentally submitted bug https://bugzilla.redhat.com/show_bug.cgi?id=733768 against yum for this issue.

Comment 1 Yury V. Zaytsev 2011-09-21 16:05:50 UTC
I think this bug against mock should be closed as invalid / wontfix, because this issue does not relate directly to mock and not something that can be fixed within mock.

If you want to build RHEL6 packages on a RHEL5 system, you need to install a patched version of rpm from Fedora Infrastructure repositories that supports XZ payloads and SHA hashes (at least until this functionality is officially implemented in RHEL5, which may or may not happen, open a support request with RH if you think that it's an important issue).

See the following bugs for reference:

https://bugzilla.redhat.com/show_bug.cgi?id=490613
https://bugzilla.redhat.com/show_bug.cgi?id=620674

Z.

Comment 2 Clark Williams 2011-09-23 18:16:25 UTC
(In reply to comment #1)
> I think this bug against mock should be closed as invalid / wontfix, because
> this issue does not relate directly to mock and not something that can be fixed
> within mock.
> 
> If you want to build RHEL6 packages on a RHEL5 system, you need to install a
> patched version of rpm from Fedora Infrastructure repositories that supports XZ
> payloads and SHA hashes (at least until this functionality is officially
> implemented in RHEL5, which may or may not happen, open a support request with
> RH if you think that it's an important issue).
> 
> See the following bugs for reference:
> 
> https://bugzilla.redhat.com/show_bug.cgi?id=490613
> https://bugzilla.redhat.com/show_bug.cgi?id=620674
> 
> Z.

Agreed, this is not something we can address via mock.