This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 733768 - Issue building CentOS/EPEL 6 packages on CentOS/RHEL 5 server
Issue building CentOS/EPEL 6 packages on CentOS/RHEL 5 server
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum (Show other bugs)
5.6
x86_64 Linux
unspecified Severity low
: rc
: ---
Assigned To: James Antill
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-26 15:00 EDT by Jim Goddard
Modified: 2014-01-21 01:24 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-26 18:02:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jim Goddard 2011-08-26 15:00:38 EDT
Description of problem:
Attempting to use Mock Version: 1.0.19 on CentOS 5.6 (cr) to build an el6 version of rsyslog-5.8.4

the yum install of the chroot environment fails with a dependency check:
ERROR: Command failed: 
 # ['/usr/bin/yum', '--installroot', '/var/lib/mock/epel-6-x86_64/root/', 'groupinstall', 'buildsys-build'
<snip>
ERROR with rpm_check_debug vs depsolve:
rpmlib(FileDigests) is needed by elfutils-0.148-1.el6.x86_64
rpmlib(PayloadIsXz) is needed by elfutils-0.148-1.el6.x86_64
rpmlib(FileDigests) is needed by hwdata-0.233-1.el6.noarch
rpmlib(PayloadIsXz) is needed by hwdata-0.233-1.el6.noarch
<snip>

Doesn't matter if I pick i386 or x86_64 configs, I get the same error.  Same server builds el5 packages just fine using mock. Similarly a CentOS6 x86_64 box can successfully build el6 & el5 packages for either arch. CentOS6 box is running Mock Version 1.1.12

Version-Release number of selected component (if applicable):
Mock Version: 1.0.19

How reproducible:
every time

Steps to Reproduce:
1. download or build srpm
2. mock -r epel-6-i386 --rebuild ~/rpm/SRPMS/rsyslog-5.8.4.src.rpm
3. error occurs
  
Actual results:
ERROR: Command failed: 
 # ['/usr/bin/yum', '--installroot', '/var/lib/mock/epel-6-x86_64/root/', 'groupinstall', 'buildsys-build'
<snip>
ERROR with rpm_check_debug vs depsolve:
rpmlib(FileDigests) is needed by elfutils-0.148-1.el6.x86_64
rpmlib(PayloadIsXz) is needed by elfutils-0.148-1.el6.x86_64
rpmlib(FileDigests) is needed by hwdata-0.233-1.el6.noarch
rpmlib(PayloadIsXz) is needed by hwdata-0.233-1.el6.noarch


Expected results:
el6 version of package is built

Additional info:
Comment 1 Jim Goddard 2011-08-26 17:18:17 EDT
This issue is more accurately attached to the mock package, and as such this can/should be closed, unless it turns out to be an issue with yum after all, which is unlikely.
Comment 2 James Antill 2011-08-26 18:02:08 EDT
 As the message says, the problem is that the rpms you are operating with use features that aren't available in the version of rpm that ships with RHEL-5 (sha256 checksums and xz compression).
 You will have similar problems with the yum code needing python-hashlib to access RHEL-6 repos.

Note You need to log in before you can comment on or make changes to this bug.