Bug 734201

Summary: hd6450 caicos | gpu lockup
Product: [Fedora] Fedora Reporter: Nicolas Mailhot <nicolas.mailhot>
Component: xorg-x11-drv-atiAssignee: Jérôme Glisse <jglisse>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: rawhideCC: gansalmon, itamar, jglisse, jonathan, kernel-maint, madhu.chinakonda, xgl-maint
Target Milestone: ---Keywords: Patch, Triaged
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:99661fca130f27b1f7d5e41e909a73dc4d175e38, [cat:lockup]
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-02-27 19:04:44 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Nicolas Mailhot 2011-08-29 17:50:29 UTC
abrt version: 2.0.5
cmdline:        ro root=/dev/VolGroup00/systeme SYSFONT=latarcyrheb-sun16 LANG=fr_FR.UTF-8 KEYTABLE=fr-latin9 quiet
comment:        scrolling in evince
kernel:         undefined
kernel_tainted: 512
kernel_tainted_long: Taint on warning.
reason:         WARNING: at drivers/gpu/drm/radeon/radeon_fence.c:267 radeon_fence_wait+0x304/0x3c5 [radeon]()
time:           Mon Aug 29 19:46:28 2011

backtrace:
:WARNING: at drivers/gpu/drm/radeon/radeon_fence.c:267 radeon_fence_wait+0x304/0x3c5 [radeon]()
:Hardware name: EP45-DS5
:GPU lockup (waiting for 0x00008A0A last fence id 0x00008A09)
:Modules linked in: tcp_lp fuse ppdev parport_pc lp parport it87 hwmon_vid coretemp snd_emu10k1_synth snd_emux_synth snd_seq_virmidi snd_seq_midi_event snd_seq_midi_emul tuner_simple tuner_types wm8775 tda9887 joydev tda8290 tuner cx25840 snd_emu10k1 microcode ivtv cx2341x snd_rawmidi v4l2_common videodev snd_ac97_codec snd_hda_codec_hdmi media v4l2_compat_ioctl32 tveeprom iTCO_wdt i2c_i801 iTCO_vendor_support serio_raw pcspkr ac97_bus snd_util_mem snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device r8169 mii snd_pcm snd_timer snd soundcore snd_page_alloc uinput raid1 pata_acpi ata_generic firewire_ohci firewire_core crc_itu_t pata_jmicron radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core [last unloaded: scsi_wait_scan]
:Pid: 1654, comm: Xorg Not tainted 3.1.0-0.rc4.git0.0.fc17.x86_64 #1
:Call Trace:
: [<ffffffff8105c534>] warn_slowpath_common+0x83/0x9b
: [<ffffffff8105c5ef>] warn_slowpath_fmt+0x46/0x48
: [<ffffffffa00cadb1>] ? evergreen_gpu_is_lockup+0xba/0xc2 [radeon]
: [<ffffffffa009129d>] radeon_fence_wait+0x304/0x3c5 [radeon]
: [<ffffffff8107ab28>] ? __init_waitqueue_head+0x4b/0x4b
: [<ffffffffa00918ae>] radeon_sync_obj_wait+0x11/0x13 [radeon]
: [<ffffffffa004b688>] ttm_bo_wait+0xbd/0x179 [ttm]
: [<ffffffffa00a2425>] radeon_bo_wait+0x7b/0xa4 [radeon]
: [<ffffffffa00a298e>] radeon_gem_wait_idle_ioctl+0x3d/0x70 [radeon]
: [<ffffffffa001a8d2>] drm_ioctl+0x2a4/0x386 [drm]
: [<ffffffffa00a2951>] ? radeon_gem_busy_ioctl+0x86/0x86 [radeon]
: [<ffffffff8120560e>] ? inode_has_perm+0x6a/0x77
: [<ffffffff812056c2>] ? file_has_perm+0xa7/0xc9
: [<ffffffff81151f5d>] do_vfs_ioctl+0x472/0x4b3
: [<ffffffff81151ff4>] sys_ioctl+0x56/0x7a
: [<ffffffff8106f33d>] ? set_current_blocked+0x2b/0x4e
: [<ffffffff8150b7c2>] system_call_fastpath+0x16/0x1b

smolt_data:
:
:
:Général
:=================================
:UUID: b78fe0ae-e51d-40f8-8e68-7f2478f9cf2a
:SE: Fedora release 17 (Rawhide)
:Niveau d'exécution par défaut: 5
:Langue: fr_FR.UTF-8
:Plateforme: x86_64
:BogoMIPS: 6332.73
:Fabricant du processeurs: GenuineIntel
:Modèle de processeur: Intel(R) Core(TM)2 Duo CPU     E8500  @ 3.16GHz
:Stepping du processeur: 10
:Famille de processeur: 6
:Modèle du processeur: 23
:Nombre de processeurs: 2
:Vitesse du processeur: 2834
:Mémoire du système: 3936
:Swap du système: 4094
:Fabricant: Gigabyte Technology Co., Ltd.
:Système: EP45-DS5 
:Type d'ordinateur: Desktop
:Noyau: 3.1.0-0.rc4.git0.0.fc17.x86_64
:SELinux activé: 1
:Stratégie SELinux: targeted
:SELinux strict: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Périphériques
:=================================
:(32902:11808:5208:20480) pci, None, HOST/PCI, GA-EP45-DS5 Motherboard
:(32902:11809:5208:20480) pci, pcieport, PCI/PCI, GA-EP45-DS5 Motherboard
:(4332:33128:5208:57344) pci, r8169, ETHERNET, GA-EP45-DS5 Motherboard
:(32902:14896:5208:20481) pci, i801_smbus, SERIAL, GA-EP45-DS5 Motherboard
:(32902:14882:5208:45061) pci, ahci, STORAGE, GA-EP45-DS5 Motherboard
:(32902:14870:5208:20481) pci, None, PCI/ISA, GA-EP45-DS5 Motherboard
:(32902:9294:5208:20480) pci, None, PCI/PCI, GA-EP45-DS5 Motherboard
:(32902:14901:5208:20484) pci, uhci_hcd, USB, GA-EP45-DS5 Motherboard
:(32902:14900:5208:20484) pci, uhci_hcd, USB, GA-EP45-DS5 Motherboard
:(32902:14905:5208:20484) pci, uhci_hcd, USB, GA-EP45-DS5 Motherboard
:(32902:14902:5208:20484) pci, uhci_hcd, USB, GA-EP45-DS5 Motherboard
:(32902:14906:5208:20486) pci, ehci_hcd, USB, GA-EP45-DS5 Motherboard
:(32902:14908:5208:20486) pci, ehci_hcd, USB, GA-EP45-DS5 Motherboard
:(6523:9059:5208:45056) pci, pata_jmicron, STORAGE, GA-EP45-DS5 Motherboard
:(6523:9059:5208:45056) pci, ahci, STORAGE, GA-EP45-DS5 Motherboard
:(32902:14918:5208:20481) pci, pcieport, PCI/PCI, GA-EP45-DS5 Motherboard
:(32902:14912:5208:20481) pci, pcieport, PCI/PCI, GA-EP45-DS5 Motherboard
:(32902:14920:5208:20481) pci, pcieport, PCI/PCI, GA-EP45-DS5 Motherboard
:(32902:14910:5208:41218) pci, snd_hda_intel, MULTIMEDIA, GA-EP45-DS5 Motherboard
:(4354:4:4354:16385) pci, snd_emu10k1, MULTIMEDIA_AUDIO, E-MU 1010
:(32902:14903:5208:20484) pci, uhci_hcd, USB, GA-EP45-DS5 Motherboard
:(4354:16385:4354:16) pci, firewire_ohci, FIREWIRE, SB Audigy FireWire Port
:(17476:22:112:32771) pci, ivtv, MULTIMEDIA_VIDEO, WinTV PVR 150
:(32902:14904:5208:20484) pci, uhci_hcd, USB, GA-EP45-DS5 Motherboard
:(4098:43672:5963:43672) pci, snd_hda_intel, MULTIMEDIA, Sapphire HD 6450 1GB DDR3
:(4098:26489:5963:57700) pci, radeon, VIDEO, Sapphire HD 6450 1GB DDR3
:(32902:14922:5208:20481) pci, pcieport, PCI/PCI, GA-EP45-DS5 Motherboard
:(4332:33128:5208:57344) pci, r8169, ETHERNET, GA-EP45-DS5 Motherboard
:
:
:Informations sur le système de fichiers
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/VolGroup00-systeme / ext4 4096 4096 12385484 7008442 6379348 3145728 2645107 2645107
:/dev/mapper/VolGroup00-utilisateur /home ext4 4096 4096 24770967 5182538 3924248 6291456 6196130 6196130
:/dev/md0 /boot ext3 4096 4096 515860 489649 463445 131072 131025 131025
:

Comment 1 Nicolas Mailhot 2011-08-30 19:01:12 UTC
Package: kernel
Architecture: x86_64
OS Release: Fedora release 17 (Rawhide)

Comment
-----
scrolling in evo

Comment 2 Nicolas Mailhot 2011-08-30 19:02:40 UTC
Package: kernel
Architecture: x86_64
OS Release: Fedora release 17 (Rawhide)

Comment
-----
scrolling in firefox

Comment 3 Dave Jones 2011-08-30 20:57:28 UTC

*** This bug has been marked as a duplicate of bug 726857 ***

Comment 4 Nicolas Mailhot 2011-09-04 13:57:01 UTC
It's a kernel problem after all

Patch
https://bugzilla.kernel.org/attachment.cgi?id=71222
from
https://bugzilla.kernel.org/show_bug.cgi?id=42162

fixes the continuous lockups.
(tested with
http://koji.fedoraproject.org/koji/taskinfo?taskID=3323239)

It will probably also fix numerous other problems
http://marc.info/?l=linux-kernel&m=131489065704672&w=2

Comment 5 Jérôme Glisse 2011-09-08 16:36:04 UTC
When it comes to gpu we prefer to assign bug to ddx even if the bug is in kernel.

Comment 6 Josh Boyer 2011-09-12 22:35:05 UTC
I've started a build of 3.1-rc6 that contains some of the PCI fixes highlighted by comment #4.  It also has the debugging options disabled.  Please test this build when it is complete:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3346292

Comment 7 Nicolas Mailhot 2011-09-19 07:56:03 UTC
I didn't really have the time to stress my system, so I'm not 100% certain this kernel fixes all the hangs, but it at least reduces their occurences a lot

Comment 8 Jérôme Glisse 2012-02-21 21:57:11 UTC
*** Bug 726412 has been marked as a duplicate of this bug. ***

Comment 9 Nicolas Mailhot 2012-02-22 06:32:01 UTC
I think this can be closed, I can't trigger it anymore

Comment 10 Jérôme Glisse 2012-02-27 19:04:44 UTC
Closing