Bug 726412 - GPU lockup
Summary: GPU lockup
Keywords:
Status: CLOSED DUPLICATE of bug 734201
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jérôme Glisse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:cd9d54e738b0e5858065e4a6a9b...
: 723014 726896 726921 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-07-28 14:19 UTC by Nicolas Mailhot
Modified: 2012-02-21 21:57 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-21 21:57:10 UTC


Attachments (Terms of Use)

Description Nicolas Mailhot 2011-07-28 14:19:38 UTC
abrt version: 2.0.5
cmdline:        ro root=/dev/VolGroup00/systeme SYSFONT=latarcyrheb-sun16 LANG=fr_FR.UTF-8 KEYTABLE=fr-latin9 log_buf_len=1M systemd.log_level=debug systemd.log_target=kmsg single
comment:        on log in, 
kernel:         undefined
kernel_tainted: 512
kernel_tainted_long: Taint on warning.
reason:         WARNING: at drivers/gpu/drm/radeon/radeon_fence.c:267 radeon_fence_wait+0x296/0x357 [radeon]()
time:           Wed Jul 27 20:14:26 2011

backtrace:
:WARNING: at drivers/gpu/drm/radeon/radeon_fence.c:267 radeon_fence_wait+0x296/0x357 [radeon]()
:Hardware name: EP45-DS5
:GPU lockup (waiting for 0x000512D3 last fence id 0x000512D2)
:Modules linked in: tcp_lp ppdev parport_pc lp parport it87 hwmon_vid coretemp snd_emu10k1_synth snd_emux_synth snd_seq_virmidi snd_seq_midi_event snd_seq_midi_emul tuner_simple tuner_types wm8775 tda9887 tda8290 tuner joydev cx25840 snd_emu10k1 microcode ivtv cx2341x v4l2_common videodev snd_rawmidi media snd_ac97_codec v4l2_compat_ioctl32 tveeprom ac97_bus snd_util_mem serio_raw iTCO_wdt iTCO_vendor_support pcspkr i2c_i801 snd_hda_codec_hdmi snd_hda_codec_realtek snd_seq snd_seq_device snd_hda_intel snd_hda_codec snd_hwdep snd_pcm r8169 mii snd_timer snd soundcore snd_page_alloc uinput raid1 pata_acpi firewire_ohci ata_generic firewire_core crc_itu_t pata_jmicron radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core [last unloaded: scsi_wait_scan]
:Pid: 2962, comm: gnome-shell Not tainted 3.0.0-1.fc16.x86_64 #1
:Call Trace:
: [<ffffffff81058ebc>] warn_slowpath_common+0x83/0x9b
: [<ffffffff81058f77>] warn_slowpath_fmt+0x46/0x48
: [<ffffffffa00ca7e5>] ? evergreen_gpu_is_lockup+0xba/0xc2 [radeon]
: [<ffffffffa0091035>] radeon_fence_wait+0x296/0x357 [radeon]
: [<ffffffff81076584>] ? __init_waitqueue_head+0x4b/0x4b
: [<ffffffffa00a2b14>] radeon_ib_get+0xf3/0x17e [radeon]
: [<ffffffffa00cccbb>] ? evergreen_copy_blit+0x3c/0xac [radeon]
: [<ffffffffa00d00a2>] evergreen_blit_prepare_copy+0x28/0x4c0 [radeon]
: [<ffffffffa00cccd1>] evergreen_copy_blit+0x52/0xac [radeon]
: [<ffffffffa0091757>] radeon_move_blit+0xfb/0x13e [radeon]
: [<ffffffffa0091986>] radeon_move_ram_vram+0xc8/0xf3 [radeon]
: [<ffffffffa004c113>] ? ttm_bo_list_ref_sub+0x29/0x2b [ttm]
: [<ffffffffa00508f6>] ? ttm_eu_list_ref_sub+0x29/0x3d [ttm]
: [<ffffffffa0091cfc>] radeon_bo_move+0xec/0x133 [radeon]
: [<ffffffffa004c946>] ttm_bo_handle_move_mem+0x1c4/0x2b1 [ttm]
: [<ffffffffa004d6bc>] ttm_bo_move_buffer+0xe1/0x119 [ttm]
: [<ffffffffa004c113>] ? ttm_bo_list_ref_sub+0x29/0x2b [ttm]
: [<ffffffffa00508f6>] ? ttm_eu_list_ref_sub+0x29/0x3d [ttm]
: [<ffffffffa004d7b6>] ttm_bo_validate+0xc2/0x100 [ttm]
: [<ffffffffa0092b60>] radeon_bo_list_validate+0x8b/0xd6 [radeon]
: [<ffffffffa00a3b90>] radeon_cs_parser_relocs+0x198/0x1f5 [radeon]
: [<ffffffffa00a3fc3>] radeon_cs_ioctl+0xaf/0x19c [radeon]
: [<ffffffffa001a8e6>] drm_ioctl+0x2a4/0x386 [drm]
: [<ffffffffa00a3f14>] ? radeon_cs_finish_pages+0x8d/0x8d [radeon]
: [<ffffffff811f917b>] ? inode_has_perm+0x6a/0x77
: [<ffffffff811f922f>] ? file_has_perm+0xa7/0xc9
: [<ffffffff81149978>] do_vfs_ioctl+0x47b/0x4bc
: [<ffffffff81149a0f>] sys_ioctl+0x56/0x7b
: [<ffffffff814e4fc2>] system_call_fastpath+0x16/0x1b

Comment 1 Josh Boyer 2011-07-28 21:39:23 UTC
Reassigning to xorg-x11-drv-ati per Dave.

Comment 2 Jérôme Glisse 2012-02-21 21:44:36 UTC
Fixed since 3.3 rc2

Comment 3 Jérôme Glisse 2012-02-21 21:47:36 UTC
Closed from bug.

Nicolas will need a test case.

Comment 4 Jérôme Glisse 2012-02-21 21:48:13 UTC
please provide dmesg and xorg log

Comment 5 Jérôme Glisse 2012-02-21 21:48:47 UTC
*** Bug 723014 has been marked as a duplicate of this bug. ***

Comment 6 Jérôme Glisse 2012-02-21 21:48:56 UTC
*** Bug 726921 has been marked as a duplicate of this bug. ***

Comment 7 Jérôme Glisse 2012-02-21 21:49:09 UTC
*** Bug 726896 has been marked as a duplicate of this bug. ***

Comment 8 Jérôme Glisse 2012-02-21 21:57:10 UTC

*** This bug has been marked as a duplicate of bug 734201 ***


Note You need to log in before you can comment on or make changes to this bug.