Bug 734964

Summary: grub2 should require os-prober
Product: [Fedora] Fedora Reporter: David Lehman <dlehman>
Component: grub2Assignee: Lubomir Rintel <lkundrak>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: awilliam, dennis, hedayatv, lkundrak, pjones, robatino
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-09-01 05:17:50 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 713564    

Description David Lehman 2011-08-31 19:42:07 EDT
Description of problem:
grub2 contains configuration material that uses os-prober to create menu entries for other OS installations. In order to make sure that this functionality is enabled, grub2 should require os-prober.


grub2-1.99-0.2.fc16
Comment 1 Adam Williamson 2011-08-31 23:57:06 EDT
Apparently os-prober isn't on the Beta TC1 DVD, which would make this bug a Final blocker, as this bug will solve the problem of os-prober not winding up on DVD composes. I'm not sure it's a Beta blocker.
Comment 2 Hedayat Vatankhah 2011-09-01 05:17:50 EDT

*** This bug has been marked as a duplicate of bug 678456 ***