Bug 678456 - GRUB 2 requires os-prober to detect other installed operating systems
GRUB 2 requires os-prober to detect other installed operating systems
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
rawhide
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
AcceptedNTH
:
: 734964 738164 (view as bug list)
Depends On: 678442
Blocks: 580176 697517 F16Beta-accepted/F16BetaFreezeExcept F16Blocker/F16FinalBlocker
  Show dependency treegraph
 
Reported: 2011-02-17 20:53 EST by Hedayat Vatankhah
Modified: 2011-09-15 11:15 EDT (History)
8 users (show)

See Also:
Fixed In Version: grub2-1.99-5.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-06 23:39:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Hedayat Vatankhah 2011-02-17 20:53:36 EST
Description of problem:
In grub 2, /etc/grub.d/30_os-prober is responsible for detecting other installed operating systems and generating menu entries for them. This script depends on os-prober package to detect other OSes. So, grub 2 should depend on os-prober package when it is available in Fedora repositories.

os-prober is currently under review: bug #678442
Comment 1 Hedayat Vatankhah 2011-05-08 13:24:09 EDT
os-prober is now available in Fedora.
Comment 2 Barry Fishman 2011-05-08 16:12:44 EDT
Problem is fixed by installing os-prober
Comment 3 Hedayat Vatankhah 2011-09-01 05:17:50 EDT
*** Bug 734964 has been marked as a duplicate of this bug. ***
Comment 4 Hedayat Vatankhah 2011-09-01 06:39:55 EDT
Considering that Grub2 is used in Fedora 16, and since this bug not only fixes a bug, but also brings a completely new feature to Fedora 16: ability to detect other Linux distributions and OSes in addition to Windows. Therefore, I think it should be considered as a nice to have bug at least. Since it is very easy to fix, it could be even a blocker bug.
Comment 5 Adam Williamson 2011-09-01 12:21:27 EDT
It should be a final blocker, per the rationale in 734964:

"Apparently os-prober isn't on the Beta TC1 DVD, which would make this bug a
Final blocker, as this bug will solve the problem of os-prober not winding up
on DVD composes."

(if os-prober isn't on the DVD, DVD installs can't detect other OSes, and this breaks Final criterion "The installer must be able to install into free space alongside an existing clean single-partition Windows installation and either install a bootloader which can boot into the Windows installation, or leave the Windows bootloader untouched and working ".)
Comment 6 Fedora Update System 2011-09-01 17:13:21 EDT
grub2-1.99-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/grub2-1.99-2.fc16
Comment 7 Adam Williamson 2011-09-02 14:54:22 EDT
Discussed at 2011-09-02 NTH review meeting (as this is Beta, blocker status for final would be assessed later if it wasn't fixed for Beta). Agreed to accept as NTH, it would be good to fix this for Beta and the fix is simple.
Comment 8 Fedora Update System 2011-09-05 11:06:05 EDT
grub2-1.99-5.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/grub2-1.99-5.fc16
Comment 9 Fedora Update System 2011-09-06 14:10:48 EDT
Package grub2-1.99-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing grub2-1.99-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/grub2-1.99-2.fc16
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2011-09-06 23:39:33 EDT
grub2-1.99-5.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 David Lehman 2011-09-15 11:15:33 EDT
*** Bug 738164 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.