Bug 735023

Summary: Fedora 16 live images are not EFI-capable: should use grub-efi package when available
Product: [Fedora] Fedora Reporter: Fabian Deutsch <fabian.deutsch>
Component: spin-kickstartsAssignee: Jeroen van Meeuwen <vanmeeuwen+fedora>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 16CC: adam.stokes, awilliam, bcl, bruno, bugzilla, dhuff, Jasper.Hartline, jonathan, katzj, kevin, liangsuilong, lkundrak, lmacken, maciej, madhu.chinakonda, mads, ma, maxamillion, petersen, pjones, satellitgo, tflink, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-10-14 14:46:41 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 743376    
Bug Blocks: 713566    

Description Fabian Deutsch 2011-09-01 04:14:58 EDT
Description of problem:
Live media for EFI systems could be created using the livecd-iso-to-disk tools, but now the EFI folder is missing on the livecd and livecd-iso-to-disk fails if run with the --efi option.

Version-Release number of selected component (if applicable):
alpha

How reproducible:
always

Steps to Reproduce:
1. Download named image.
2. Run livecd-iso-to-disk --format --efi $ISO $DEV
3. 
  
Actual results:
livecd-iso-to-disk fails with ERROR: This live image does not support EFI booting

Expected results:
efi bootable disk is created

Additional info:
As noted above the efi folder is missing on the live cd ..
Comment 1 Fabian Deutsch 2011-09-27 10:34:11 EDT
The RC3 still can not be used with livecd-iso-to-disk and --efi - any progress on this?
Comment 2 Fabian Deutsch 2011-09-27 10:49:35 EDT
The F15-live can be used with the livecd-iso-to-disk --efi commandline and can be booted on a efi system.

Some versions:
- Fedora 15 with all updates-testing.
- Fedora-16-RC3 x86_64 image as of today.

$ rpm -q livecd-tools
livecd-tools-15.8-1.fc15.x86_64

$ sudo livecd-iso-to-disk --format --efi  Fedora-16-Beta-x86_64-Live-Desktop.iso /dev/sdg
Verifying image...
/home/fabiand/Downloads/Fedora-16-Beta-x86_64-Live-Desktop.iso:   266d2136cde77ee390f5e4f1ba033d7c
Fragment sums: 511daddc795156378fbaecd488c2d75b7b28c2a35c67eddc920f6aae9c16
Fragment count: 20
Press [Esc] to abort check.
Checking: 100.0%

The media check is complete, the result is: PASS.

It is OK to use this media.
WARNING: THIS WILL DESTROY ANY DATA ON /dev/sdg!!!
Press Enter to continue or ctrl-c to abort

wipefs: WARNING: /dev/sdg: appears to contain 'gpt' partition table
Waiting for devices to settle...
mkdosfs 3.0.11 (24 Dec 2010)
ERROR: This live image does not support EFI booting
Cleaning up to exit...
Comment 3 Tim Flink 2011-09-27 11:46:40 EDT
Fabian, can you confirm that you were using the Fedora 16 beta RC3 livecd from:
http://dl.fedoraproject.org/pub/alt/stage/16-Beta.RC3/Live/x86_64/Fedora-16-Beta-x86_64-Live-Desktop.iso

If so, the build logs for the livecd are in koji:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3380695
Comment 4 Brian Lane 2011-09-27 12:04:15 EDT
livecd-creator needs the grub.efi file in order to build images with EFI support.

A grub-efi package that doesn't conflict with grub2 is needed.
Comment 5 Fabian Deutsch 2011-09-27 12:09:13 EDT
(In reply to comment #3)
> Fabian, can you confirm that you were using the Fedora 16 beta RC3 livecd from:
> http://dl.fedoraproject.org/pub/alt/stage/16-Beta.RC3/Live/x86_64/Fedora-16-Beta-x86_64-Live-Desktop.iso
> 
> If so, the build logs for the livecd are in koji:
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=3380695

Yes I used exactly that file.
Comment 6 Mads Kiilerich 2011-09-27 12:28:52 EDT
(In reply to comment #4)
> A grub-efi package that doesn't conflict with grub2 is needed.

Note that grub (which includes efi) and grub2 only conflicts because the spec says so - there is no real conflict.

(There is however a bug in grubby that prevent it from working correctly when both packages are installed - see bug 725185.)
Comment 7 Adam Williamson 2011-10-04 13:59:10 EDT
Updating bug: pjones wants to create an EFI-specific grub-efi package which will not conflict with grub2, so I've filed a bug for that, and am making this a bug for spin-kickstarts to use that package once it exists, to render the live images once again EFI-capable. Proposing as NTH for F16 Final.
Comment 8 Brian Lane 2011-10-06 16:16:37 EDT
*** Bug 743972 has been marked as a duplicate of this bug. ***
Comment 9 Adam Williamson 2011-10-07 15:42:50 EDT
Discussed at 2011-10-07 NTH review meeting. agreed we need to know exactly what change is needed to make the live images bootable again to make a decision on NTH status: if it's just putting grub-efi into the ks, then that's fine, if there's any changes needed to livecd-creator, we might not want to do that during a freeze.
Comment 10 Chris Murphy 2011-10-08 22:04:32 EDT
*** Bug 744386 has been marked as a duplicate of this bug. ***
Comment 11 Adam Williamson 2011-10-11 21:38:29 EDT
I've verified that just building the live image with grub-efi added to fedora-live-base.ks (and a grub-efi package available from a side repo, obviously...) is enough to make an image that boots successfully both via EFI and BIOS. So as soon as the updated grub goes stable we can change fedora-live-base.ks and close this.
Comment 12 Jens Petersen 2011-10-13 05:38:57 EDT
Great.  So if grub2 pulls in grub-efi it will solve the issue for us. :)
Comment 13 Mads Kiilerich 2011-10-13 06:13:23 EDT
(In reply to comment #12)
> Great.  So if grub2 pulls in grub-efi it will solve the issue for us. :)

I doubt it will do that. I hope it doesn't. We might be able to specify grub and instead get both grub-efi and grub2, but specifying explicitly what we want instead of relying on magic would IMHO be a better solution.

(Or was it a joking smiley?)
Comment 14 Kevin Fenzi 2011-10-13 11:22:13 EDT
commit 3c72e9eae4ed169f7f8c756c0fafdd0f24fe4b01
Author: Kevin Fenzi <kevin@scrye.com>
Date:   Thu Oct 13 09:20:03 2011 -0600

    Add grub2, grub-efi and efibootmgr for EFI install/booting. Fixes bug #735023

grub2 and grub-efi don't depend on each other... I've added them to the ks files. 
They are also no longer in comps. 

This should hopefully do the right thing here.
Comment 15 Adam Williamson 2011-10-13 14:35:00 EDT
that's correct, AIUI. it's not really right for grub2 to depend on grub-efi. if we had some sort of virtual 'bootloader' provides it could require both grub2 and grub-efi, but we don't, so just pulling them both in explicitly is the right thing to do.
Comment 16 Adam Williamson 2011-10-14 14:46:41 EDT
the necessary change has been commited to spin-kickstarts: closing.
Comment 17 Jens Petersen 2011-10-16 22:36:26 EDT
Thanks --efi install works for me on latest nightly F16 Live images.
Comment 18 Martin Jürgens 2011-12-27 08:11:33 EST
does not work for me. i can put fedora 16 onto a stick with the --efi option, but only a grub promt appears when efi-booting it.
Comment 19 satellitgo 2011-12-27 09:11:00 EST
Works for Me
WORKS WITH SoaS v5 Coconut and SoaS v6 Pineapple 

Command:
sudo livecd-iso-to-disk --format --efi --overlay-size-mb 300 --home-size-mb 175 --delete-home --unencrypted-home Fedora-15-x86_64-Live-SoaS.iso /dev/sd(x) (x)=device name

Ref:
http://wiki.sugarlabs.org/go/Community/Distributions/Fedora-SoaS#MacBook_Persistent_SoaS_v5_and_SoaS_v6_EFI_Boot_USB
Comment 20 Adam Williamson 2012-01-03 18:34:23 EST
"does not work for me. i can put fedora 16 onto a stick with the --efi option,
but only a grub promt appears when efi-booting it."

Then it worked. Or else you wouldn't have seen a grub prompt.

Clearly, you have *another* issue, but it's not this bug.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 21 Martin Jürgens 2012-01-08 08:32:45 EST
its a grub command promt.
anyway, you do not seem interested to solve it which i find disappointing. well, then lets leave it that way
Comment 22 Chris Murphy 2012-01-08 12:17:10 EST
(In reply to comment #21)
Please note the component, and the bug description. This bug is about making *live images* EFI capable again, not about subsequent boot problems from the resulting stick.

A GRUB prompt means it's not finding grub.conf so you need to find out why that might be. Maybe one wasn't created? Maybe it's empty or truncated? Maybe it's looking for it in the wrong location due to some EFI weirdness? [grub.efi and grub.conf get renamed to bootx64.efi and bootx64.conf on the resulting stick, so that .conf file is what you're looking for] Does the stick fail in the same way on a different EFI system?

If you do find a fully intact grub.conf that looks properly formatted then you need to do some grub command line work to see why it might not be finding the grub.conf...no one else can do these things on a system having this problem except you. 

And yes of course it's going to have to go in a different bug report because it's a completely different problem than what's described in this one. If you need help poking GRUB with a stick I suggest the installation help forum at fedoraforums.org with a clear subject like "GRUB-EFI boot fail, only get a grub prompt".
Comment 23 Martin Jürgens 2012-01-08 18:02:21 EST
chris, thanks for your help. ive found a post on fedoraforums.org which did not get any reply and represents my issue. this is why i filed bug 772505 . lets see if it will work with fedora 17.
Comment 24 satellitgo 2012-01-08 18:04:03 EST
see
1-)
http://wiki.sugarlabs.org/go/Community/Distributions/Fedora-SoaS#MacBook_Persistent_SoaS_v5_and_SoaS_v6_EFI_Boot_USB

Run "yum install livecd-tools" so it installs all the required
dependencies and  then use livecd-iso-to-disk
script:
sudo livecd-iso-to-disk --format --efi --overlay-size-mb 300 --home-size-mb 175
--delete-home --unencrypted-home Fedora-15-x86_64-Live-SoaS.iso /dev/sd(x)
(x)=device name

And:
2-)http://wiki.sugarlabs.org/go/Community/Distributions/Fedora-SoaS#MacBook_Pro_i7_CD_Boot
Works fine for me as CD (64 bit) or USB built with script