Bug 737431

Summary: No sound drivers present in winecfg, in 1.3.28-1 from updates-testing
Product: [Fedora] Fedora Reporter: Gabriel <gbauman>
Component: wineAssignee: Andreas Bierfert <andreas.bierfert>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 15CC: andreas.bierfert, belegdol, chepioq, dr.diesel, dzrudy, error, gilboad, jannhorn, marbolangos, nerijus, stefan
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: wine-1.3.33-1.fc16 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-12-12 21:59:38 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Screenshot. [+] cannot be expanded. none

Description Gabriel 2011-09-12 03:48:12 UTC
Created attachment 522643 [details]
Screenshot. [+] cannot be expanded.

Description of problem:

In winecfg while creating a new wineprefix, no audio drivers appear on the Audio tab. Clicking "Test Sound" results in an error box reading "Audio Test Failed!".

Version-Release number of selected component (if applicable):

1.3.28-1 from updates-testing

How reproducible:

Open winecfg. Click to the Audio tab. There is nothing in the Sound Drivers treeview.

Expected results:

I should be able to select the ALSA or PulseAudio driver here.

Additional info:

Previous version of wine worked as expected.

Comment 1 Gabriel 2011-09-12 03:51:49 UTC
I forgot to mention... sound no longer works in existing wineprefixes either.

Comment 2 Andreas Bierfert 2011-09-13 19:04:15 UTC
There are two aspects here:

1. Audio Driver Selection:
This has been removed as of wine .28 and is done automatically. However you can still set the corresponding registry keys if you wish to set it manually. 

2. Audio not working:
This of course is not how it should be. I will investigate.

Comment 3 Gabriel 2011-09-14 23:04:17 UTC
I pulled the latest package from updates-testing today. The package version did not get bumped, but every wine-related package was updated.

winecfg no longer shows the driver selection view, and clicking the Test Sound button plays a sound as expected. Good.

However, sound only works in the default wineprefix. Clicking Test Sound in my other prefixes results in the "Audio Test Failed!" message. I got the "updating wine configuration" message in each of those prefixes after installing the update.

Audio works in new wineprefixes as well.

I've checked the registry in each prefix, and the audio driver is set to 'pulse' as it should be.

Comment 4 Stefan Lesicnik 2011-09-16 04:49:38 UTC
Hi,

Also having sound issues since upgrade to 1.3.28.  I have been through http://wiki.winehq.org/Sound and done the registry changes to try oss, coreaudio, alsa and pulse.  Alsa seems to work best but getting choppy audio.

I have deleted and created prefix. I have tried WinXP and Win7.

When audio is set to pulse i get the following

trace:mmdevapi:init_driver Loading driver list L"pulse"
trace:mmdevapi:load_driver Attempting to load L"winepulse.drv"
trace:mmdevapi:load_driver Unable to load L"winepulse.drv": 126
trace:mmdevapi:init_driver Failed to load driver L"pulse"

Setting up Install Process
Package wine-pulseaudio-1.3.28-1.fc15.i686 already installed and latest version
Package wine-pulseaudio-1.3.28-1.fc15.x86_64 already installed and latest version
Nothing to do

rpm -ql wine-pulseaudio
(contains no files)
(contains no files)

Doesn't actually seem like winepulse.drv exists - same with wine-oss.

Comment 5 dominique 2011-09-24 07:48:56 UTC
Same problem here.

For test I install the 1.3.28 version from updates-testing, and sound don't work.

I have "test sound failed"

I post to CC this bug

Comment 6 Gilboa Davara 2011-09-24 21:06:59 UTC
Upsteamed.
http://bugs.winehq.org/show_bug.cgi?id=28421

- Gilboa

Comment 7 Julian Sikorski 2011-10-15 20:16:03 UTC
To get the sound to work a registry key needs to be removed:
HKEY_CURRENT_USER\Software\Wine\Drivers\Audio
This is because the pulseaudio driver was removed.

Comment 8 Stefan Lesicnik 2011-10-23 07:53:02 UTC
I have created a new profile with the 1.3.29 update (that above reg key doesn't exist) and I still get no sound - particularly World of Warcraft. Perhaps the 1.3.31 update will fix something.

Comment 9 Julian Sikorski 2011-10-23 07:56:33 UTC
Make sure you have alsa-plugins-pulseaudio.i686 and wine-alsa installed.

Comment 10 Stefan Lesicnik 2011-10-23 09:13:33 UTC
Thanks Julian!  It was the wine-alsa.i686 package that was missing (only had x86_64).  Sound is working now.

Comment 11 Andy Lawrence 2011-11-06 12:26:55 UTC
(In reply to comment #6)
> Upsteamed.
> http://bugs.winehq.org/show_bug.cgi?id=28421
> 
> - Gilboa

Note, this was closed as invalid.

Comment 12 Andy Lawrence 2011-11-06 12:32:26 UTC
*** Bug 747735 has been marked as a duplicate of this bug. ***

Comment 13 Dawid Zamirski 2011-11-06 19:09:00 UTC
Just to confirm, installing wine-alsa.i686 and removing the registry key HKEY_CURRENT_USER\Software\Wine\Drivers\Audio resolved the problem for me.

Comment 14 Andreas Bierfert 2011-11-06 19:22:05 UTC
This will be fixed with the next push (.32)

* Fri Nov 04 2011 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
- 1.3.31-2
- pull in correct wine-alsa arch in the pa meta package

Comment 15 Fedora Update System 2011-11-06 22:14:55 UTC
wine-1.3.32-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2011-15185

Comment 16 dominique 2011-11-07 06:56:58 UTC
I test 1.3.31-2, but the problem still persist: no sound.
I get sound with removing the registry key HKEY_CURRENT_USER\Software\Wine\Drivers\Audio...

Comment 17 Fedora Update System 2011-11-07 08:55:26 UTC
Package wine-1.3.32-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing wine-1.3.32-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-15185
then log in and leave karma (feedback).

Comment 18 Michael Hampton 2011-11-16 23:16:05 UTC
Either removing the registry entry in comment 7, or updating to 1.3.32, fixed the issue for me.

Comment 19 Fedora Update System 2011-11-21 22:55:05 UTC
Package wine-1.3.33-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing wine-1.3.33-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-15185/wine-1.3.33-1.fc16
then log in and leave karma (feedback).

Comment 20 Nerijus Baliƫnas 2011-12-09 14:43:56 UTC
Sound still does not work with 1.3.33 until I remove HKEY_CURRENT_USER\Software\Wine\Drivers\Audio key.

Comment 21 Fedora Update System 2011-12-12 21:59:38 UTC
wine-1.3.33-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.