Bug 747735 - Wine "Test Sound" results in Audio test failed
Summary: Wine "Test Sound" results in Audio test failed
Keywords:
Status: CLOSED DUPLICATE of bug 737431
Alias: None
Product: Fedora
Classification: Fedora
Component: wine
Version: 16
Hardware: i686
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-10-20 21:26 UTC by Andy Lawrence
Modified: 2011-11-06 12:32 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-06 12:32:26 UTC


Attachments (Terms of Use)

Description Andy Lawrence 2011-10-20 21:26:08 UTC
Description of problem:

Open winecfg, click the audio tab then "Test Sound".  Direct Sound settings are hardware acceleration = Full, Default sample rate = 44100, Default bits per sample = 16.  Changing these settings doesn't appear to help the situation any.

Console output:

err:mmdevapi:DllGetClassObject Driver initialization failed
err:ole:apartment_getclassobject DllGetClassObject returned error 0x80004005
err:ole:CoGetClassObject no class object {bcde0395-e52f-467c-8e3d-c4579291692e} could be created for context 0x1

Wine versions:

wine-system-fonts-1.3.29-1.fc16.noarch
wine-core-1.3.29-1.fc16.x86_64
wine-1.3.29-1.fc16.i686
wine-desktop-1.3.29-1.fc16.noarch
wine-marlett-fonts-1.3.29-1.fc16.noarch
wine-common-1.3.29-1.fc16.noarch
wine-ldap-1.3.29-1.fc16.i686
wine-small-fonts-1.3.29-1.fc16.noarch
wine-fonts-1.3.29-1.fc16.noarch
wine-pulseaudio-1.3.29-1.fc16.i686
wine-capi-1.3.29-1.fc16.i686
wine-ms-sans-serif-fonts-1.3.29-1.fc16.noarch
wine-systemd-1.3.29-1.fc16.noarch
wine-openal-1.3.29-1.fc16.i686
wine-symbol-fonts-1.3.29-1.fc16.noarch
wine-courier-fonts-1.3.29-1.fc16.noarch
wine-cms-1.3.29-1.fc16.i686
wine-tahoma-fonts-1.3.29-1.fc16.noarch
wine-wow-1.3.29-1.fc16.i686
wine-core-1.3.29-1.fc16.i686
wine-alsa-1.3.29-1.fc16.x86_64
wine-twain-1.3.29-1.fc16.i686

F16, x64 bit, XFCE install, all updates as of today.

Note this is a wine.i686 on 64 bit F16 Install.  I'm not familiar with debugging wine but will provide any output, please ask!

Comment 1 Andy Lawrence 2011-11-01 23:06:42 UTC
The same happens with the just updated wine 1.3.31-1.

Default Audio setup changed automatically when upgrading to 1.3.31-1:

Driver Diagnostics: (None)

Defaults device, voice ouput device, input device, voice input device all (System default)

Pressing "Test Sound" returns the same output as above:

Comment 2 Ian Westcott 2011-11-06 08:17:07 UTC
I'm having the same issue. 

Did you use your .wine hierarchy with an earlier version of wine? I think I recall seeing that earlier versions of wine put registry keys in for an older style of sound system, and those keys broke under the new sound system implimented in a recent wine.

Comment 3 Ian Westcott 2011-11-06 08:20:41 UTC
See http://bugs.winehq.org/show_bug.cgi?id=28421
Specifically: 
"I was able to properly fix the problem by going into regedit and in
HKEY_CURRENT_USER\Software\Wine\Drivers\, removing an old Audio string entry
that had the value "pulse".  Now the driver autodetection works properly."

That fixed my sound problem.

Comment 4 Andy Lawrence 2011-11-06 10:17:34 UTC
As a test I deleted my .wine directory.  I checked regedit as well and I don't even have a "Drivers" folder listed.  Same problem.

Thanks for the help

Comment 5 Stefan Lesicnik 2011-11-06 11:03:33 UTC
See https://bugzilla.redhat.com/show_bug.cgi?id=737431

Might be some advice there.

Comment 6 Andy Lawrence 2011-11-06 12:32:04 UTC
Stefan, thanks, installing wine-alsa.i686 worked!  Marking this as a dupe.

Comment 7 Andy Lawrence 2011-11-06 12:32:26 UTC

*** This bug has been marked as a duplicate of bug 737431 ***


Note You need to log in before you can comment on or make changes to this bug.