Bug 739284

Summary: Firefox becomes unkillable after visiting novatech web site
Product: [Fedora] Fedora Reporter: Tim Waugh <twaugh>
Component: firefoxAssignee: Gecko Maintainer <gecko-bugs-nobody>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: gecko-bugs-nobody, robatino
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-09-19 10:16:32 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Tim Waugh 2011-09-17 10:01:48 UTC
Description of problem:
Visiting http://www.novatech.co.uk/ causes Firefox to become unkillable, in that closing the Firefox window leaves a firefox process running that has to be killed "by hand".

Version-Release number of selected component (if applicable):
firefox-6.0.2-1.fc16.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Visit http://www.novatech.co.uk/
  
Actual results:
Blank page, no way to restart it except by closing window and killing the process in system monitor (or by command line)

Expected results:
Correctly shown web site, or else an error message, or some other consistent behaviour.

Additional info:
Works fine in Fedora 14 (firefox-3.6.22-1.fc14.x86_64).

Comment 1 Andre Robatino 2011-09-17 16:31:16 UTC
I'm not able to reproduce this either in F16 x86_64 with firefox-6.0.2-1.fc16.x86_64, or in F15 x86_64 with firefox-6.0.2-1.fc15.x86_64. In both cases I ran "firefox http://www.novatech.co.uk/" from a terminal, verified that the page appears to display properly, then closed it with the "Close Window" button, then checked for leftover processes. I have some proprietary plugins (including Flash) in F15, nothing proprietary or from any external repos in F16.

Comment 2 Tim Waugh 2011-09-19 10:16:32 UTC
Oh, works now here as well after running via strace (weird)... perhaps it was something in the cache.  Sorry for the noise.