Bug 739284 - Firefox becomes unkillable after visiting novatech web site
Summary: Firefox becomes unkillable after visiting novatech web site
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 16
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-17 10:01 UTC by Tim Waugh
Modified: 2011-09-19 10:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-19 10:16:32 UTC


Attachments (Terms of Use)

Description Tim Waugh 2011-09-17 10:01:48 UTC
Description of problem:
Visiting http://www.novatech.co.uk/ causes Firefox to become unkillable, in that closing the Firefox window leaves a firefox process running that has to be killed "by hand".

Version-Release number of selected component (if applicable):
firefox-6.0.2-1.fc16.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Visit http://www.novatech.co.uk/
  
Actual results:
Blank page, no way to restart it except by closing window and killing the process in system monitor (or by command line)

Expected results:
Correctly shown web site, or else an error message, or some other consistent behaviour.

Additional info:
Works fine in Fedora 14 (firefox-3.6.22-1.fc14.x86_64).

Comment 1 Andre Robatino 2011-09-17 16:31:16 UTC
I'm not able to reproduce this either in F16 x86_64 with firefox-6.0.2-1.fc16.x86_64, or in F15 x86_64 with firefox-6.0.2-1.fc15.x86_64. In both cases I ran "firefox http://www.novatech.co.uk/" from a terminal, verified that the page appears to display properly, then closed it with the "Close Window" button, then checked for leftover processes. I have some proprietary plugins (including Flash) in F15, nothing proprietary or from any external repos in F16.

Comment 2 Tim Waugh 2011-09-19 10:16:32 UTC
Oh, works now here as well after running via strace (weird)... perhaps it was something in the cache.  Sorry for the noise.


Note You need to log in before you can comment on or make changes to this bug.