Bug 741078

Summary: prefdm.service entered failed state
Product: [Fedora] Fedora Reporter: Clyde E. Kunkel <clydekunkel7734>
Component: systemdAssignee: Lennart Poettering <lpoetter>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 16CC: bugzilla, harald, johannbg, kay, lpoetter, mattia.verga, metherid, mishu, mschmidt, notting, plautrba, rmarko, stanley.king
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: systemd-36-3.fc16 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-09-30 18:53:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Clyde E. Kunkel 2011-09-25 02:23:21 UTC
Description of problem:
Unit prefdm.service entered failed state.
prefdm.service: main process exited, code=exited, status=1
prefdm.service holdoff time over, scheduling restart.
Unit prefdm.service entered failed state.
prefdm.service start request repeated too quickly, refusing to start.

Version-Release number of selected component (if applicable):
36-2.fc16.x86_64

How reproducible:
Every time booting into level 5

Steps to Reproduce:
1. boot system
2.
3.
  
Actual results:
prefdm fails to start leaving system hanging

Expected results:
Normal boot into desktop

Additional info:
Can escape failure with C-A-Del reboot.
reverting systemd fixes problem.

Comment 1 Stan King 2011-09-25 07:15:39 UTC
I'm also seeing what Clyde seeing.  I'll keep an eye on this bugzilla for any hints or information requests.  The affected system is i686, not x86_64.

Specifying "3" as a boot parameter to the kernel will let me log in, but networking mode is not functional, so getting an update onto the system will have to come in by a different mechanism.

Comment 2 Stan King 2011-09-25 07:35:17 UTC
A correction to my earlier comment: after logging in at the systemd equivalent of runlevel 3, a "telinit 5" command brings me into the GUI, along with networking, so I will be able to grab an update that way.

Comment 3 Michal Schmidt 2011-09-25 07:51:09 UTC
I can reproduce the bug. There are ordering cycles:

 Found ordering cycle on basic.target/start
 Walked on cycle path to sockets.target/start
 Walked on cycle path to dbus.socket/start
 Walked on cycle path to sysinit.target/start
 Walked on cycle path to mdmonitor-takeover.service/start
 Walked on cycle path to basic.target/start
 Breaking ordering cycle by deleting job dbus.socket/start

The ordering dependency mdmonitor-takeover.service -> basic.target probably should not be there. mdmonitor-takeover.service should probably use DefaultDependencies=no.

The regression appeared because of this fix:
http://cgit.freedesktop.org/systemd/commit/?id=a65cb51f29ee177f6f800c87232b68475216a418

We should revert that at least for now to get the other needed fixes into F16.

Comment 4 Fedora Update System 2011-09-25 08:32:39 UTC
systemd-36-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2011-13150

Comment 5 Steve 2011-09-25 09:23:02 UTC
(In reply to comment #4)
> systemd-36-3.fc16 has been submitted as an update for Fedora 16.
> https://admin.fedoraproject.org/updates/FEDORA-2011-13150

works again. thx!

Comment 6 Michal Schmidt 2011-09-25 14:21:10 UTC
*** Bug 741110 has been marked as a duplicate of this bug. ***

Comment 7 Michal Schmidt 2011-09-25 15:55:59 UTC
(In reply to comment #3)
> The ordering dependency mdmonitor-takeover.service -> basic.target probably
> should not be there. mdmonitor-takeover.service should probably use
> DefaultDependencies=no.

Filed as bug 741115.

Comment 8 Stan King 2011-09-29 22:56:39 UTC
Is there something I can do to test a fix for this situation?

I thought the change might have been held up by a code chill for the upcoming F16 Beta, but I just got a bunch of updates for F16 today, none of which helped this condition.

Thanks for your help or advice.

Comment 9 Michal Schmidt 2011-09-29 23:14:46 UTC
(In reply to comment #8)
The update is still stuck in the pending queue because of the Beta freeze. You can download systemd-36-3.fc16 manually from Koji. Follow the "Builds" link from the update page https://admin.fedoraproject.org/updates/FEDORA-2011-13150

Comment 10 Stan King 2011-09-30 05:44:56 UTC
Michal, I managed to install the four files, and it works for me now.  Thanks.  Good luck with the freeze.

Comment 11 Fedora Update System 2011-09-30 18:52:55 UTC
systemd-36-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.