Bug 741110 - Systemd upgrade to 36-2 broke dbus functionality
Summary: Systemd upgrade to 36-2 broke dbus functionality
Keywords:
Status: CLOSED DUPLICATE of bug 741078
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 16
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: David Zeuthen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-25 13:39 UTC by Mattia Verga
Modified: 2013-03-06 04:08 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-25 14:21:10 UTC


Attachments (Terms of Use)

Description Mattia Verga 2011-09-25 13:39:40 UTC
Description of problem:
After today updates my system has become unusable: when I log in to KDE I get the error:

Cannot connect to ConsolKit session: unable to open session: failed to connect to socket /var/run/dbus/system_bus_socket: no such file or directory

In the logs I get this error for every program that tries to connect to dbus.
This is the list of updates that broke my system:
Sep 25 13:14:23 Updated: 1:qt-4.8.0-0.11.beta1.fc16.x86_64
Sep 25 13:14:26 Updated: 1:qt-x11-4.8.0-0.11.beta1.fc16.x86_64
Sep 25 13:14:26 Updated: 2:phonon-backend-gstreamer-4.5.90-2.fc16.x86_64
Sep 25 13:14:27 Updated: phonon-4.5.57-1.20110914.fc16.x86_64
Sep 25 13:14:29 Updated: systemd-36-2.fc16.x86_64
Sep 25 13:14:30 Updated: systemd-units-36-2.fc16.x86_64
Sep 25 13:14:30 Updated: abrt-libs-2.0.4.981-1.fc16.x86_64
Sep 25 13:14:31 Updated: abrt-2.0.4.981-1.fc16.x86_64
Sep 25 13:14:32 Updated: systemd-sysv-36-2.fc16.x86_64
Sep 25 13:14:32 Updated: libkgeomap-2.0.0-4.fc16.x86_64
Sep 25 13:14:33 Installed: libwsman1-2.2.5-3.fc16.x86_64
Sep 25 13:14:33 Installed: cairomm-1.10.0-1.fc16.x86_64
Sep 25 13:14:33 Installed: pangomm-2.28.2-1.fc16.x86_64
Sep 25 13:14:35 Updated: libvirt-client-0.9.6-1.fc16.x86_64
Sep 25 13:14:35 Updated: abrt-addon-kerneloops-2.0.4.981-1.fc16.x86_64
Sep 25 13:14:36 Updated: 1:cups-libs-1.5.0-9.fc16.x86_64
Sep 25 13:14:38 Updated: gtk3-3.1.92-2.fc16.x86_64
Sep 25 13:14:40 Updated: webkitgtk3-1.5.90-1.fc16.x86_64
Sep 25 13:14:40 Installed: atkmm-2.22.5-1.fc16.x86_64
Sep 25 13:14:41 Installed: gtkmm24-2.24.2-1.fc16.x86_64
Sep 25 13:14:42 Updated: 1:yelp-libs-3.1.4-2.fc16.x86_64
Sep 25 13:14:44 Updated: 1:yelp-3.1.4-2.fc16.x86_64
Sep 25 13:14:45 Installed: abrt-addon-vmcore-2.0.4.981-1.fc16.x86_64
Sep 25 13:14:45 Updated: abrt-addon-ccpp-2.0.4.981-1.fc16.x86_64
Sep 25 13:14:46 Updated: abrt-addon-python-2.0.4.981-1.fc16.x86_64
Sep 25 13:14:46 Updated: abrt-gui-2.0.4.981-1.fc16.x86_64
Sep 25 13:14:51 Updated: 1:qt-devel-4.8.0-0.11.beta1.fc16.x86_64
Sep 25 13:14:51 Updated: sip-macros-4.12.4-2.fc16.x86_64
Sep 25 13:14:51 Updated: sip-4.12.4-2.fc16.x86_64
Sep 25 13:14:52 Updated: device-mapper-multipath-libs-0.4.9-19.fc16.x86_64
Sep 25 13:14:52 Installed: tbb-3.0-1.20110419.fc16.x86_64
Sep 25 13:14:53 Updated: kpartx-0.4.9-19.fc16.x86_64
Sep 25 13:14:53 Installed: tinyxml-2.6.1-2.fc15.x86_64
Sep 25 13:14:54 Installed: openni-1.0.0.25-0.5.git4c9ff978.fc16.x86_64
Sep 25 13:14:55 Installed: opencv-2.3.1-1.fc16.x86_64
Sep 25 13:14:56 Updated: libkface-2.0.0-4.fc16.x86_64
Sep 25 13:14:56 Updated: digikam-libs-2.0.0-4.fc16.x86_64
Sep 25 13:15:00 Updated: digikam-2.0.0-4.fc16.x86_64
Sep 25 13:15:01 Updated: kipi-plugins-libs-2.0.0-4.fc16.x86_64
Sep 25 13:15:03 Updated: kipi-plugins-2.0.0-4.fc16.x86_64
Sep 25 13:15:04 Updated: 1:NetworkManager-glib-0.9.1.90-1.fc16.x86_64
Sep 25 13:15:05 Updated: 1:NetworkManager-0.9.1.90-1.fc16.x86_64
Sep 25 13:15:05 Updated: device-mapper-multipath-0.4.9-19.fc16.x86_64
Sep 25 13:15:06 Updated: sip-devel-4.12.4-2.fc16.x86_64
Sep 25 13:15:06 Updated: phonon-devel-4.5.57-1.20110914.fc16.x86_64
Sep 25 13:15:06 Updated: abrt-desktop-2.0.4.981-1.fc16.x86_64
Sep 25 13:15:07 Installed: gparted-0.9.0-1.fc16.x86_64
Sep 25 13:15:08 Updated: gtk3-immodule-xim-3.1.92-2.fc16.x86_64
Sep 25 13:15:10 Updated: 1:cups-1.5.0-9.fc16.x86_64
Sep 25 13:15:10 Updated: libvirt-python-0.9.6-1.fc16.x86_64
Sep 25 13:15:13 Updated: libvirt-0.9.6-1.fc16.x86_64
Sep 25 13:15:14 Updated: perl-Net-SSLeay-1.40-1.fc16.x86_64
Sep 25 13:15:14 Updated: xsettings-kde-0.12.2-2.fc16.x86_64
Sep 25 13:15:16 Updated: tzdata-2011k-0.1.20110921.fc16.noarch
Sep 25 13:15:17 Updated: fuse-2.8.6-1.fc16.x86_64
Sep 25 13:15:17 Updated: rhino-1.7R3-2.fc16.noarch
Sep 25 13:15:19 Updated: graphite2-1.0.3-1.fc16.x86_64
Sep 25 13:15:20 Updated: fuse-libs-2.8.6-1.fc16.x86_64
Sep 25 13:15:20 Updated: redhat-rpm-config-9.1.0-18.fc16.noarch
Sep 25 13:15:21 Updated: tzdata-java-2011k-0.1.20110921.fc16.noarch

Comment 1 Mattia Verga 2011-09-25 14:05:04 UTC
I found that this is caused by systemd upgrade.

After downgrading systemd, systemd-units and systemd-sysv to 35-1 now dbus is working again.

Comment 2 Michal Schmidt 2011-09-25 14:21:10 UTC
Yes. This is already fixed in systemd-36-3.fc16.

*** This bug has been marked as a duplicate of bug 741078 ***


Note You need to log in before you can comment on or make changes to this bug.