Bug 743732

Summary: [zh_CN] missing translations in subscription-manager -h
Product: Red Hat Enterprise Linux 6 Reporter: John Sefler <jsefler>
Component: subscription-managerAssignee: Bryan Kearney <bkearney>
Status: CLOSED ERRATA QA Contact: IDM QE LIST <seceng-idm-qe-list>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 6.2CC: lijli, skallesh, spandey, syeghiay
Target Milestone: rcKeywords: Reopened, Translation
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-12-06 12:25:30 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 682238, 747120    

Description John Sefler 2011-10-05 16:31:47 EDT
Description of problem:

# LANG=zh_CN.UTF8 subscription-manager register -h | grep register
使用:subscription-manager register [OPTIONS]



# LANG=zh_CN.UTF8 subscription-manager -h
Usage: subscription-manager [options] MODULENAME --help
^^^^^ TRANSLATION FOR THIS WORD IS MISSING.  IT SHOULD BE 使用

主模块:

	list           为这台机器列出订阅和产品信息。
	refresh        从该服务器中提出最新订阅数据
	register       在 RHN 里注册客户  
	subscribe      在指定的产品中订阅注册的机器
	unregister     在 RHN 里取消客户的注册
	unsubscribe    在所有订阅或者具体订阅中取消订阅该机器

其它模块(请参考文档):

	clean          Remove all local consumer and subscription data without affecting the server
	config         List, set, or remove the configuration parameters in use by this machine.

                       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
                       MISSING TRANSLATIONS FOR clean AND config

	environments   显示用户可用的环境
	facts          在这台机器中使用现有详情
	identity       为这台机器显示 ID 证书或者申请一个新的证书
	import         导入工具之外提供的证书
	orgs           显示用户可以注册系统的机构
	redeem         尝试为预先配置的机器兑现订阅
	repos          列出这台机器授权使用的库



Version-Release number of selected component (if applicable):
# rpm -q subscription-manager
subscription-manager-0.96.11-1.el6.x86_64


How reproducible:


Steps to Reproduce:
1. see description
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bryan Kearney 2011-10-05 16:38:09 EDT

*** This bug has been marked as a duplicate of bug 742128 ***
Comment 2 John Sefler 2011-10-06 09:50:24 EDT
This one untranslated string is NOT a dup of bug 742128 and has never been translated since rhel61 desipite the fact that the word is translated in the other help messages...

# LANG=zh_CN.UTF8 subscription-manager -h
Usage: subscription-manager [options] MODULENAME --help
^^^^^ TRANSLATION FOR THIS WORD IS MISSING.  IT SHOULD BE 使用 AS INDICATED IN THE OTHER HELP MESSAGES SHOWN BELOW

# LANG=zh_CN.UTF8 subscription-manager register -h | grep register
使用:subscription-manager register [OPTIONS]
Comment 4 John Sefler 2011-10-07 08:50:39 EDT
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.13-1.git.0.b1b0502.el6.x86_64

[root@jsefler-onprem-62server ~]# LANG=zh_CN.UTF8 subscription-manager -h | grep subscription-manager
Usage: subscription-manager [options] MODULENAME --help

Error still exists in latest 0.96 build
Comment 5 Bryan Kearney 2011-10-07 13:24:04 EDT
final usage string fixed in b02364db7e119e551d466b48d04916db75de743b
Comment 6 Bryan Kearney 2011-10-07 13:25:03 EDT
*** Bug 743734 has been marked as a duplicate of this bug. ***
Comment 8 John Sefler 2011-10-08 23:28:30 EDT
(In reply to comment #5)
> final usage string fixed in b02364db7e119e551d466b48d04916db75de743b

Not sure what's going on here...  cannot find this commit in master nor RHEL6.2 builds on hudson.  Did it git pushed?


STILL SEEING SEVERAL FAILED CASES...


[root@jsefler-onprem-62server ~]# LANG=fr_FR.UTF8 subscription-manager -h | grep subscription-manager
Usage: subscription-manager [options] MODULENAME --help
^^^^^
THAT'S NOT fr_FR. EXPECTING Utilisation


[root@jsefler-onprem-62server ~]# LANG=zh_CN.UTF8 subscription-manager -h | grep subscription-manager
ব্যৱহাৰ: subscription-manager [বিকল্পসমূহ] MODULENAME --help
^^^^^                        ^^^^^^^
THAT'S NOT zh_CN.  IT'S as_IN.  EXPECTING 使用


[root@jsefler-onprem-62server ~]# LANG=as_IN.UTF8 subscription-manager -h | grep subscription-manager
Usage: subscription-manager [options] MODULENAME --help
^^^^^
THAT'S NOT as_IN.  IN FACT, NO MATTER WHAT I TYPE AFTER LANG=as_IN.UTF8 subscription-manager I FAIL TO GET TRANSLATED RESULTS.


moving back to NEW/FailedQA
Comment 9 Bryan Kearney 2011-10-10 08:23:52 EDT
RHEL 6.2: b02364db7e119e551d466b48d04916db75de743b
Master: 3a2d3ad5cb5900609f9947607b75248d3a680d6d
Comment 10 John Sefler 2011-10-10 10:00:22 EDT
HOT POTATO.. Moving back to to NEW/FailedQA

Not fixed in RHEL62 commit 687a8cf1ad175d732df59e713954d91159f1ae83; still cannot find commit b02364db7e119e551d466b48d04916db75de743b

Not fixed in master commit 3a2d3ad5cb5900609f9947607b75248d3a680d6d

attempt all three cases in comment 8 before putting back ON_QA
Comment 11 Bryan Kearney 2011-10-11 10:55:50 EDT
Two new commits fix the issues. There was a typo in the as.po file. This is fixed in 

master: 37a269921d46b74db0f2b32bc739647aa53263d1
RHEL6.2: 32f7ccac3a8866dfb1176a8caa734b564fcdc4a0


The other is fixed with new strings:

master: 37a269921d46b74db0f2b32bc739647aa53263d1
RHEL6.2: 32f7ccac3a8866dfb1176a8caa734b564fcdc4a0
Comment 13 Shwetha Kallesh 2011-10-12 07:07:38 EDT
Moving the bug to verified.

[root@dhcp193-9 ~]#  LANG=zh_CN.UTF8 subscription-manager -h

使用: subscription-manager [options] MODULENAME --help

主模块:

	list           为这台机器列出订阅和产品信息。
	refresh        从该服务器中提出最新订阅数据
	register       在 RHN 里注册客户  
	subscribe      在指定的产品中订阅注册的机器
	unregister     在 RHN 里取消客户的注册
	unsubscribe    在所有订阅或者具体订阅中取消订阅该机器

其它模块(请参考文档):

	clean          删除所有本地客户和订阅数据而不影响服务器
	config         列出、设置或删除这机器使用的配置参数。
	environments   显示用户可用的环境
	facts          在这台机器中使用现有详情
	identity       为这台机器显示 ID 证书或者申请一个新的证书
	import         导入工具之外提供的证书
	orgs           显示用户可以注册系统的机构
	redeem         尝试为预先配置的机器兑现订阅
	repos          列出这台机器授权使用的库


RPM's used:

[root@dhcp193-9 ~]# rpm -qa | grep subscription-manager
subscription-manager-firstboot-0.97.1-1.git.85.2353df9.el6.x86_64
subscription-manager-gnome-0.97.1-1.git.85.2353df9.el6.x86_64
subscription-manager-0.97.1-1.git.85.2353df9.el6.x86_64
Comment 14 errata-xmlrpc 2011-12-06 12:25:30 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html