This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 744209

Summary: Cannot select the correct MBR for bootloader
Product: [Fedora] Fedora Reporter: Stephen Gallagher <sgallagh>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 16CC: anaconda-maint-list, awilliam, dinyar.rabady+spam, jhall, jonathan, mcjhn1, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-10-19 15:31:40 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 713568    

Description Stephen Gallagher 2011-10-07 09:37:51 EDT
Description of problem:
Anaconda on the Fedora 16 beta image allows only selecting /dev/sda as the MBR. However, on my system the MBR is on the drive detected as /dev/sdb. It should be possible to install the bootloader on the correct partition.

Version-Release number of selected component (if applicable):
Fedora 16 beta x86_64 install DVD

How reproducible:
Every time

Steps to Reproduce:
1. Install Fedora
2. Try to select a boot partition other than /dev/sda or /dev/sdb1
  
Actual results:
Impossible to select the correct drive for the bootloader


Expected results:
Should be possible to choose to install on the MBR of /dev/sdb


Additional info:
The reason behind this is that I have a laptop with an existing OS on the internal HD, and I want to install Fedora 16 on a drive connected via eSATA. I want the bootloader for Fedora 16 to be on the eSATA drive so that I can select it to boot first in the BIOS when the drive is connected and otherwise use the standard bootloader on the internal drive when it's not attached.
Comment 1 dinyar.rabady+spam 2011-10-12 05:46:41 EDT
I have the same problem. Upgrading my Fedora 15 system with the DVD image on an USB key the only MBR I can write the boot loader to is the one on /dev/sdb although this is the USB key.
Comment 2 dinyar.rabady+spam 2011-10-12 06:06:02 EDT
Additional info: The bahaviour I encountered closely matches the one described in https://bugzilla.redhat.com/show_bug.cgi?id=738964 which (judging from https://bugzilla.redhat.com/show_bug.cgi?id=738964#c83) hasn't been fixed.

My system is a Thinkpad X200s.

Let me know if you need anything else.
Comment 3 dinyar.rabady+spam 2011-10-12 09:34:10 EDT
Ok, so just FYI, I booted the system with the USB stick and could then install grub2 easily by executing grub2-install /dev/sda as root.
Comment 4 Jim Hall 2011-10-19 15:11:11 EDT
I have the same problem on a Dell Latitude E6410, and a Dell Latitude D620, so this is not just a problem on Thinkpad. I tried to install the beta to a USB flash drive, but was not able to select the USB flash drive to install the bootloader on the MBR.

I have been able to do this with previous Fedora releases, and has been the standard way I test out new Fedora beta releases.

Similarly, I also use this method to install a "rescue" Fedora system on a bootable USB flash drive.
Comment 5 Stephen Gallagher 2011-10-19 15:28:14 EDT
Proposing for blocker status under the criteria:
"The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above"
Comment 6 Adam Williamson 2011-10-19 15:31:40 EDT

*** This bug has been marked as a duplicate of bug 744088 ***