This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 744088 - On custom partitioning path, when bootloader could be installed to multiple disks' MBRs, anaconda doesn't give you a choice
On custom partitioning path, when bootloader could be installed to multiple d...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 744209 748488 (view as bug list)
Depends On:
Blocks: F16Blocker/F16FinalBlocker
  Show dependency treegraph
 
Reported: 2011-10-06 19:54 EDT by Adam Williamson
Modified: 2011-11-01 00:19 EDT (History)
6 users (show)

See Also:
Fixed In Version: anaconda-16.22-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-20 00:04:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2011-10-06 19:54:04 EDT
When you do custom partitioning in anaconda, bootloader location is chosen after package installation in a dialog that doesn't occur on the non-custom path.

In some cases there will be multiple disks that could potentially have the bootloader installed in their MBRs. For instance, you might have a USB stick plugged in during install, which anaconda identifies as a valid stage1 target; or you might just have two hard disks with different OSes on them.

In the background, anaconda correctly identifies all these potential targets, but the dialog does not offer you a choice of which disk's MBR to put the bootloader on. Only one disk is offered as a possible MBR target.
Comment 1 David Lehman 2011-10-07 11:48:11 EDT
Anaconda has never offered multiple options for mbr targets. Adding that ability would involve UI work that seems both risky and wasteful given the redesign that is already under way for F17.

What if we show the "cleardisks" screen but with all disks on the right and no way to move them back to the left as a way to force boot disk selection? The only negatives I can think of are a) given the title of the screen it may be a bit confusing and b) you'd have to choose your boot disk prior to actually partitioning. Thoughts?
Comment 2 Adam Williamson 2011-10-07 12:51:00 EDT
hum. if this isn't a regression it might be best just to leave it alone until the UI rewrite at this point. I was kind of assuming this was somehow a regression as we'd never come across it before, but I guess it was just because we happened to do more intensive multi-disk testing this cycle.
Comment 3 Adam Williamson 2011-10-07 12:51:47 EDT
would it be easy/safe to make sure that, if there are multiple possible stage1 targets and one of them is the disk with Fedora's / (or /boot) on it, it should go for that one as the MBR target?
Comment 4 David Lehman 2011-10-07 18:11:04 EDT
Too much guessing. I'm tired of all these attempts to guess correctly. I think from now on you should have to choose your boot device no matter what path you take through anaconda, unless there is only one disk.
Comment 5 Adam Williamson 2011-10-07 18:47:29 EDT
well, the problem with using the 'cleardisks' screen is that you can't pick to install to /boot rather than MBR with that screen, can you?
Comment 6 Adam Williamson 2011-10-07 18:48:00 EDT
or is the idea to show *both* screens and use the later one to decide between MBR and root/boot partition?
Comment 7 David Lehman 2011-10-17 10:30:30 EDT
(In reply to comment #6)
> or is the idea to show *both* screens and use the later one to decide between
> MBR and root/boot partition?

Yes -- this is it.
Comment 8 David Lehman 2011-10-17 12:29:33 EDT
The patch is associated with this bug, but the naturally occurring failure is reported in bug 739389. One or both of these should probably block F16. For now I only marked this one since it's the one that's coherent and also mentioned in an existing anaconda commit.
Comment 9 Fedora Update System 2011-10-19 14:44:04 EDT
anaconda-16.22-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/anaconda-16.22-1.fc16
Comment 10 Adam Williamson 2011-10-19 15:31:40 EDT
*** Bug 744209 has been marked as a duplicate of this bug. ***
Comment 11 Fedora Update System 2011-10-19 22:25:44 EDT
Package anaconda-16.22-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-16.22-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-14624
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2011-10-20 00:04:09 EDT
anaconda-16.22-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 David Lehman 2011-10-24 11:41:51 EDT
*** Bug 748488 has been marked as a duplicate of this bug. ***
Comment 14 Adam Williamson 2011-11-01 00:19:32 EDT
*** Bug 737430 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.