This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 748219

Summary: Can't update sssd, broken selinux-policy dependency
Product: [Fedora] Fedora Reporter: Yann Droneaud <yann>
Component: sssdAssignee: Stephen Gallagher <sgallagh>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 16CC: collura, jhrozek, s.binnie, sbose, sgallagh, ssorce, terjeros
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: 389-ds-base-1.2.10-0.4.a4.fc16 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-10-24 23:38:17 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 748336    

Description Yann Droneaud 2011-10-23 04:45:34 EDT
After booting Fedora-16-TC-x86_64-Live-Desktop,
I have enabled all software sources (fedora, updates, test-updates).

I tried to install all available updates, but transaction failed with:

sssd-1.6.2-3.fc16.x86_64 requires selinux-policy >= 3.10.0-46 : Protected multilib versions: sssd-client-1.6.1-1.fc16.i686 != sssd-client-1.6.2-3.fc16.x86_64
Comment 1 Terje Røsten 2011-10-23 14:50:59 EDT
And why is this change done?

Does really sssd need selinux-policy at all?

git has only 

- Add explicit requirement on selinux-policy version to address new SBUS
  symlinks.

bugzilla # reference is?

Or is it just that if selinux-policy (or selinux) is in use selinux-policy it must be >= 3.10.0-46.

Fixing bugs in selinux-policy in sssd seems wrong.


(I ask because I remove all selinux* rpms on my systems, however I need sssd,
adding this explicit requirement makes it impossible to remove selinux-policy)
Comment 2 Jakub Hrozek 2011-10-23 15:11:57 EDT
(In reply to comment #1)
> And why is this change done?
> 
> Does really sssd need selinux-policy at all?
> 
> git has only 
> 
> - Add explicit requirement on selinux-policy version to address new SBUS
>   symlinks.
> 
> bugzilla # reference is?
> 

https://bugzilla.redhat.com/show_bug.cgi?id=747608

> Or is it just that if selinux-policy (or selinux) is in use selinux-policy it
> must be >= 3.10.0-46.
> 

The point is that SSSD 1.6.2 includes a change that *needs* the SELinux rules included in the Required: release, otherwise it won't even start. Otherwise users would run into bugs such as https://bugzilla.redhat.com/show_bug.cgi?id=746665
Comment 3 Terje Røsten 2011-10-23 15:18:13 EDT
Ok, would then 

Conflicts: selinux-policy < 3.10.0-46

be better?
Comment 4 Stephen Gallagher 2011-10-23 16:44:35 EDT
Yes, the correct behaviour would be Conflicts: here. I'm rebuilding the packages this way now.

Thanks for the bug report!
Comment 5 Fedora Update System 2011-10-23 17:02:03 EDT
389-ds-base-1.2.10-0.4.a4.fc16, freeipa-2.1.3-4.fc16, selinux-policy-3.10.0-46.fc16, sssd-1.6.2-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2011-14614
Comment 6 Fedora Update System 2011-10-24 00:00:17 EDT
Package 389-ds-base-1.2.10-0.4.a4.fc16, freeipa-2.1.3-4.fc16, selinux-policy-3.10.0-46.fc16, sssd-1.6.2-4.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing 389-ds-base-1.2.10-0.4.a4.fc16 freeipa-2.1.3-4.fc16 selinux-policy-3.10.0-46.fc16 sssd-1.6.2-4.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-14614
then log in and leave karma (feedback).
Comment 7 collura 2011-10-24 03:48:14 EDT
*** Bug 748336 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2011-10-24 23:38:17 EDT
389-ds-base-1.2.10-0.4.a4.fc16, freeipa-2.1.3-4.fc16, selinux-policy-3.10.0-46.fc16, sssd-1.6.2-4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 collura 2011-10-25 13:30:25 EDT
confirming that after a 'yum clean all' the 2 copies of the sssd-1.6.2-3 updates cleared out so the sssd-1.6.2-4.fc16 (x86_64) did show up and installed fine.