This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 753210

Summary: matplotlib: upgrade to 1.1 release
Product: [Fedora] Fedora Reporter: Scott Tsai <scottt.tw>
Component: python-matplotlibAssignee: Jef Spaleta <jspaleta>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: amcnabb, henriquecsj, jan.teichmann, jdy, jonathan.underwood, jspaleta, liling, limburgher, loganjerry, thibault.north, tomspur, vedran
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-09-04 13:56:48 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On: 810859    
Bug Blocks:    

Description Scott Tsai 2011-11-11 10:54:42 EST
Matplotlib 1.1 was released in early October 2011:
http://sourceforge.net/projects/matplotlib/files/matplotlib/matplotlib-1.1.0/

The new animation feature:
http://matplotlib.sourceforge.net/users/whats_new.html
seems so shiny that I really want to play with it in the next Fedora release.
Comment 1 Vedran Miletić 2011-11-20 14:42:52 EST
Update in F16, if possible, would be nice as well.
Comment 2 Thibault North 2011-12-14 14:52:26 EST
I would also appreciate an update to 1.1.0.
Comment 3 Jerry James 2012-01-03 15:58:12 EST
Also, while we're piling on, would you please add a python3 build, too?  I need it so I can create a python3-cvxopt package.

Jef, if you need help with this, drop me a line.
Comment 4 Thibault North 2012-01-09 16:04:37 EST
Here is a quick and dirty update to 1.1.0. (I am not an owners of matplotlib)
http://koji.fedoraproject.org/koji/taskinfo?taskID=3633916
http://koji.fedoraproject.org/koji/taskinfo?taskID=3633945

Where are the licences in the tar.gz archive ? Seem to be missing.
Comment 5 Jef Spaleta 2012-01-23 13:46:35 EST
Okay I'm back in the country.  I'll start working towards an upgrade in rawhide this week.

Just to let everyone know. I'm pretty much off the grid for a couple of weeks in January every year due to regular schedule trip down to Antarctica.  Not just busy but literally off the grid.  Next year will probably be an even longer trip..at least a month...maybe up to 2 months...where I'll be utterly unresponsive. 

If someone wants to take primary ownership of matplotlib and friends (scipy and basemap among others) over the next few months.  I'll have no qualms about it handing it over.   


-jef
Comment 6 Andrew McNabb 2012-01-27 11:55:33 EST
A python3 build of matplotlib would also be helpful for a python3 build of IPython.
Comment 7 Joel 2012-04-04 19:36:32 EDT
Any progress on getting python and python3 builds for the new matplotlib?
Comment 8 Thibault North 2012-04-04 20:55:55 EDT
AFAIK matplotlib 1.1 does not support python3.

(Hm, scratch build deleted: builds for f16 x86_64 are here:
http://tnorth.fedorapeople.org/python-matplotlib{,tk,wx}-1.1.0-1.fc16.x86_64.rpm
)

Jef, I can co-maintain it if you don't mind. I don't know how much time I will have in the future for that, but at least for now if would be good.
Comment 9 Joel 2012-04-06 17:51:50 EDT
You're right.  1.1 doesn't.  master does.
Comment 10 Henrique "LonelySpooky" Junior 2012-05-27 17:09:04 EDT
(In reply to comment #8)
> AFAIK matplotlib 1.1 does not support python3.
> 
> (Hm, scratch build deleted: builds for f16 x86_64 are here:
> http://tnorth.fedorapeople.org/python-matplotlib{,tk,wx}-1.1.0-1.fc16.x86_64.
> rpm
> )
> 
> Jef, I can co-maintain it if you don't mind. I don't know how much time I
> will have in the future for that, but at least for now if would be good.

Thibault, are you already a co-mantainer?
I know that Jef is a great maintainer, but, as he ultimately did not have the time to dedicate to this package a co-maintainer is indispensable. Fedora is one of the few distros that have not updated the version of matplotlib and it is a problem right now.
Comment 11 Thibault North 2012-05-27 17:27:09 EDT
No, not yet but I applied and am waiting for approval.

I would be happy to commit it after the review of the interested people there as soon as we have the ACL updated: please also apply if you feel like helping!
Comment 12 Henrique "LonelySpooky" Junior 2012-05-27 17:46:52 EDT
(In reply to comment #11)
> No, not yet but I applied and am waiting for approval.
> 
> I would be happy to commit it after the review of the interested people
> there as soon as we have the ACL updated: please also apply if you feel like
> helping!

I'd love to help, but I did not have the time to be an active contributor anymore. I can, however, help testing (adding karma) or reporting bugs if you wish.
Comment 13 Ling Li 2012-07-06 10:39:45 EDT
Guess the matplotlib will be updated in bug 837156?

fwiw, Python3 support will be official in the next major release (according to http://matplotlib.sourceforge.net/users/whats_new.html)
Comment 14 Henrique "LonelySpooky" Junior 2012-09-04 13:53:27 EDT
Didn't we have news about this update?
Comment 15 Jon Ciesla 2012-09-04 13:56:48 EDT
Yes, see the 837156.

*** This bug has been marked as a duplicate of bug 837156 ***