This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes

Bug 753863

Summary: Floppy support broken
Product: [Fedora] Fedora Reporter: Zeeshan Ali <zali>
Component: qemuAssignee: Justin M. Forbes <jforbes>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 16CC: amit.shah, berrange, bloch, cfergeau, crobinso, dougsland, dwmw2, ehabkost, ipilcher, itamar, jaswinder, jforbes, karmstrong, knoel, kwolf, mail, mclasen, scottt.tw, tburke, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: qemu-0.15.1-4.fc16 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-02-08 18:00:51 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
floppy fixes for fedora qemu none

Description Zeeshan Ali 2011-11-14 12:37:21 EST
Description of problem:

Floppy support in qemu is broken and no guest OS (windows or linux) is able to read from floppy images when floppy image path is passed to qemu using '-fda' option rather than '-drive' (i-e always reproducible when using libvirtd). Since the issue has already been fixed in qemu git master by Kevin Wolf, I don't see the need to provide more details as the solution is simply to merge block devices/floppy related patches from Kevin.

Version-Release number of selected component (if applicable): 0.15.1


How reproducible: Always
Comment 1 Kevin Wolf 2011-11-14 12:57:49 EST
The relevant upstream commit IDs are 34d4260e (most definitely required), a18e67f5 and acae6f1c (probably both not required in 0.15).
Comment 2 Justin M. Forbes 2011-11-15 10:54:00 EST
This will make the next update.  Thanks for the report, and thanks for the upstream commit references Kevin.
Comment 3 Christophe Fergeau 2012-01-05 06:51:22 EST
Created attachment 550883 [details]
floppy fixes for fedora qemu

Here is the patch I applied locally to the f16 qemu package to get working floppy devices. The 34d4260e184 commit needed some (trivial) rediffing in hw/pc_piix.c
I tested that floppy support was fixed by dowloading a DOS floppy image used for bios flashing and starting it with 
qemu-kvm -drive file=DRDFLASH.IMG,if=none,id=fdc,format=raw -global isa-fdc.driveA=fdc
With the current fedora package, this fails with "no bootable devices found", with a package built with the attached patch, I get to a dos prompt
Comment 4 Cole Robinson 2012-01-24 19:23:12 EST
Justin, any word on this?
Comment 5 Christophe Fergeau 2012-01-25 04:31:13 EST
I've uploaded a qemu 0.15 package with this patch to http://teuf.fedorapeople.org/boxes/gnome-boxes-preview.repo if that can help with testing.
Comment 6 Fedora Update System 2012-01-30 15:49:09 EST
qemu-0.15.1-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/qemu-0.15.1-4.fc16
Comment 7 Fedora Update System 2012-01-31 17:02:20 EST
Package qemu-0.15.1-4.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qemu-0.15.1-4.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-1080/qemu-0.15.1-4.fc16
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-02-08 18:00:51 EST
qemu-0.15.1-4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.