Bug 763851 (GLUSTER-2119)

Summary: [glusterfs-3.1.1qa8]: gluster volume set sets wrong options also
Product: [Community] GlusterFS Reporter: Raghavendra Bhat <rabhat>
Component: glusterdAssignee: Kaushal <kaushal>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: low    
Version: 3.1.0CC: fharshav, gluster-bugs, hz02ruc, vijay
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-04-04 09:52:56 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Raghavendra Bhat 2010-11-17 00:44:01 EST
gluster volume set sets wrong options also. Accoding to the documentation

(http://www.gluster.com/community/documentation/index.php/Gluster_3.1:_Setting_Volume_Options)






performance.cache-min-file-size       ( 0 < min-file-size )
performance.cache-max-file-size       ( 0 < max-file-size > min-file-size )
performance.cache-refresh-timeout     ( 0 < cache-timeout < 61 )
cluster.read-subvolume                ( The subvolume name on which read operations should be performed on)
cluster.stripe-block-size             ( list such as : "*.jpg:1,abc*:2" )
cluster.self-heal-window-size         ( 0 < data-self-heal-window-size < 1025)
network.frame-timeout                 ( 5 < frame-timeout < 86400 )   
network.ping-timeout                  ( 0 < ping-timeout < 1014 )
auth.allow                            ( valid IP address which includes wild card               
auth.reject                             patterns including *, such as 192.168.1.* )
performance.cache-size                ( 4MB < cache-size < 6GB )
performance.write-behind-window-size  ( Write-behind cache size )
diagnostics.latency-measurement       ( yes/no )
diagnostics.dump-fd-stats             ( yes/no )
diagnostics.brick-log-level           ( DEBUG|WARNING|ERROR|CRITICAL|NONE|TRACE )
diagnostics.client-log-level          ( DEBUG|WARNING|ERROR|CRITICAL|NONE|TRACE )








minimum file size for cachind should be greater than 0. But the following command

gluster volume set mirror performance.cache-min-file-size 0
Set volume successful
root@bigbang:/home/raghu#


succeeds.
Comment 1 kaushik 2010-12-10 05:38:17 EST
*** Bug 1880 has been marked as a duplicate of this bug. ***
Comment 2 kaushik 2011-01-06 01:51:16 EST
*** Bug 2275 has been marked as a duplicate of this bug. ***
Comment 3 kaushik 2011-03-28 22:34:54 EDT
(In reply to comment #2)
> *** Bug 2275 has been marked as a duplicate of this bug. ***
Fixed with the patch http://patches.gluster.com/patch/6561/ against the commit head 9bd4f25b6b0ea8103324b685fcc21525a29849a8
Comment 4 Raghavendra Bhat 2011-04-08 08:08:43 EDT
This bug still exists in glusterfs-3.2.0qa10.



[root@centos-rahul-2 ~]# gluster volume set mirror performance.cache-min-file-size 0

Set volume successful
[root@centos-rahul-2 ~]#
[root@centos-rahul-2 ~]# gluster volume info

Volume Name: mirror
Type: Replicate
Status: Started
Number of Bricks: 2
Transport-type: tcp
Bricks:
Brick1: 10.1.12.171:/export/mirror
Brick2: 10.1.12.172:/export/mirror
Options Reconfigured:
performance.cache-min-file-size: 0
diagnostics.count-fop-hits: on
diagnostics.latency-measurement: on
features.quota: on
features.marker-gsync: on



[root@centos-rahul-2 ~]# gluster --version
glusterfs 3.2.0qa10 built on Apr  7 2011 21:19:20
Repository revision: v3.2.0qa10
Copyright (c) 2006-2010 Gluster Inc. <http://www.gluster.com>
GlusterFS comes with ABSOLUTELY NO WARRANTY.
You may redistribute copies of GlusterFS under the terms of the GNU Affero General Public License.
[root@centos-rahul-2 ~]#
Comment 5 Harshavardhana 2011-11-07 14:51:48 EST
(In reply to comment #4)
> This bug still exists in glusterfs-3.2.0qa10.
> 
This is not a Bug.
Comment 6 Kaushal 2012-04-04 09:52:56 EDT
As Harsha said above.