Bug 1880 - problem with script /etc/X11/xdm/Xsession
problem with script /etc/X11/xdm/Xsession
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
5.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-03-30 09:59 EST by Dimitri Papadopoulos
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-30 15:52:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dimitri Papadopoulos 1999-03-30 09:59:30 EST
The file /etc/X11/xdm/Xsession is not the original XFree86
one. It has been enhanced - probably by Red Hat.

This enhancement has introduced a bug in line 54:
	    exec "$startup $@"
where:
* "$startup" is $HOME/.xsession
* "$@" is whatever options are passed to the script
  by xdm or an equivalent program.
The script will try to exec a file in the $PATH with
the name "$startup $@" instead of a program with the
name "$startup" followed by command-line arguments "$@".


To fix this problem, change line 54 from
	    exec "$startup $@"
to
	    exec "$startup" "$@"



I am trying to install KDE and its kdm display manager.
In kdm, the user is able to choose the type of the session
- `failsafe' or `kde' or `CDE' or `fvwm' or whatever.
I have added an .xsession file to my home directory.
If I choose any session type that is not `failsafe',
let's say `kde', the script fails because it tries to
exec "/home/papadopo/.xsession kde".

I want to modify as few system files as possible. I chose
to create a .Xclients file instead of a .xsession file in
my home directory. The drawback is that no session type
argument is passed anymore from  /etc/X11/xdm/Xsession to
.Xclients: I can only choose between `failsafe' which is
handled directly in /etc/X11/xdm/Xsession and another
environment defined in .Xclients.
Comment 1 Preston Brown 1999-03-30 15:52:59 EST
This has been fixed in later releases of Red Hat Linux (5.2 and
greater). Please have a look at the /etc/X11/xdm/Xsession file from a
recent build of RawHide, and if you have any suggestions on improving
that one, report back to me.

Note You need to log in before you can comment on or make changes to this bug.