Bug 77193

Summary: kswapd causing random installation crashes
Product: [Retired] Red Hat Linux Reporter: Justin Garrett <usjgarrett>
Component: kernelAssignee: Dave Jones <davej>
Status: CLOSED NOTABUG QA Contact: Brock Organ <borgan>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0CC: pfrields
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-12-17 02:36:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Justin Garrett 2002-11-02 18:23:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2a) Gecko/20020910

Description of problem:
CPU: 0 Oops:0000
EIP: 0010:[<c01472db>] Not tainted
EFLAGS: 00010246

EIP is at (2.4.18-14BOOT)
eax: 00000000 ebx: fffffff8  ecx: 00000000 edx: c1b76000
esi: 00000000 edi: 00000000  ebp: 0000a9d0 esp: c1b77f94<F12> next screen
ds: 0018 es:0018 ss:0018
Process kswapd (pid: 4, stackpage=c1b77000)
Stack: c1b76000 00000283 eefce058 ee4451d8 000001d0 00001c22 00000002 0004e000
       c01473e4 00010cbd c012f0d8 00000001 000001d0 c33d2f08 000001d0 000001d0
       c1b76000 00000000 c012f247 000001d0 00010f00 c31d1fb8 c0105000 c0106fc6
Call Trace: [<c01473e4>]  (0xc1b77fb4))
[<c012f0d8>] (0xc1b77fbc))
[<c012f247>] (0xc1b77fdc))
[<c0105000>] (0xc1b77fec))
[<c0106fc6>] (0xc1b77ff0))
[<c012f1e0>] (0xc1b77ff8))

Code: 8b 83 fc 00 00 00 a9 38 00 00 00 8b 76 04 75 08 0b 83 c0 00

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install over HTTP, cdrom
2. workstation and custom install (didn't try the others)
	

Actual Results:  Random crashes with kswapd

Additional info:

896 MB RAM
Dual PII 400Mhz

Comment 1 Arjan van de Ven 2002-11-04 22:30:15 UTC
can you try typing "linux mem=xxxM" (where xxx is the amount of memory you have
minus 32, eg 864) at the very first screen?

Comment 2 Justin Garrett 2002-11-07 19:59:57 UTC
I tried linux=864M and that got me past the kswapd failures.  However I've 
experienced many other random failures.  

1) received signal 11
2) error installing package x...This is a fatal error (different than bug 75377)
3) script abnormally exited

I finally got it to install but then the system was extremely unstable.  This 
was under smp and non-smp kernels.

I tried installing 7.3 with same result.  I'm now under the impression this is 
some sort of hardware failure.