Bug 75377 - (pyschediscinfo) Hitting a bad package can lead to a traceback
Hitting a bad package can lead to a traceback
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
: 71269 74718 75093 75197 75201 75227 75246 75258 75263 75310 75360 75441 75456 75475 75559 75721 75766 75775 75837 75848 75921 75929 75962 76038 76045 76249 76299 76404 76405 76412 76413 76585 76611 76784 76818 76850 76864 76988 76994 77033 77141 77257 77261 77321 77566 77595 77819 77879 77891 77925 77931 78012 78030 78136 78154 78208 78226 78315 78454 78476 78525 78585 78656 78712 78714 78757 78797 78833 78847 78853 78869 78985 79019 79265 79369 79432 79614 79628 79741 79908 80107 80630 80637 81088 81274 81333 81337 81376 81442 81616 82154 82335 82775 82908 83083 83093 83256 83275 83346 83465 83796 83804 83831 84050 84563 84895 84899 85383 85412 85438 85693 86169 86348 86462 87387 88694 89095 89550 90813 91609 91614 97025 97429 97882 97993 98711 101144 103143 104487 104590 110559 115532 117811 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-07 16:42 EDT by Jeremy Katz
Modified: 2007-04-18 12:47 EDT (History)
60 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-24 14:55:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Blocco lettura RPM (153.59 KB, text/plain)
2002-10-30 06:01 EST, ilario pescarolo
no flags Details

  None (edit)
Description Jeremy Katz 2002-10-07 16:42:59 EDT
If you hit a case where a package can't be read and you get prompted to try
again, you can end up in a case where the CD isn't mounted, so trying to read
the .discinfo file fails.
Comment 1 Jeremy Katz 2002-10-07 16:52:36 EDT
*** Bug 75246 has been marked as a duplicate of this bug. ***
Comment 2 Jeremy Katz 2002-10-07 16:54:23 EDT
*** Bug 74718 has been marked as a duplicate of this bug. ***
Comment 3 Jeremy Katz 2002-10-07 16:54:43 EDT
*** Bug 75258 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2002-10-07 16:56:24 EDT
*** Bug 75263 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Katz 2002-10-07 17:01:00 EDT
*** Bug 75310 has been marked as a duplicate of this bug. ***
Comment 6 Jeremy Katz 2002-10-07 17:10:49 EDT
*** Bug 75360 has been marked as a duplicate of this bug. ***
Comment 7 chris candrl 2002-10-07 17:43:23 EDT
I have also been able to replicate this on the 7.3 iso's.  I had to go back to
7.1 to get an install.  Next, I tried an upgrade to 8.0 which also failed. So,
now I'm trying the upgrade to 7.3.  Which has subsequently failed.......
Comment 8 Jeremy Katz 2002-10-07 17:56:14 EDT
Actually, the failure case under 7.3 is different.  And in fixing it, it
uncovered something else.  Unfortunately, my CD-ROM drives were correcting
errors before they got to the level where this code would get triggered when I
tested the fix :/

An update disk for Red Hat Linux 8.0 is available at
http://people.redhat.com/~katzj/8.0-cdread.img that should correct this problem.
 If you download this image and place it on a floppy disk (using dd or rawrite
as with a boot disk), and then boot with 'linux updates' from the syslinux
prompt, you will be prompted to provide this disk.
Comment 9 Jeremy Katz 2002-10-07 18:07:56 EDT
*** Bug 75201 has been marked as a duplicate of this bug. ***
Comment 10 Jeremy Katz 2002-10-07 18:08:12 EDT
*** Bug 75227 has been marked as a duplicate of this bug. ***
Comment 11 chris candrl 2002-10-07 19:11:01 EDT
I tried the 8.0-cdread.img file.  Same read error.  However, this time when I
hit "okay" the cd was ejected and I was prompted to insert disk 1.  I pushed the
cd back in, it remounted and the install continued.  This happened 7 times on
Disk 1.    Disk 2 and 3 did not have the any problems. 

As it stands now I have a fully working machine.  Thanks for the quick fix.
Comment 12 Adam Pribyl 2002-10-08 01:26:56 EDT
So this image corrects bug I mentioned as no.1 from bug #74718 - anaconda not
able handle situation.
Now left to find why CD is unmounted, mount directory deleted and device is
changing from hdc to cdrom and vice versa.
Comment 13 Need Real Name 2002-10-09 11:23:09 EDT
Tried your fix.  Rawrite won't find a file not in 8.3 format "8.0-cdread.img" 
has 10 characters in front of the extension.  Understand that I'm a complete 
newbie at Linux, so forgive me if I don't know something obvious.  Even tried 
renaming the file to "80cdread.img" and did a rawrite to a floppy, but once I 
ran the linux updates command anaconda started up and received a "signal 11" 
and aborted.  What am I doing wrong here?
Comment 14 Jeremy Katz 2002-10-09 11:25:03 EDT
*** Bug 75201 has been marked as a duplicate of this bug. ***
Comment 15 Jeremy Katz 2002-10-09 11:33:55 EDT
*** Bug 75441 has been marked as a duplicate of this bug. ***
Comment 16 Jeremy Katz 2002-10-09 11:37:29 EDT
*** Bug 75475 has been marked as a duplicate of this bug. ***
Comment 17 Rusty Samuelson 2002-10-09 14:13:10 EDT
Rather than rawwrite use rawwritewin. Both are located in the dosutils directory under RH Linux 8.0 on the ftp 
sites. Besides rawwritewin, download also the one dll file.

The rawwritewin app is more compatible with 
the later windows releases, imho.
Its straightforward.

Haven't had the chance to apply the path but I do 
have the diskette readied.
Comment 18 Jeremy Katz 2002-10-09 19:57:07 EDT
*** Bug 75559 has been marked as a duplicate of this bug. ***
Comment 19 Jeremy Katz 2002-10-14 05:25:27 EDT
*** Bug 75848 has been marked as a duplicate of this bug. ***
Comment 20 Jeremy Katz 2002-10-14 05:26:26 EDT
*** Bug 75837 has been marked as a duplicate of this bug. ***
Comment 21 Jeremy Katz 2002-10-14 05:30:54 EDT
*** Bug 75775 has been marked as a duplicate of this bug. ***
Comment 22 Jeremy Katz 2002-10-14 05:31:06 EDT
*** Bug 75766 has been marked as a duplicate of this bug. ***
Comment 23 Ben Ramsey 2002-10-14 10:53:32 EDT
Burning the ISO to disk and then installing from CD seems to work best.  I
didn't have any problems with the installation that way.
Comment 24 Jeremy Katz 2002-10-14 13:52:02 EDT
*** Bug 75721 has been marked as a duplicate of this bug. ***
Comment 25 Gautam Saha 2002-10-14 17:17:34 EDT
When I tried to save the http://people.redhat.com/~katzj/8.0-cdread.img  file in a floppy (1.44MB) I got into disk space problem as the file
is > 1.44MB.  I think I am not clear about the steps:
I am not able to install RH8.0 yet (has Win98 in another partition)
1. Can I download the file in my hard drive and then use some tool (dd?, don't know how to use it) to
move the file in a floppy.
2. Is dd or rawrite linux tools. How to use it?
Comment 26 Jeremy Katz 2002-10-15 10:20:19 EDT
*** Bug 75962 has been marked as a duplicate of this bug. ***
Comment 27 Jeremy Katz 2002-10-15 10:30:45 EDT
*** Bug 75921 has been marked as a duplicate of this bug. ***
Comment 28 Jeremy Katz 2002-10-15 10:31:40 EDT
*** Bug 75929 has been marked as a duplicate of this bug. ***
Comment 29 Jeremy Katz 2002-10-16 09:36:20 EDT
*** Bug 76038 has been marked as a duplicate of this bug. ***
Comment 30 Jeremy Katz 2002-10-16 09:37:03 EDT
*** Bug 76045 has been marked as a duplicate of this bug. ***
Comment 31 Don Babcock 2002-10-16 13:34:14 EDT
I had most of the same problems listed. The cdread.img helped except that there 
are some packages that result in a "fatal" error and as such do not allow you 
the opportunity of a retry. If they did, I think I might have made it.

This is a serious problem. I've tried a couple of different images from 
different mirrors and I don't think it is a problem with the download. The 
installs are being attempted on DELL GX150's and this is a new machine. It did 
the same on the older Dells we have too.
Comment 32 Bart Laarhoven 2002-10-19 15:04:26 EDT
This still doesn't work for me. I "only" tried 3 times, so I'll go on trying, 
but it gives, after re-insertion of the first CD, the same error.
Comment 33 Jeremy Katz 2002-10-19 15:34:15 EDT
*** Bug 76249 has been marked as a duplicate of this bug. ***
Comment 34 Jeremy Katz 2002-10-19 15:36:06 EDT
*** Bug 76299 has been marked as a duplicate of this bug. ***
Comment 35 Jeremy Katz 2002-10-21 00:15:26 EDT
*** Bug 75093 has been marked as a duplicate of this bug. ***
Comment 36 Jeremy Katz 2002-10-21 09:57:53 EDT
*** Bug 76404 has been marked as a duplicate of this bug. ***
Comment 37 Don Babcock 2002-10-21 15:04:46 EDT
Tried this weekend with generic AMD 500Mhz machine with the SAME CD's that I 
tried with my Dell's (INTEL). Install worked flawlessly without so much as a 
hiccup. This "feels" like something is going on with the CD drives/error 
correction or something related. Either that or the Dell bioses have something 
unusual in them that is corrupting things. On both Dell's I get "bad magic - 
cpio" messages at the very start just before the linux install prompt appears 
indicating something wrong with the CD images apparently. Yet these same CD's 
load other machines just fine. Until I got a flawless install on the generic 
AMD box, I suspected my downloads (even though the media checks are good.) Now 
I suspect something in the Dell architecture/devices.
Comment 38 burke almquist 2002-10-22 20:30:18 EDT
I had the same problem on a shuttle AI61 board using a generic ide-cdrom
its a slot-A board that uses the AMD chipset. Its not just a dell bios problem.
My mitsumi cd-rw drive on my other box says the media is ok when you do the
media check. But when i test the same disc on my athlon system, ive gotten both
good and bad results, but it always locksup during the install or does the fatal
package error thing.
Comment 39 Don Babcock 2002-10-22 22:58:27 EDT
My other suspicion is the video hardware or something to do with that. The 
tranceback messages/packages seem to have a video "flavor/theme" to them if the 
naming conventions mean anything. (gui.py and the like.) Just a hunch. I may 
try a different CDROM, taking the one out of the "flawless" machine and putting 
it into the Dell, just to eliminate one variable. The Dell's have on board 
video so I can't change the video easily.
Comment 40 Michael Fulbright 2002-10-23 15:38:12 EDT
*** Bug 76585 has been marked as a duplicate of this bug. ***
Comment 41 Michael Fulbright 2002-10-23 15:44:56 EDT
*** Bug 76413 has been marked as a duplicate of this bug. ***
Comment 42 Michael Fulbright 2002-10-23 16:09:20 EDT
*** Bug 76412 has been marked as a duplicate of this bug. ***
Comment 43 Michael Fulbright 2002-10-24 14:52:12 EDT
*** Bug 76611 has been marked as a duplicate of this bug. ***
Comment 44 Michael Fulbright 2002-10-24 14:55:26 EDT
*** Bug 76405 has been marked as a duplicate of this bug. ***
Comment 45 Need Real Name 2002-10-29 16:31:37 EST
I tried the update disk and I still have this problem installing 8.0.  Every
time it gets to zlip, it fails.  Hitting OK at the traceback results in a reboot.
Comment 46 ilario pescarolo 2002-10-30 06:01:39 EST
Created attachment 82664 [details]
Blocco lettura RPM
Comment 47 Need Real Name 2002-10-30 10:54:38 EST
I tried making the floppy in order to get some kind of debugging info.  It did
make a floppy, but it seems wrong.  It contains only the following files:

[rutt@mojo floppy]$ ls
boot.msg    general.msg  ldlinux.sys  rescue.msg  syslinux.cfg	vmlinuz
expert.msg  initrd.img	 param.msg    snake.msg   template.img

Is one of these the right thing?

Anyway, I'm dead in the water at the moment.  Using the updates floppy as
suggested in the fix message seems to do nothing.  I'd suspect that I have a bad
cd, but the problem is repeatable and also occurs exactly with the zlib install
as reported in earlier reports, so this doesn't really seem likely.

Please help soon.
Comment 48 Need Real Name 2002-10-30 12:50:50 EST
After a closer reading of the comments above I tried swapping cd drives and had
no problem during the installation.

The problem cd drive was an Acer cdrw 1208a--002.  Perhaps this info will help
someone else.
Comment 49 Michael Fulbright 2002-10-30 15:48:34 EST
*** Bug 76818 has been marked as a duplicate of this bug. ***
Comment 50 Michael Fulbright 2002-10-30 16:38:48 EST
*** Bug 76994 has been marked as a duplicate of this bug. ***
Comment 51 Michael Fulbright 2002-10-30 16:41:09 EST
*** Bug 76988 has been marked as a duplicate of this bug. ***
Comment 52 Michael Fulbright 2002-10-30 17:09:26 EST
*** Bug 76864 has been marked as a duplicate of this bug. ***
Comment 53 Michael Fulbright 2002-10-30 17:10:29 EST
*** Bug 76864 has been marked as a duplicate of this bug. ***
Comment 54 Michael Fulbright 2002-10-30 17:37:11 EST
*** Bug 76784 has been marked as a duplicate of this bug. ***
Comment 55 Michael Fulbright 2002-10-30 17:44:15 EST
*** Bug 76850 has been marked as a duplicate of this bug. ***
Comment 56 Michael Fulbright 2002-10-30 17:44:30 EST
*** Bug 76850 has been marked as a duplicate of this bug. ***
Comment 57 Adam Pribyl 2002-10-31 12:34:08 EST
Still I see problem. This bug says:
"If you hit a case where a package can't be read and you get prompted to try
again, you can end up in a case where the CD isn't mounted, so trying to read
the .discinfo file fails."
OK, but why installer is missing package?
In my opinion, this happens in reversed order than bug is saiing - means first
/tmp/hdc disappears, then package is corrupted, and then also .discinfo is not
found.
So .img solves only traceback problem of anaconda not the roots...

Comment 58 Michael Fulbright 2002-10-31 12:46:50 EST
*** Bug 77033 has been marked as a duplicate of this bug. ***
Comment 59 Michael Fulbright 2002-11-04 16:23:54 EST
*** Bug 77261 has been marked as a duplicate of this bug. ***
Comment 60 Michael Fulbright 2002-11-04 16:26:23 EST
*** Bug 77257 has been marked as a duplicate of this bug. ***
Comment 61 Michael Fulbright 2002-11-04 17:32:31 EST
*** Bug 77141 has been marked as a duplicate of this bug. ***
Comment 62 Michael Fulbright 2002-11-05 15:36:15 EST
*** Bug 77321 has been marked as a duplicate of this bug. ***
Comment 63 Michael Fulbright 2002-11-06 12:05:32 EST
*** Bug 75456 has been marked as a duplicate of this bug. ***
Comment 64 Michael Fulbright 2002-11-11 10:39:59 EST
*** Bug 77595 has been marked as a duplicate of this bug. ***
Comment 65 Don Babcock 2002-11-11 14:36:35 EST
FWIW - I've done at least two other installs on an IBM 300P (Pentium III) and 
an old AMD 233-K6 machine and the SAME CD's that blew up on my Dells had no 
trouble whatsoever with the install.
Comment 66 Michael Fulbright 2002-11-14 17:13:55 EST
*** Bug 77891 has been marked as a duplicate of this bug. ***
Comment 67 Michael Fulbright 2002-11-14 17:14:48 EST
*** Bug 77891 has been marked as a duplicate of this bug. ***
Comment 68 Michael Fulbright 2002-11-14 17:15:09 EST
*** Bug 77891 has been marked as a duplicate of this bug. ***
Comment 69 Michael Fulbright 2002-11-14 17:35:51 EST
*** Bug 77819 has been marked as a duplicate of this bug. ***
Comment 70 Michael Fulbright 2002-11-18 15:26:22 EST
*** Bug 77925 has been marked as a duplicate of this bug. ***
Comment 71 Michael Fulbright 2002-11-18 15:32:56 EST
*** Bug 78030 has been marked as a duplicate of this bug. ***
Comment 72 Michael Fulbright 2002-11-18 15:34:30 EST
*** Bug 78012 has been marked as a duplicate of this bug. ***
Comment 73 David Falco 2002-11-19 02:27:30 EST
Guys,
Forgive my ignorance, but like some of the other comments made here, I have no 
idea how to execute the procedures written to resolve this error and install 
RedHat 8.0 on my PC. I think there is too much Linux knowledge assumed here.
I have a goal which is to find something better than a Windows platform and I 
was really hoping RedHat Linux was the way to go. So far I have 6 impressive 
CD's which I bought and no Linux on my PC.
Can someone "in the know" list a set of steps of how to resolve this problem. I 
don't even care if it is just a work-a-round, as long as I can get RedHat 8.0 
installed on my PC. Fitting files greater than 1.44 on to a floppy would be a 
good starting point.
Thanks in advance for the copius amounts of help coming my way.
Comment 74 Michael Fulbright 2002-11-19 13:35:41 EST
*** Bug 78154 has been marked as a duplicate of this bug. ***
Comment 75 Michael Fulbright 2002-11-19 13:41:45 EST
*** Bug 78136 has been marked as a duplicate of this bug. ***
Comment 76 Michael Fulbright 2002-11-19 13:49:15 EST
*** Bug 77931 has been marked as a duplicate of this bug. ***
Comment 77 Michael Fulbright 2002-11-19 15:08:50 EST
*** Bug 77879 has been marked as a duplicate of this bug. ***
Comment 78 Michael Fulbright 2002-11-19 15:12:53 EST
*** Bug 77566 has been marked as a duplicate of this bug. ***
Comment 79 Michael Fulbright 2002-11-22 10:15:34 EST
*** Bug 78315 has been marked as a duplicate of this bug. ***
Comment 80 Michael Fulbright 2002-11-22 10:21:30 EST
*** Bug 78208 has been marked as a duplicate of this bug. ***
Comment 81 Michael Fulbright 2002-11-26 16:06:49 EST
*** Bug 78525 has been marked as a duplicate of this bug. ***
Comment 82 Michael Fulbright 2002-11-26 16:07:44 EST
*** Bug 78476 has been marked as a duplicate of this bug. ***
Comment 83 Michael Fulbright 2002-11-26 17:18:11 EST
*** Bug 78585 has been marked as a duplicate of this bug. ***
Comment 84 Michael Fulbright 2002-11-26 17:32:02 EST
*** Bug 78454 has been marked as a duplicate of this bug. ***
Comment 85 Michael Lee Yohe 2002-11-27 23:28:01 EST
I added this comment to Bug 78656 (which appears to be a duplicate of this bug).
 The reporter seemed a bit confused on the steps necessary to apply the image to
a floppy.  Hopefully my comments will help out (please feel free to amend the
steps if I left out something).

The boot portion of the Red Hat Linux 8.0 installation disc and Anaconda, the
Red Hat Linux installer, were designed with the philosophy that even the "gold"
edition could have bugs that hinder Red Hat Linux being installed on certain
systems.  The .discinfo problem seems to be sort of a timing issue -
specifically related to certain CD-ROM drives (I might be over-simplifying the
problem).  Nonetheless, people filed the bug in Bugzilla - the Red Hat engineers
went to work to create an update image.

When you first put in the Red Hat Linux 8.0 disc 1, it shows you a text screen
showing some options.  Typing "linux updates" at the prompt let's the
installation know that you have a disk that contains some patches or workarounds
to get rid of a problem.  You will then be asked to provide the disk that you
wrote the image on.

See the following steps:

1. Most people have access to a Windows machine - if you do, you should first
obtain the rawwritewin application.  You can find the rawwritewin application at
the following address:
ftp://mirror.hiwaay.net/redhat/redhat/linux/8.0/en/os/i386/dosutils/rawritewin/

If you have access to a Linux box, you can also use "dd" - go to step 2.

Download all the files in the directory to your local computer. "rawwritewin"
will take an image (like the image file mentioned in the bug report) and
byte-for-byte write it to your floppy disk.

2. You should then download the actual image to be written to the floppy disk.
http://people.redhat.com/~katzj/8.0-cdread.img - place the 8.0-cdread.img file
in a convenient location.

3. Put a 1.44M floppy disk in your drive - make sure you don't mind losing
everything on the disk!

4. Windows - Double-click "rawwritewin.exe" (where ever you put the file) - it 
will pop-up a dialog box that says "Write", "Read", etc. in the tabs.  The 
Floppy Drive selection box should already be set to your default A: drive. 
Click the "..." button to the right of the Image file: text box.  Now, find the
 image that you downloaded - Click OK.  Now click the "Write" button in the
lower right of your tab area.  This will byte-for-byte write the update disk to
your floppy.

Linux - if you have the image in a convenient spot - you can write the image as
such: dd if=<path to image file>/8.0-cdread.img of=/dev/fd0 bs=1440k

5. Now you are ready to install Red Hat Linux 8.0 again!

6. Boot off disc 1.

7. Text will appear (the SYSLINUX menu) - at the prompt type: linux updates

8. Follow the instructions and you should be good-to-go.

I hope this helps you out.
Comment 86 Need Real Name 2002-11-29 20:16:59 EST
*** Bug 78712 has been marked as a duplicate of this bug. ***
Comment 87 Michael Fulbright 2002-12-02 10:56:30 EST
*** Bug 78853 has been marked as a duplicate of this bug. ***
Comment 88 Michael Fulbright 2002-12-02 11:00:26 EST
*** Bug 78797 has been marked as a duplicate of this bug. ***
Comment 89 Michael Fulbright 2002-12-02 11:03:44 EST
*** Bug 78757 has been marked as a duplicate of this bug. ***
Comment 90 Michael Fulbright 2002-12-02 11:06:39 EST
*** Bug 78656 has been marked as a duplicate of this bug. ***
Comment 91 Jeff Johnson 2002-12-03 13:51:59 EST
*** Bug 78869 has been marked as a duplicate of this bug. ***
Comment 92 Michael Fulbright 2002-12-06 12:29:42 EST
*** Bug 79019 has been marked as a duplicate of this bug. ***
Comment 93 Michael Fulbright 2002-12-06 12:30:02 EST
*** Bug 78985 has been marked as a duplicate of this bug. ***
Comment 94 Michael Fulbright 2002-12-09 14:48:49 EST
*** Bug 79265 has been marked as a duplicate of this bug. ***
Comment 95 Need Real Name 2002-12-12 03:42:44 EST
hmm...i get a problem like this. it cant install slang-1.4.5-11.i286.rpm
i think this is a problem that happends every day at 1000's of people. and its 
a big - for Red Hat.
anyway, ill try what michael wrote above me, dont know if i can do it. alltough 
its maybe a perfect answer. im not english speaking, so its more difficult to 
me.
Comment 96 Michael Lee Yohe 2002-12-12 11:45:34 EST
I have been informed by quite a few people that my plain-explanation of how to
apply the above fix has been helpful.  There are some, however, that still have
problems installing Red Hat Linux 8.0 even after applying katzj's update.  After
investigating one-on-one with various people having the ".discinfo" problem -
I've come up with the following conclusion which I added to Bug 79369.

I am beginning to think that there are two actual problems - though one is
dependent on the vast number of others.

First problem - Anaconda that is shipped with Red Hat Linux 8.0 does not
properly handle the inability to read packages that appear to be "corrupt" (to
some degree).  This is largely corrected by the procedures listed in bug 75377.

Second problem - ailing CD-ROM drives (be it a dirty lens, firmware issues, or a
failing drive altogether) seem to trigger this bug.

You have properly pointed out that it installs without a hitch on your laptop
(thus, the CDs themselves are good - which means the stock shipment of Anaconda
never encounters the second problem [which triggers the first problem]).  I
would suggest the following:

1) Replace the EIDE cable from the motherboard that attaches to your CD-ROM
drive with a fresh one.  Bad cables are notorious for spurring strange errors
(seek and read).  Install again.

If it installs properly - the culprit seems to be the faulty cable.
If not, proceed to step two.

2) Move your CD-ROM drive to a different EIDE interface (for example, from the
secondary channel master to the primary channel slave).  Install again.

If it installs properly, then there is a quirk between the interface of your
CD-ROM and the EIDE controller.  This could be due to a variety of factors - namely:

   (1) failing CD-ROM chipset - I've had a hard drive that would work only as a
slave.
   (2) failing EIDE controller on the motherboard - I've had a channel go flaky
on a motherboard and then quit functioning altogether.

If it does not install properly, proceed to step three.

3) Replace your CD-ROM drive with a new one (or one that has successfully
installed Red Hat Linux 8.0 on a machine).

If it installs properly, your original CD-ROM drive may need to be cleaned or it
is out of calibration (which should never happen, but if it does it means CD-ROM
drive death).

By step 3 you should be able to install Red Hat Linux 8.0 without a hitch.  Even
the Windows installer does not handle ailing CD-ROM drives (or EIDE interfaces)
gracefully.  Hardware problems are assumed to NOT exist in software (generally).

If it doesn't install properly - you've hit something particularly strange -
which could me costly repairs (like motherboard replacement).  Fluctuations in
voltage on a motherboard can also cause VERY strange problems that trickle down
to the application level.

Conclusion:

Although there appears to be a wide-spread problem with the Anaconda that
shipped with Red Hat Linux 8.0, I do not believe that to be the case
(necessarily).  Hardware issues (quirks and errors) cause erratic behaviour in
software.

Microsoft also experienced a problem of a greater magnitude when thousands of
consumers complained that installing Windows 95 was corrupting there machines
after a reboot.  In later service releases of Windows 95, Microsoft required
Scandisk to check for strange anomalies on the file system, and more
specifically the hard drive itself.  The solution was not to engineer the
installer to ignore such strange errors - but to inform the user that the
hardware in the system was failing and needed to be repaired or replaced before
continuing with the install process.

The Anaconda installer that ships with Red Hat Linux 8.0 is pretty much sound as
far as being "stable" - however, the quirks that can arise from "well-worn"
hardware can trigger a problem based on an assumption in Anaconda (which has
been properly patched).

My recommendation to the Anaconda team at Red Hat is to also add a
recommendation to the user that hardware may be failing if this behaviour
continues even with the fixes applied to Anaconda.  The test of this theory is
to actually botch a CD-ROM drive or two (applying a finger print or dust on the
lens of a CD-ROM drive) and see how Anaconda handles such hardware.  Also,
ailing computers should not be retired from the labs at Red Hat - I would
imagine that most hodge-podge computers out in the world that would potentially
be running Red Hat Linux have some sort of quirk (stemming from ailing
hardware).  Being able to handle as such would be useful.
Comment 97 Michael Fulbright 2002-12-16 10:48:52 EST
*** Bug 79614 has been marked as a duplicate of this bug. ***
Comment 98 Michael Fulbright 2002-12-16 21:47:15 EST
*** Bug 79628 has been marked as a duplicate of this bug. ***
Comment 99 Michael Fulbright 2002-12-16 22:29:55 EST
*** Bug 79369 has been marked as a duplicate of this bug. ***
Comment 100 Michael Fulbright 2002-12-19 10:05:19 EST
*** Bug 79908 has been marked as a duplicate of this bug. ***
Comment 101 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated
Comment 102 Michael Fulbright 2002-12-27 10:56:47 EST
*** Bug 80107 has been marked as a duplicate of this bug. ***
Comment 103 Jeremy Katz 2002-12-28 23:57:56 EST
*** Bug 80630 has been marked as a duplicate of this bug. ***
Comment 104 Jeremy Katz 2002-12-29 17:32:17 EST
*** Bug 80637 has been marked as a duplicate of this bug. ***
Comment 105 Michael Fulbright 2003-01-08 15:10:31 EST
*** Bug 81337 has been marked as a duplicate of this bug. ***
Comment 106 Michael Fulbright 2003-01-08 15:11:42 EST
*** Bug 81333 has been marked as a duplicate of this bug. ***
Comment 107 Michael Fulbright 2003-01-08 15:12:04 EST
*** Bug 81088 has been marked as a duplicate of this bug. ***
Comment 108 Michael Fulbright 2003-01-08 16:25:21 EST
*** Bug 81376 has been marked as a duplicate of this bug. ***
Comment 109 Michael Fulbright 2003-01-08 16:26:33 EST
*** Bug 81274 has been marked as a duplicate of this bug. ***
Comment 110 Michael Fulbright 2003-01-08 17:31:48 EST
*** Bug 78847 has been marked as a duplicate of this bug. ***
Comment 111 Jeremy Katz 2003-01-08 19:32:07 EST
*** Bug 78226 has been marked as a duplicate of this bug. ***
Comment 112 Mike McLean 2003-01-09 11:47:11 EST
*** Bug 81442 has been marked as a duplicate of this bug. ***
Comment 113 Jeremy Katz 2003-01-10 01:46:46 EST
*** Bug 79741 has been marked as a duplicate of this bug. ***
Comment 114 Jeremy Katz 2003-01-10 01:51:44 EST
*** Bug 78833 has been marked as a duplicate of this bug. ***
Comment 115 Jeremy Katz 2003-01-10 01:55:45 EST
*** Bug 78714 has been marked as a duplicate of this bug. ***
Comment 116 Jeremy Katz 2003-01-10 02:28:28 EST
*** Bug 71269 has been marked as a duplicate of this bug. ***
Comment 117 Need Real Name 2003-01-10 17:14:14 EST
The fix helped me out.
Thanx
Comment 118 Pat Robinson 2003-01-10 18:16:07 EST
I guess I have to comment in order to stop the emails. As a newbie, I didn't 
know how to check the other bugs. With that in mind, I followed the directions 
on bug 75377, and Vi-ola, things work just famously! Thank you all for your 
prompt support.

Pat
Comment 119 Jeremy Katz 2003-01-11 01:50:43 EST
*** Bug 81616 has been marked as a duplicate of this bug. ***
Comment 120 Jeremy Katz 2003-01-18 11:38:13 EST
*** Bug 82154 has been marked as a duplicate of this bug. ***
Comment 121 Damon 2003-01-19 00:58:27 EST
thx for the fix
Comment 122 Jeremy Katz 2003-01-22 01:00:50 EST
*** Bug 82335 has been marked as a duplicate of this bug. ***
Comment 123 Michael Fulbright 2003-01-27 12:12:01 EST
*** Bug 82775 has been marked as a duplicate of this bug. ***
Comment 124 Jeremy Katz 2003-01-29 16:43:05 EST
*** Bug 82908 has been marked as a duplicate of this bug. ***
Comment 125 Jeremy Katz 2003-01-29 23:05:50 EST
*** Bug 83083 has been marked as a duplicate of this bug. ***
Comment 126 Michael Fulbright 2003-01-30 14:44:49 EST
*** Bug 83093 has been marked as a duplicate of this bug. ***
Comment 127 Michael Fulbright 2003-02-03 13:54:27 EST
*** Bug 83256 has been marked as a duplicate of this bug. ***
Comment 128 Michael Fulbright 2003-02-03 13:56:31 EST
*** Bug 83275 has been marked as a duplicate of this bug. ***
Comment 129 Michael Fulbright 2003-02-03 13:57:23 EST
*** Bug 83346 has been marked as a duplicate of this bug. ***
Comment 130 Michael Fulbright 2003-02-04 15:12:23 EST
*** Bug 83465 has been marked as a duplicate of this bug. ***
Comment 131 Jeremy Katz 2003-02-08 17:03:05 EST
*** Bug 83796 has been marked as a duplicate of this bug. ***
Comment 132 Jeremy Katz 2003-02-10 13:11:10 EST
*** Bug 83804 has been marked as a duplicate of this bug. ***
Comment 133 Jeremy Katz 2003-02-10 13:14:03 EST
*** Bug 83831 has been marked as a duplicate of this bug. ***
Comment 134 Michael Fulbright 2003-02-11 12:31:45 EST
*** Bug 84050 has been marked as a duplicate of this bug. ***
Comment 135 Michael Fulbright 2003-02-11 12:36:41 EST
*** Bug 83831 has been marked as a duplicate of this bug. ***
Comment 136 Jeremy Katz 2003-02-11 22:11:20 EST
*** Bug 83831 has been marked as a duplicate of this bug. ***
Comment 137 Jeremy Katz 2003-02-19 00:13:13 EST
*** Bug 84563 has been marked as a duplicate of this bug. ***
Comment 138 Eido Inoue 2003-02-19 15:46:29 EST
*** Bug 79432 has been marked as a duplicate of this bug. ***
Comment 139 Jeremy Katz 2003-02-23 17:54:11 EST
*** Bug 84895 has been marked as a duplicate of this bug. ***
Comment 140 Jeremy Katz 2003-02-23 17:54:36 EST
*** Bug 84899 has been marked as a duplicate of this bug. ***
Comment 141 Jeremy Katz 2003-03-03 11:36:11 EST
*** Bug 85438 has been marked as a duplicate of this bug. ***
Comment 142 Michael Fulbright 2003-03-04 12:46:40 EST
*** Bug 85383 has been marked as a duplicate of this bug. ***
Comment 143 Michael Fulbright 2003-03-04 12:55:32 EST
*** Bug 85412 has been marked as a duplicate of this bug. ***
Comment 144 Michael Fulbright 2003-03-07 14:14:14 EST
*** Bug 85693 has been marked as a duplicate of this bug. ***
Comment 145 Michael Fulbright 2003-03-13 16:40:56 EST
*** Bug 75197 has been marked as a duplicate of this bug. ***
Comment 146 Michael Fulbright 2003-03-17 14:28:51 EST
*** Bug 86169 has been marked as a duplicate of this bug. ***
Comment 147 Michael Fulbright 2003-03-20 11:39:33 EST
*** Bug 86348 has been marked as a duplicate of this bug. ***
Comment 148 Michael Fulbright 2003-03-24 12:48:56 EST
*** Bug 86462 has been marked as a duplicate of this bug. ***
Comment 149 Michael Fulbright 2003-03-31 15:46:36 EST
*** Bug 87387 has been marked as a duplicate of this bug. ***
Comment 150 Michael Fulbright 2003-04-15 12:05:40 EDT
*** Bug 88694 has been marked as a duplicate of this bug. ***
Comment 151 Michael Fulbright 2003-04-22 11:58:36 EDT
*** Bug 89095 has been marked as a duplicate of this bug. ***
Comment 152 Michael Fulbright 2003-04-29 12:13:14 EDT
*** Bug 89550 has been marked as a duplicate of this bug. ***
Comment 153 Michael Fulbright 2003-05-14 12:32:16 EDT
*** Bug 90813 has been marked as a duplicate of this bug. ***
Comment 154 Michael Fulbright 2003-05-27 12:45:28 EDT
*** Bug 91609 has been marked as a duplicate of this bug. ***
Comment 155 Michael Fulbright 2003-05-27 12:47:21 EDT
*** Bug 91614 has been marked as a duplicate of this bug. ***
Comment 156 Michael Fulbright 2003-06-12 12:59:30 EDT
*** Bug 97025 has been marked as a duplicate of this bug. ***
Comment 157 Michael Fulbright 2003-06-18 16:41:15 EDT
*** Bug 97429 has been marked as a duplicate of this bug. ***
Comment 158 Michael Fulbright 2003-06-23 14:33:48 EDT
*** Bug 97882 has been marked as a duplicate of this bug. ***
Comment 159 Michael Fulbright 2003-06-26 12:02:54 EDT
*** Bug 97993 has been marked as a duplicate of this bug. ***
Comment 160 Jeremy Katz 2003-07-09 00:17:26 EDT
*** Bug 98711 has been marked as a duplicate of this bug. ***
Comment 161 Michael Fulbright 2003-07-29 16:56:47 EDT
*** Bug 101144 has been marked as a duplicate of this bug. ***
Comment 162 Michael Fulbright 2003-09-03 15:16:51 EDT
*** Bug 103143 has been marked as a duplicate of this bug. ***
Comment 163 Michael Fulbright 2003-09-16 12:31:22 EDT
*** Bug 104487 has been marked as a duplicate of this bug. ***
Comment 164 Jeremy Katz 2003-09-17 23:00:05 EDT
*** Bug 104590 has been marked as a duplicate of this bug. ***
Comment 165 Jeremy Katz 2003-11-21 16:24:21 EST
*** Bug 110559 has been marked as a duplicate of this bug. ***
Comment 166 Jeremy Katz 2004-02-13 13:24:25 EST
*** Bug 115532 has been marked as a duplicate of this bug. ***
Comment 167 Jeremy Katz 2004-03-08 18:18:33 EST
*** Bug 117811 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.