Bug 7830

Summary: RPM IS REPORTING: unpacking of archive failed: cpio: Bad magic
Product: [Retired] Red Hat Raw Hide Reporter: shane
Component: rpmAssignee: Jeff Johnson <jbj>
Status: CLOSED RAWHIDE QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 1.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-12-20 19:05:21 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description shane 1999-12-16 04:18:32 UTC
After upgrading to the latest version of Rawhide, I have begun noticing RPM
reporting "unpacking of archive failed: cpio: Bad magic" when installing
some (not all) rpms.  The RPMS I am attempting to install are rawhide RPMS
so I assume they are built correctly.

I have tried downloading the same files that error out and the problem
persists.

[root@lost shane]# rpm -Uhv newt-devel-0.50.1-14.i386.rpm
isapnptools-1.21-1.i386.rpm
newt-devel
##################################################
unpacking of archive failed: cpio: Bad magic
isapnptools
##################################################
unpacking of archive failed: cpio: Bad magic

Comment 1 Jeff Johnson 1999-12-16 15:59:59 UTC
Yup, rpm-3.0.4 is broke. The problem (I'm guessing) is only on builds, but,
if you're doing serious production work, you should use rpm-3.0.3 instead.
Meanwhile I should have a fix in the next day or 2 ...

Comment 2 Bill Nottingham 1999-12-17 19:06:59 UTC
*** Bug 7798 has been marked as a duplicate of this bug. ***

Comment 3 Bill Nottingham 1999-12-20 19:05:59 UTC
This should be fixed in the next Raw Hide with rebuilt RPMs.