Bug 784359

Summary: Review Request: qpid-gui-tools - GUI utilities for Red Hat MRG qpid
Product: [Fedora] Fedora Reporter: Ernie <eallen>
Component: Package ReviewAssignee: Nobody's working on this, feel free to take it <nobody>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: karlthered, notting, nsantos, package-review, pingou, volker27
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-08-08 08:11:44 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 201449    

Description Ernie 2012-01-24 12:10:28 EST
Spec URL: http://eallen.fedorapeople.org/qpid-guitools.spec
SRPM URL: http://eallen.fedorapeople.org/qpid-guitools-1.0.0-1.fc16.src.rpm
Description:  Graphical tools built with qt that display
information about quid brokers, queues, messages, exchanges, etc.

Nuno Santos has already volunteered to review this package. nsantos@redhat.com
Comment 1 Ernie 2012-01-24 12:18:48 EST
This is my first package so I guess I'll need a sponsor. Nuno Santos has volunteered.
Comment 2 Haïkel Guémar 2012-01-24 17:03:40 EST
Nice tool for working with QPid. Just few advices:
* you don't need to require glibc-common as BR (it's already provided in the minimal build chroot)
* use the %cmake macro
* discrepancies between version field (1.0.0) and changelog (0.1)
* does not build under mock (missing BR: cmake >= 2.6.0)
* your BR should be qpid-qmf-devel and qpid-cpp-client-devel
* either you plan to maintain your package under EL5 and you should handle buildroot cleaning or you don't plan maintaining it under EL5 and should remove the %defattr macro
* a typo in your description: "quid" instead of "qpid"
* wrong license: license.txt says it's under Apache License 2.0, by the way, GPL alone is not enough (valid values: GPLv{2,3}{,+} etc ...)
* i recommand you to check your src.rpm and binary rpm with the rpmlint tool. Building your src.rpm with the mock tool is also a must.
  
Since I assume you're also the upstream maintainer:
* you should version your source tarball
* you should also add installation bits inside your build system, with cmake something like that:
install(TARGET xview RUNTIME DESTINATION bin)
* you should also rename your binary upstream (xview will also conflicts in other distro which ships xloadimage) qpid-gbroker might confuse people since it's written Qt4 (people usually expect that software that have "g" in their name to be Gtk+ application)
Comment 3 Ernie 2012-01-31 10:13:57 EST
Thanks for the review. Very helpful.
I've fixed the .spec file per your advice. 
rpmlint now reports one warning about a missing man page, but I believe that can be safely ignored.
Everything seems to build under mock. 

I will be the upstream maintainer, but I'm unclear on what is meant by
"you should version your source tarball". Please elaborate.
Comment 4 Haïkel Guémar 2012-01-31 15:26:30 EST
You should append the version to the tarball name,ie:  qpid-guitools-1.0.0.tar.bz2 (which should decompress as qpid-guitools-1.0.0).
For Fedora, it allows storing multiple versions in the tarball cache (and it's easier for users to discriminate differents version).
For the man page, it's good practice to include one, though it's really necessary for command-line utilities, so it's safe to ignore it.
Comment 5 Ernie 2012-02-02 11:14:06 EST
The tarball is now versioned. The .spec file was updated to reflect the new SOURCE0.
The new spec file, source .bz2, and f16.x86_64 rpms are at http://eallen.fedorapeople.org/

Thanks for the help!
Please let me know if there is anything further.
Comment 6 Ernie 2012-02-08 08:17:03 EST
Is there anything further I can do to move this to the approved state?
Comment 7 Haïkel Guémar 2012-02-08 08:52:02 EST
Since you're not a fedora packager, you need to be approved by a sponsor which will formally review your packages. Usually, sponsors require that new packagers do some informal reviews to show their knowledge of fedora packaging (and help processing the reviews queue).

I would have gladly sponsored you but i'm no sponsor so i can help you to get your review in shape by doing an informal review.

I suggest that you search a sponsor either on irc (#fedora-devel @freenode), or fedora devel mailing-list. Maybe one of your coworkers @redhat can sponsor you too.

When you'll be sponsored, any fedora packager can review and then approve your packages.
Comment 8 Ernie 2012-02-13 09:20:00 EST
Changed the package name to qpid-gui-tools.
Spec URL: http://eallen.fedorapeople.org/qpid-gui-tools.spec
SRPM URL: http://eallen.fedorapeople.org/qpid-gui-tools-1.0.0-1.fc16.src.rpm

Still in the process of locating a sponsor.
Comment 9 Volker Fröhlich 2012-02-19 06:15:53 EST
Cmake doesn't need a version restriction. Even if you're going for EL 5, you're having 2.6. Talking about EL 5: As Haïkel already said, if you don't go for EL 5, you don't need the clean section and the rm in the install section. But if you're going for EL 5, you need to add a buildroot definition, see:
http://fedoraproject.org/wiki/EPEL/FAQ

In general, defattr is not necessary anymore, see:
http://fedoraproject.org/wiki/Packaging:Guidelines#File_Permissions

You don't need any of the Requires. RPM is smart enough to figure them out, see: http://fedoraproject.org/wiki/Packaging:Guidelines#Requires

Please use the name macro in Source, your cp and in your cmake invocation. The name macro is usually %{name}, not ${name}. Please preserve the timestamp for your copied file (cp -p, for instance), see:
http://fedoraproject.org/wiki/Packaging:Guidelines#Timestamps

You need a desktop file for graphical applications, see: http://fedoraproject.org/wiki/Packaging:Guidelines#Desktop_files

Also add license.txt with %doc.

The bindir macro is usually %{_bindir}.
Comment 10 Ernie 2012-02-21 17:41:06 EST
Thanks for the feedback!

- removed the version from cmake
- added a buildroot definition for EL 5
- removed defattr
- removed the Requires
- used the %{name} macro
- added a .desktop file and icon. Installs under the Accessories menu
- added license.txt to %doc
- changed the bindir macro to %{_bindir}

rpmlint doesn't report any problems
A mock build for f16 produced an rpm that successfully installed/uninstalled with yum.
Comment 11 Volker Fröhlich 2012-02-21 17:52:56 EST
Please always upload a new release when you're making changes and keep a detailed changelog inside the spec file. It's a lot easier for the reviewer that way.

By the way, the spec file is not accessible.

Please use %global instead of %define, see guidelines.

(You can install the desktop file with desktop-file-install as well, by the way.)

rpmlint:

qpid-gui-tools.src: W: strange-permission qpid-gui-tools.spec 0600L
Comment 12 Ernie 2012-02-22 13:49:51 EST
File permissions on the spec file have been fixed (read access granted to all).

The updated spec file, bziped tar of the source, the source rpm and mock built f16 rpm are all uploaded to http://eallen.fedorapeople.org/

- used global instead of define
- used desktop-file-install macro
- added changelog entries

The rpmlint strange-permission was fixed when the read access permission was fixed.

The only rpmlint issue is the warning about not using a man page, but since this is a gui, I believe a man page is not required. Please correct me if I'm wrong.
Comment 13 Volker Fröhlich 2012-02-23 18:06:50 EST
Please use the version macro in Source0. The group should rather be Applications/System, I guess.

http://fedoraproject.org/wiki/RPMGroups

Following this discussion, http://lists.fedoraproject.org/pipermail/devel/2012-January/161102.html, hicolor-icon-theme should be Required.

One last thing I stumbled upon, is fedora-review complaining about the desktop file having a different name than the package. I haven't found that in the guidelines explicitly.

As you mentioned, the missing manpage is not a blocker.
Comment 14 Ernie 2012-02-27 09:53:43 EST
Spec file uploaded and updated to:
- use version macro in Source0
- changed Group: to Applications/System 
- added Require: hicolor-icon-theme

This package will eventually be home to several utilities, including the current qpid-xbroker. Each utility will have it's own .desktop file describing it's name, icon, etc. That is why the current .desktop file doesn't match the package name.
Comment 15 Nuno Santos 2012-03-19 15:49:58 EDT
Looks like the review process has stalled, so I've picked up where Volker Fröhlich and Haïkel Guémar had left off:

========================================
Package review guidelines template:

OK - MUST: rpmlint must be run on the source rpm and all binary rpms the build produces. The output should be posted in the review.

$ mock -r fedora-16-i386 qpid-gui-tools-1.0.0-4.fc16.src.rpm  
INFO: mock.py version 1.1.18 starting...
State Changed: init plugins
INFO: selinux enabled
State Changed: start
INFO: Start(qpid-gui-tools-1.0.0-4.fc16.src.rpm)  Config(fedora-16-i386)
State Changed: lock buildroot
State Changed: clean
State Changed: unlock buildroot
State Changed: init
State Changed: lock buildroot
Mock Version: 1.1.18
INFO: Mock Version: 1.1.18
INFO: calling preinit hooks
INFO: enabled root cache
INFO: root cache aged out! cache will be rebuilt
INFO: enabled yum cache
State Changed: cleaning yum metadata
INFO: enabled ccache
State Changed: running yum
State Changed: creating cache
State Changed: unlock buildroot
INFO: Installed packages:
State Changed: setup
State Changed: build
INFO: Done(qpid-gui-tools-1.0.0-4.fc16.src.rpm) Config(fedora-16-i386) 44 minutes 8 seconds
INFO: Results and/or logs in: /var/lib/mock/fedora-16-i386/result
State Changed: end

$ rpmlint /var/lib/mock/fedora-16-i386/result/*.rpm
qpid-gui-tools.i686: W: no-manual-page-for-binary qpid-xbroker
3 packages and 0 specfiles checked; 0 errors, 1 warnings.

OK - MUST: The package must be named according to the Package Naming Guidelines .

OK - MUST: The spec file name must match the base package %{name}, in the format %{name}.spec unless your package has an exemption.

OK - MUST: The package must meet the Packaging Guidelines .

OK (ASL 2.0) - MUST: The package must be licensed with a Fedora approved license and meet the Licensing Guidelines .

OK - MUST: The License field in the package spec file must match the actual license.

OK - MUST: If (and only if) the source package includes the text of the license(s) in its own file, then that file, containing the text of the license(s) for the package must be included in %doc.

OK - MUST: The spec file must be written in American English.

OK - MUST: The spec file for the package MUST be legible.

OK - MUST: The sources used to build the package must match the upstream source, as provided in the spec URL. Reviewers should use md5sum for this task. If no upstream URL can be specified for this package, please see the Source URL Guidelines for how to deal with this.

$ wget http://eallen.fedorapeople.org/qpid-gui-tools-1.0.0-4.fc16.src.rpm
--2012-03-19 14:09:05--  http://eallen.fedorapeople.org/qpid-gui-tools-1.0.0-4.fc16.src.rpm
Resolving eallen.fedorapeople.org... 85.236.55.7
Connecting to eallen.fedorapeople.org|85.236.55.7|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 51623 (50K) [application/x-rpm]
Saving to: “qpid-gui-tools-1.0.0-4.fc16.src.rpm”

100%[==========================================================>] 51,623       142K/s   in 0.4s    

2012-03-19 14:09:06 (142 KB/s) - “qpid-gui-tools-1.0.0-4.fc16.src.rpm” saved [51623/51623]

$ rpm2cpio qpid-gui-tools-1.0.0-4.fc16.src.rpm | cpio -ivd
qpid-gui-tools-1.0.0.tar.bz2
qpid-gui-tools.spec
99 blocks

$ md5sum qpid-gui-tools-1.0.0.tar.bz2 
5ee122af648f9e785ed75b849ed0cb99  qpid-gui-tools-1.0.0.tar.bz2



$ wget http://eallen.fedorapeople.org/qpid-gui-tools-1.0.0.tar.bz2
--2012-03-19 14:38:41--  http://eallen.fedorapeople.org/qpid-gui-tools-1.0.0.tar.bz2
Resolving eallen.fedorapeople.org... 85.236.55.7
Connecting to eallen.fedorapeople.org|85.236.55.7|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 47476 (46K) [application/x-bzip2]
Saving to: “qpid-gui-tools-1.0.0.tar.bz2”

100%[==========================================================>] 47,476       100K/s   in 0.5s    

2012-03-19 14:38:42 (100 KB/s) - “qpid-gui-tools-1.0.0.tar.bz2” saved [47476/47476]

$ md5sum qpid-gui-tools-1.0.0.tar.bz2 
5ee122af648f9e785ed75b849ed0cb99  qpid-gui-tools-1.0.0.tar.bz2


OK - MUST: The package MUST successfully compile and build into binary rpms on at least one primary architecture.

(see mock build output above)

NA - MUST: If the package does not successfully compile, build or work on an architecture, then those architectures should be listed in the spec in ExcludeArch. Each architecture listed in ExcludeArch MUST have a bug filed in bugzilla, describing the reason that the package does not compile/build/work on that architecture. The bug number MUST be placed in a comment, next to the corresponding ExcludeArch line.

OK - MUST: All build dependencies must be listed in BuildRequires, except for any that are listed in the exceptions section of the Packaging Guidelines ; inclusion of those as BuildRequires is optional. Apply common sense.

NA - MUST: The spec file MUST handle locales properly. This is done by using the %find_lang macro. Using %{_datadir}/locale/* is strictly forbidden.

NA - MUST: Every binary RPM package (or subpackage) which stores shared library files (not just symlinks) in any of the dynamic linker's default paths, must call ldconfig in %post and %postun.

OK - MUST: Packages must NOT bundle copies of system libraries.

NA - MUST: If the package is designed to be relocatable, the packager must state this fact in the request for review, along with the rationalization for relocation of that specific package. Without this, use of Prefix: /usr is considered a blocker.

OK - MUST: A package must own all directories that it creates. If it does not create a directory that it uses, then it should require a package which does create that directory.

OK - MUST: A Fedora package must not list a file more than once in the spec file's %files listings. (Notable exception: license texts in specific situations)

OK - MUST: Permissions on files must be set properly. Executables should be set with executable permissions, for example.

OK - MUST: Each package must consistently use macros.

OK - MUST: The package must contain code, or permissable content.

NA - MUST: Large documentation files must go in a -doc subpackage. (The definition of large is left up to the packager's best judgement, but is not restricted to size. Large can refer to either size or quantity).

OK - MUST: If a package includes something as %doc, it must not affect the runtime of the application. To summarize: If it is in %doc, the program must run properly if it is not present.

NA - MUST: Header files must be in a -devel package.

NA - MUST: Static libraries must be in a -static package.

NA - MUST: If a package contains library files with a suffix (e.g. libfoo.so.1.1), then library files that end in .so (without suffix) must go in a -devel package.

NA - MUST: In the vast majority of cases, devel packages must require the base package using a fully versioned dependency: Requires: %{name}%{?_isa} = %{version}-%{release}

OK - MUST: Packages must NOT contain any .la libtool archives, these must be removed in the spec if they are built.

OK - MUST: Packages containing GUI applications must include a %{name}.desktop file, and that file must be properly installed with desktop-file-install in the %install section. If you feel that your packaged GUI application does not need a .desktop file, you must put a comment in the spec file with your explanation.

OK - MUST: Packages must not own files or directories already owned by other packages. The rule of thumb here is that the first package to be installed should own the files or directories that other packages may rely upon. This means, for example, that no package in Fedora should ever share ownership with any of the files or directories owned by the filesystem or man package. If you feel that you have a good reason to own a file or directory that another package owns, then please present that at package review time.

OK - MUST: All filenames in rpm packages must be valid UTF-8.


NA - SHOULD: If the source package does not include license text(s) as a separate file from upstream, the packager SHOULD query upstream to include it.

NA - SHOULD: The description and summary sections in the package spec file should contain translations for supported Non-English languages, if available.

OK - SHOULD: The reviewer should test that the package builds in mock.

(see mock build output above)

OK - SHOULD: The package should compile and build into binary rpms on all supported architectures.

OK - SHOULD: The reviewer should test that the package functions as described. A package should not segfault instead of running, for example.

OK - SHOULD: If scriptlets are used, those scriptlets must be sane. This is vague, and left up to the reviewers judgement to determine sanity.

NA - SHOULD: Usually, subpackages other than devel should require the base package using a fully versioned dependency.

NA - SHOULD: The placement of pkgconfig(.pc) files depends on their usecase, and this is usually for development purposes, so should be placed in a -devel pkg. A reasonable exception is that the main pkg itself is a devel tool not installed in a user runtime, e.g. gcc or gdb.

NA - SHOULD: If the package has file dependencies outside of /etc, /bin, /sbin, /usr/bin, or /usr/sbin consider requiring the package which provides the file instead of the file itself.

NO - SHOULD: your package should contain man pages for binaries/scripts. If it doesn't, work with upstream to add them where they make sense.

========================================

All of Volker's and Haïkel's concerns above have been addressed with this latest update, and the explanation for the .desktop file issue sounds good too.

Package is APPROVED.
Comment 16 Volker Fröhlich 2012-03-19 17:16:40 EDT
Ernie needs a sponsor, so you must be an approved packager to take the review, if I'm not wrong. As far as I know, you'd also have to take ownership of the ticket, Nuno.
Comment 17 Volker Fröhlich 2012-03-19 17:17:13 EDT
That should have been "proven packager".
Comment 18 Haïkel Guémar 2012-03-19 17:42:11 EDT
@nuno: It's not stalled, please take the time to read previous posts before taking action. 
The FE-NEEDSPONSOR flag says that the packager needs to be sponsored first, only sponsors can review these. Usually sponsors ask new applicants to do unformal review to prove their knowledge of Fedora packaging guidelines and their implication.
When a reviewee has been sponsored, he (or his sponsor) can drop the FE-NEEDSPONSOR flag in his other reviews to allow any approved packager to review them.

Doing informal reviews is Ok to help new packagers to fix their packages and get sponsored. 

Fedora packagers with sponsor privileges:
https://admin.fedoraproject.org/accounts/group/members/packager/*/sponsor


PS: i take the freedom to reset the fedora-review flag since you're not listed as a sponsor in the Fedora Account System. Eallen has not been approved yet into the Fedora Packager group. If this is inaccurate, please update Eallen FAS status and remove the FE-NEEDSPONSOR *first*.
https://admin.fedoraproject.org/accounts/user/view/nsantos
https://admin.fedoraproject.org/accounts/user/view/eallen
Comment 19 Nuno Santos 2012-03-20 09:45:46 EDT
There had been no activity on the review for over 3 weeks after Ernie posted his last updates, so it was easy to conclude it was stalled/abandoned. It's true I am not a sponsor, but I've done a large number of reviews and packaging work, I believe my review stands and all that Ernie needs to do is find a sponsor.
Comment 20 Haïkel Guémar 2012-03-20 10:11:09 EDT
@nuno: in the first place, it was not stalled since only sponsors can approve package reviews with FE-NEEDSPONSOR flag set. 

Extracted from http://fedoraproject.org/wiki/How_to_sponsor_a_new_contributor
"Once they've made those changes, you can approve the package and sponsor the user in the fedora account system"

A sponsor can't sponsor someone without having formally reviewed at least one package from the new packager (unless you take the co-maintainership path)
No matter how thorough you review has been, until Eallen has been sponsored, you can't approve this package.
Comment 21 Volker Fröhlich 2012-07-23 02:31:03 EDT
Ernie, did you find a sponsor yet?
Comment 22 Ernie 2012-07-23 12:52:13 EDT
Not yet. My plan is to turn this over to another one of the MRG-messaging group and ask them to see it through. 
Since this is a MRG-messaging specific utility, and others in that group have been sponsored and have had packages approved, I thought that would be more expedient.
Comment 23 Volker Fröhlich 2012-08-02 16:14:50 EDT
I think the standard procedure is to close it as FE-DEADREVIEW then. The actual submitter then opens his own request.
Comment 24 Ernie 2012-08-08 08:11:44 EDT
Closing. Marking as dependent on FE-DEADREVIEW.