Bug 785909

Summary: --debug-timestamps=1 is not passed to providers
Product: Red Hat Enterprise Linux 6 Reporter: Stephen Gallagher <sgallagh>
Component: sssdAssignee: Stephen Gallagher <sgallagh>
Status: CLOSED ERRATA QA Contact: IDM QE LIST <seceng-idm-qe-list>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 6.3CC: grajaiya, jgalipea, kbanerje, prc, sgoveas
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: sssd-1.8.0-2.el6.beta2 Doc Type: Bug Fix
Doc Text:
No technical note required
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-06-20 11:54:48 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Stephen Gallagher 2012-01-30 21:07:57 UTC
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/sssd/ticket/972

When you run sssd with --debug-timestamps=1, it is not passed to providers arguments.

As result, when you disable timestamps in sssd.conf (debug_timestamps = false) in other section than [sssd] and run sssd --debug-timestamps=1, timestamps are only shown in monitor debug messages.

Comment 3 Steeve Goveas 2012-04-05 07:51:23 UTC
Disabled timestamps in domain section of sssd.conf

[root@wheeljack ~]# cat /etc/sssd/sssd.conf 
[domain/lab.eng.pnq.redhat.com]
 
cache_credentials = True
krb5_store_password_if_offline = True
ipa_domain = lab.eng.pnq.redhat.com
id_provider = ipa
auth_provider = ipa
debug_level = 9
debug_timestamps = false
access_provider = ipa
chpass_provider = ipa
ipa_server = wheeljack.lab.eng.pnq.redhat.com
ldap_tls_cacert = /etc/ipa/ca.crt

[sssd]
services = nss, pam, ssh
debug_level = 9
config_file_version = 2
 
domains = lab.eng.pnq.redhat.com

[root@wheeljack ~]# tail -f /var/log/sssd/sssd_lab.eng.pnq.redhat.com.log /var/log/sssd/sssd.log 
==> /var/log/sssd/sssd.log <==
(Thu Apr  5 03:49:02 2012) [sssd] [monitor_quit] (0x0020): Child [nss] exited gracefully
(Thu Apr  5 03:49:02 2012) [sssd] [monitor_quit] (0x0020): Terminating [lab.eng.pnq.redhat.com][4083]

==> /var/log/sssd/sssd_lab.eng.pnq.redhat.com.log <==
[sssd[be[lab.eng.pnq.redhat.com]]] [sbus_dispatch] (0x0080): Connection is not open for dispatching.
[sssd[be[lab.eng.pnq.redhat.com]]] [be_client_destructor] (0x0400): Removed NSS client

Executing with --debug-timestamps=1

[root@wheeljack ~]# sssd --debug-timestamps=1 --debug-to-files

[root@wheeljack ~]# tail -f /var/log/sssd/sssd_lab.eng.pnq.redhat.com.log /var/log/sssd/sssd.log
==> /var/log/sssd/sssd_lab.eng.pnq.redhat.com.log <==
(Thu Apr  5 03:38:25 2012) [sssd[be[lab.eng.pnq.redhat.com]]] [sbus_dispatch] (0x4000): dbus conn: 227ED80

==> /var/log/sssd/sssd.log <==
(Thu Apr  5 03:38:25 2012) [sssd] [sbus_remove_timeout] (0x2000): 0x1954890
(Thu Apr  5 03:38:25 2012) [sssd] [sbus_dispatch] (0x4000): dbus conn: 1954100

Execution with --debug-timestamps=1 overrides the config value in sssd.conf

Verified in version sssd-1.8.0-17.el6.x86_64

Comment 4 Stephen Gallagher 2012-04-10 16:50:58 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No technical note required

Comment 5 Kaushik Banerjee 2012-05-07 10:35:02 UTC
Verified in sssd-1.8.0-25

"sssd --debug-timestamps=1" overrides the config(debug_timestamps = false) in domain section

Comment 7 errata-xmlrpc 2012-06-20 11:54:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0747.html