Bug 79296

Summary: Tool tip on RP3 dialer does not deactivate
Product: [Retired] Red Hat Linux Reporter: Craig Lawson <craig.lawson>
Component: gtk+Assignee: Owen Taylor <otaylor>
Status: CLOSED WONTFIX QA Contact: David Lawrence <dkl>
Severity: low Docs Contact:
Priority: low    
Version: 7.3CC: harald
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-12-16 17:03:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Craig Lawson 2002-12-09 19:32:11 UTC
Description of Problem:
Tool tip on RP3 dialer gnome applet stays active until a network connection is established. If a connection is never established, the tool tip is not deactivated.

Version-Release number of selected component (if applicable):
redhat-config-network-1.0.3-1

How Reproducible:
100%

Steps to Reproduce:
1. Display the RP3 dialer applet on a gnome panel.
2. Hover over the "connect" button on the applet. Two tool tips are displayed: "Click to connect to ppp0" (or similar) and "Connect". (Hmm, two tool tips at the same time? Could be another bug here.)
3. Click the button. The second tool tip ("Connect") is deactivated. The "Change Connection Status" dialog is displayed
4. In the Change Connection Status window, click "No".
5. The first tool tip ("Click to connect to ppp0") is still displayed. It will continue to be displayed until the cursor is moved onto and away from the "connect" button.

Similar things happen when disconnecting.

Actual Results:
The "Click to connect to ppp0" tool tip stays displayed until the cursor is moved onto and then away from the "connect" button.

Expected Results:
After a few seconds, the tool tip should disappear whether a connection was established or not. The user should not have to take further action to make the tool tip vanish.

Comment 1 Harald Hoyer 2002-12-16 09:43:25 UTC
this is more a gtk bug...

Comment 2 Owen Taylor 2002-12-16 15:23:07 UTC
This applet wasn't shipped in 8.0, was it? This could easily be a GTK+
bug, an libpanel-applet bug, or an applet bug; but if it is only occurring
in an applet we don't ship anymore, linked against old versions of the 
libraries, I'm just going to close WONTFIX.

Comment 3 Harald Hoyer 2002-12-16 15:26:59 UTC
not shipped in 8.0 ... as the bugreport says, this is Version 7.3