Bug 806217

Summary: Audio Jack plug in dockingstation stops working with installation of kernel-3.3.0.2
Product: [Fedora] Fedora Reporter: Dennis Appelon Nielsen <AppelonD>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 16CC: cwickert, gansalmon, itamar, jonathan, jrankin, kayvansylvan, kernel-maint, madhu.chinakonda
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: kernel-3.6.1-1.fc17 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-10-23 14:10:01 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
My entire dmesg out
none
My Messages log out
none
My alsa-info
none
Output of lspci -vvnn none

Description Dennis Appelon Nielsen 2012-03-23 05:00:47 EDT
Created attachment 572194 [details]
My entire dmesg out

Description of problem:
Sound jack out in my Lenovo docking-station stopped working after kernel update to 3.3.0.2 it keeps working if I plug my headset in to the jack in the laptop. If I boots back in to a kernel-3.2 the jack out in the dock starts working again

Version-Release number of selected component (if applicable):
kernel-3.2.10-3.fc16.x86_64  Works
kernel-3.3.0-2.fc16.x86_64 don't work
kernel-3.3.0-4.fc16.x86_64 don't work

How reproducible:
Install a kernel-3.3.0.2 or kernel-3.3.0.4 and you will not be able to use the audio jack out in your docking-station but are forced to use the audio jack out in the laptop it self. 

Boot back in to any kernel-3.2 and your audio jack out in your docking-station works again.

Steps to Reproduce:
1. Install kernel-3.3.0.4
2. connect your speakers to the jack out in your docking-station
3. Generate some sound, but you wan't hear it
4. connect your speakers to the jack in the laptop it self and you hear the sound again.
5. Boot in to any 3.2.x.x
6. connect your speakers to the jack out in your docking-station
7. generate some sound this time you hear it.
  
Actual results:


Expected results:


Additional info:
I have attached my messages log out and my dmesg log out
Comment 1 Dennis Appelon Nielsen 2012-03-23 05:01:47 EDT
Created attachment 572195 [details]
My Messages log out
Comment 2 Dennis Appelon Nielsen 2012-04-02 14:16:23 EDT
This problem continue in kernel 3.3.0.8 x86_64 sadly
Comment 3 Kayvan Sylvan 2012-04-02 14:17:59 EDT
The same has happened on the kernel-3.3 series for my Lenovo Thinkpad T410 in the docking station.
Comment 4 Kayvan Sylvan 2012-04-02 14:21:20 EDT
*** Bug 808308 has been marked as a duplicate of this bug. ***
Comment 5 Kayvan Sylvan 2012-04-02 14:22:53 EDT
The problem happens with both audio input and audio output on the docking station for the Lenovo Thinkpad T410.
Comment 6 Christoph Wickert 2012-04-12 19:51:21 EDT
*** Bug 812165 has been marked as a duplicate of this bug. ***
Comment 7 Josh Boyer 2012-04-12 20:25:49 EDT
Does this only happen when the machine is booted while in the docking station?  Does docking/undocking make it work at all?

Can you attach the output of alsa-info and lspci -vvnn?

Lastly, you might try the following scratch build and see if it makes any difference:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3981036
Comment 8 Christoph Wickert 2012-04-13 02:43:32 EDT
(In reply to comment #7)
> Does this only happen when the machine is booted while in the docking station? 
> Does docking/undocking make it work at all?

Doesn't make any difference.

Meanwhile I tried a few more kernels. kernel-3.3.0-0.rc1.git0.3.fc17.x86_64 still works, but kernel-3.3.0-1.fc17.x86_64 doesn't. I'll try to narrow down the change further and I'll give your scratch-build a try.
Comment 9 Christoph Wickert 2012-04-13 02:45:34 EDT
Created attachment 577245 [details]
My alsa-info
Comment 10 Christoph Wickert 2012-04-13 02:47:50 EDT
Created attachment 577251 [details]
Output of lspci -vvnn

FYI: My smolt profile is available at http://www.smolts.org/client/show/pub_260fd7f2-040f-4d1f-8d60-1c8d0c1ff861
Comment 11 Christoph Wickert 2012-04-13 03:07:33 EDT
With your scratch-build 3.3.1-5.3.fc16.x86_64 the audio jack works again.
Comment 12 Josh Boyer 2012-04-13 08:44:40 EDT
(In reply to comment #11)
> With your scratch-build 3.3.1-5.3.fc16.x86_64 the audio jack works again.

Thank you for testing.  I've emailed upstream about the issue and hopefully we'll have an official fix of sorts shortly.
Comment 13 Josh Boyer 2012-04-13 09:39:55 EDT
Christoph and Kayvan, upstream has a different thing for you to test if you would be so
kind.

You'll need to boot back into the non-scratch-build kernel to do this.

Create a file named /lib/firmware/alsa-tp-dock with the following contents:

================================================================
[codec]
0x14f15069 0x17aa21a4 0

[pincfg]
0x19 0x042110ff
0x1a 0x21a190f0
0x1c 0x212140ff
================================================================

Then in /etc/modprobe.d/dist-alsa.conf, add the following:

 options snd-hda-intel patch="alsa-tp-dock"

then reboot (or rmmod/modprobe the drivers).

After the driver is loaded with that set, new mixer elements will appear.  You
will need to look at the volume and mute settings for those manually.
Comment 14 Christoph Wickert 2012-04-13 13:27:56 EDT
That doesn't seem to work.

$ uname -r
3.3.1-5.fc17.x86_64
$ cat /lib/firmware/alsa-tp-dock 
[codec]
0x14f15069 0x17aa21a4 0

[pincfg]
0x19 0x042110ff
0x1a 0x21a190f0
0x1c 0x212140ff

$ cat /etc/modprobe.d/dist-alsa.conf 
options snd-hda-intel patch="alsa-tp-dock"

However I see no new mixer elements, neither in pavucontrol nor in alsamixer ox xfce4-mixer (uses ALSA, too).
Comment 15 Josh Boyer 2012-04-13 14:13:17 EDT
(In reply to comment #14)
> That doesn't seem to work.

Hm.  It might be because I have the wrong [codec] values.  I've let upstream know.  If you'd like to be CC'd directly in the conversation, let me know.

I'll also have another scratch build to test a bit later today which won't need these manual settings.
Comment 16 Christoph Wickert 2012-04-13 14:25:40 EDT
Awesome. Thanks a lot for your quick response + the fix.

(In reply to comment #15)
> If you'd like to be CC'd directly in the conversation, let me know.

Yes please.
Comment 17 Josh Boyer 2012-04-13 15:22:52 EDT
(In reply to comment #16)
> Awesome. Thanks a lot for your quick response + the fix.

This scratch build has Takashi's proposed patch to fix this.  Hopefully it works for you when it finishes building:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3989218

> (In reply to comment #15)
> > If you'd like to be CC'd directly in the conversation, let me know.
> 
> Yes please.

OK, will do on further emails.
Comment 18 Christoph Wickert 2012-04-14 05:35:27 EDT
(In reply to comment #17)
> http://koji.fedoraproject.org/koji/taskinfo?taskID=3989218

A warning to others: This kernel does not boot, at least it doesn't boot here. I am using an encrypted /home and for some reason, the password prompt is displayed *after* booting is finished and plymouth disappeared. I enter my password but nothing happens.

And if this was not enough, I accidentally used "rpm -U" instead of "rpm -i" to install it, so it was my only kernel. Fun! ;)
Comment 19 Josh Boyer 2012-04-14 08:02:02 EDT
(In reply to comment #18)
> (In reply to comment #17)
> > http://koji.fedoraproject.org/koji/taskinfo?taskID=3989218
> 
> A warning to others: This kernel does not boot, at least it doesn't boot here.
> I am using an encrypted /home and for some reason, the password prompt is
> displayed *after* booting is finished and plymouth disappeared. I enter my
> password but nothing happens.

That sounds like issues in the initramfs, not the kernel.
Comment 20 Christoph Wickert 2012-04-14 08:19:59 EDT
Indeed, I reinstalled that kernel and it does boot now. I do see two new options in alsamixer and pavucontrol: "Dock mic" and "Dock Mic Boost". "Mic" and "Mic boost" are now called "Internal Mic" and "Internal Mic Boost". So far, so good, no new output and no sound on the speakers.

I'll need to further test the different kernels and their impact on ALSA.
Comment 21 Josh Boyer 2012-04-14 08:54:16 EDT
(In reply to comment #20)
> Indeed, I reinstalled that kernel and it does boot now. I do see two new
> options in alsamixer and pavucontrol: "Dock mic" and "Dock Mic Boost". "Mic"
> and "Mic boost" are now called "Internal Mic" and "Internal Mic Boost". So far,
> so good, no new output and no sound on the speakers.

So the controls are there, but sound still doesn't play?  Are they unmuted and the volume adjusted?
Comment 22 Christoph Wickert 2012-06-08 07:11:10 EDT
Yes, they were unmuted, but still now sound.

The problem was fixed with the newer kernels, all the 3.3.4 and 3.3.7 kernels for F17 worked fine, but now in kernel-3.4.0-1.fc17.x86_64 it's broken again. And this kernel seems to have other serious regressions, my keyboard randomly stops working and only half of the keystrokes I type actually make it.
Comment 23 Christoph Wickert 2012-06-08 07:18:24 EDT
The keyboard attached to the docking that is, not the one of the Thinkpad.
Comment 24 Josh Boyer 2012-06-08 08:14:35 EDT
Can you try the udev update in updates-testing (or it might hit stable updates later today) for the keyboard thing?
Comment 25 Christoph Wickert 2012-06-30 17:12:14 EDT
I installed udev-182-3.fc17 on Jund 10th and the keyboard problems are fixed. However none of the 3.4.x kernels makes the audiojack work again.

Don't work:
kernel-3.4.0-1.fc17.x86_64
kernel-3.4.2-4.fc17.x86_64
kernel-3.4.3-1.fc17.x86_64

Works:
kernel-3.3.7-1.fc17.x86_64

Sorry I have been so unresponsive, I really want to get this fixed and I am willing to help you debugging the problem, but I don't know where to start.
Comment 26 Dave Jones 2012-10-23 11:40:30 EDT
# Mass update to all open bugs.

Kernel 3.6.2-1.fc16 has just been pushed to updates.
This update is a significant rebase from the previous version.

Please retest with this kernel, and let us know if your problem has been fixed.

In the event that you have upgraded to a newer release and the bug you reported
is still present, please change the version field to the newest release you have
encountered the issue with.  Before doing so, please ensure you are testing the
latest kernel update in that release and attach any new and relevant information
you may have gathered.

If you are not the original bug reporter and you still experience this bug,
please file a new report, as it is possible that you may be seeing a
different problem. 
(Please don't clone this bug, a fresh bug referencing this bug in the comment is sufficient).
Comment 27 Christoph Wickert 2012-10-23 14:10:01 EDT
Yes, it's fixed for me with all 3.6.x kernels. No more manual tweaks needed.