Bug 81475

Summary: Alt is ignored
Product: [Retired] Red Hat Linux Reporter: Miloslav Trmac <mitr>
Component: vteAssignee: Nalin Dahyabhai <nalin>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 9   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:51:03 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Miloslav Trmac 2003-01-09 20:01:38 UTC
Description of problem:
I think this is too difficult not to notice, but anyway:
Alt is ignored, so Alt-b, Alt-backspace behave like
b, backspace respectively.

Version-Release number of selected component (if applicable):
gnome-terminal-2.1.32
vte-0.10.7-2

Comment 1 Nalin Dahyabhai 2003-01-09 21:38:50 UTC
Which locale is your system in?  Alt-b produces Escape,b in en_US.

Comment 2 Miloslav Trmac 2003-01-10 23:44:29 UTC
Ah...
Using default Czech installation (cs_CZ.UTF-8 et all),
Alt-b bash in in gnome-terminal correctly skips words,
but Alt-backspace deletes only one character at a time,
not one word at a time.

When I run
setxkbmap -symbols 'czsk(us_cz_qwerty)' -compat group_led
(this used to be -layout in 8.0, BTW), Alt-backspace
doesn't work either and in addition, Alt-b just outputs
'b'. The czsk keyboard is there only for compatibility, there
is supposed to be a better mechanism for X keyboard switching
in XFree 4.3, which I haven't tried yet.

So, Alt-Backspace doesn't work in cz in default install.
Consider Alt-B NEEDINFO until I try the recommended way to
replace czsk or get more data.
Thanks.

Comment 3 Nalin Dahyabhai 2003-01-14 04:03:07 UTC
This should be fixed in 0.10.9 and later.  Please reopen this bug ID if you find
that this is not the case.

Comment 4 Nalin Dahyabhai 2003-01-14 04:06:02 UTC

*** This bug has been marked as a duplicate of 80252 ***

Comment 5 Red Hat Bugzilla 2006-02-21 18:51:03 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.