Bug 80252 - Alt-backspace is passed to the application as plain backspace
Alt-backspace is passed to the application as plain backspace
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: vte (Show other bugs)
phoebe
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
: 81475 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-23 05:08 EST by Alexandre Oliva
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-13 23:04:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2002-12-23 05:08:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
Even with `all menu mnemonics' disabled in the gnome-terminal Keybindings editor
disabled, Alt-backspace doesn't work the same as Alt-Ctrl-H like it did in
earlier releases.  It used to delete the entire word to the left, like it does
in Emacs.  Now it only deletes one character.  This may be the result of a
change in XFree86, since xterm also fails to recognize Alt-backspace now, but it
may well be something in gnome-terminal or in gtk+.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start gnome-terminal
2.Enter a few words into bash
3.Try to delete the last word with Alt-backspace
    

Actual Results:  It deletes only one character

Expected Results:  It should delete the entire word

Additional info:
Comment 1 Havoc Pennington 2002-12-23 11:09:20 EST
If your X events are right, in "xev" alt backspace will show as state = 0x8, 
BackSpace. If that shows up right it's probably a terminal issue, otherwise
probably X keymap issue.
Comment 2 Alexandre Oliva 2002-12-23 11:59:55 EST
Here are the events I get for Alt-Backspace:

KeyPress event, serial 20, synthetic NO, window 0x2a00001,
    root 0x3f, subw 0x0, time 17005674, (73,88), root:(750,615),
    state 0x0, keycode 64 (keysym 0xffe9, Alt_L), same_screen YES,
    XLookupString gives 0 bytes:  ""
 
KeyPress event, serial 25, synthetic NO, window 0x2a00001,
    root 0x3f, subw 0x0, time 17006091, (73,88), root:(750,615),
    state 0x8, keycode 22 (keysym 0xff08, BackSpace), same_screen YES,
    XLookupString gives 1 bytes:  "
 
KeyRelease event, serial 25, synthetic NO, window 0x2a00001,
    root 0x3f, subw 0x0, time 17006158, (73,88), root:(750,615),
    state 0x8, keycode 22 (keysym 0xff08, BackSpace), same_screen YES,
    XLookupString gives 1 bytes:  "
 
KeyRelease event, serial 25, synthetic NO, window 0x2a00001,
    root 0x3f, subw 0x0, time 17006630, (73,88), root:(750,615),
    state 0x8, keycode 64 (keysym 0xffe9, Alt_L), same_screen YES,
    XLookupString gives 0 bytes:  ""

Looks like it's a terminal issue, then...
Comment 3 Nalin Dahyabhai 2003-01-13 23:04:04 EST
This should be fixed in 0.10.9 and later.  Please reopen this bug ID if you find
that this is not the case.
Comment 4 Nalin Dahyabhai 2003-01-13 23:06:04 EST
*** Bug 81475 has been marked as a duplicate of this bug. ***
Comment 5 Alexandre Oliva 2003-01-23 09:56:47 EST
Confirmed fixed in phoebe2.

Note You need to log in before you can comment on or make changes to this bug.