Bug 814938

Summary: [abrt] kernel: [271149.777831] WARNING: at fs/dcache.c:1287 d_set_d_op+0x7c/0xb0()
Product: [Fedora] Fedora Reporter: Serge Pavlovsky <pal666>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: gansalmon, itamar, jonathan, kernel-maint, madhu.chinakonda
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:6748fe9fec7c8c38a67da9134e770271344d5f35
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-07-16 15:16:35 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
File: smolt_data none

Description Serge Pavlovsky 2012-04-21 09:01:55 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.2.7-1.fc16.x86_64 root=UUID=767aaff4-775e-49cd-a068-0cd1a6576716 ro LANG=ru_RU.UTF-8 rd.md=0 rd.lvm=0 rd.dm=0 quiet rhgb rd.luks=0 radeon.pcie_gen2=1 KEYTABLE=ru
kernel:         3.2.7-1.fc16.x86_64
reason:         [271149.777831] WARNING: at fs/dcache.c:1287 d_set_d_op+0x7c/0xb0()
time:           Суб 17 Мар 2012 01:30:33

smolt_data:     Binary file, 4558 bytes

backtrace:
:[271149.777831] WARNING: at fs/dcache.c:1287 d_set_d_op+0x7c/0xb0()
:[271149.777837] Hardware name: GA-990XA-UD3
:[271149.777841] Modules linked in: r8169 sctp tcp_lp nf_nat_h323 nf_conntrack_h323 nf_nat_pptp nf_conntrack_pptp nf_conntrack_proto_gre nf_nat_proto_gre nf_nat_tftp nf_conntrack_tftp nf_nat_sip nf_conntrack_sip nf_nat_irc nf_conntrack_irc nf_nat_ftp nf_conntrack_ftp pppoe pppox ppp_generic slhc ppdev parport_pc lp parport rfcomm ebtable_nat ebtables xt_CHECKSUM bridge stp llc be2iscsi iscsi_boot_sysfs bnx2i lockd cnic uio cxgb4i cxgb4 cxgb3i libcxgbi cxgb3 mdio ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi bnep it87 hwmon_vid ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 xt_state ipt_MASQUERADE ip6table_filter iptable_nat ip6_tables nf_nat nf_conntrack_ipv4 nf_conntrack nf_defrag_ipv4 xt_TCPMSS iptable_mangle arc4 fuse ath9k_htc mac80211 ath9k_common ath9k_hw ath cfg80211 edac_core cdc_acm joydev edac_mce_amd k10temp serio_raw snd_hda_codec_hdmi microcode snd_ctxfi sp5100_tco i2c_piix4 btusb snd_hda_codec_realtek blueto
:oth rfkill snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device binfmt_misc snd_pcm snd_timer snd soundcore snd_page_alloc mii vhost_net macvtap macvlan tun virtio_net kvm_amd kvm uinput sunrpc btrfs zlib_deflate libcrc32c mxm_wmi firewire_ohci firewire_core crc_itu_t usb_storage wmi radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core [last unloaded: r8169]
:[271149.778144] Pid: 5622, comm: bash Not tainted 3.2.7-1.fc16.x86_64 #1
:[271149.778153] Call Trace:
:[271149.778172]  [<ffffffff8106dd4f>] warn_slowpath_common+0x7f/0xc0
:[271149.778187]  [<ffffffff8106ddaa>] warn_slowpath_null+0x1a/0x20
:[271149.778200]  [<ffffffff8118dd2c>] d_set_d_op+0x7c/0xb0
:[271149.778214]  [<ffffffff8119ceef>] simple_lookup+0x3f/0x60
:[271149.778228]  [<ffffffff81183d65>] d_alloc_and_lookup+0x45/0x90
:[271149.778241]  [<ffffffff81190695>] ? d_lookup+0x35/0x60
:[271149.778255]  [<ffffffff81186331>] do_lookup+0x2b1/0x3a0
:[271149.778268]  [<ffffffff811870bc>] path_lookupat+0x11c/0x740
:[271149.778282]  [<ffffffff8118427b>] ? getname_flags+0x3b/0x260
:[271149.778295]  [<ffffffff812c4327>] ? __strncpy_from_user+0x27/0x60
:[271149.778309]  [<ffffffff81187711>] do_path_lookup+0x31/0xc0
:[271149.778323]  [<ffffffff81188ab9>] user_path_at_empty+0x59/0xa0
:[271149.778338]  [<ffffffff81266536>] ? selinux_inode_getattr+0x36/0x40
:[271149.778350]  [<ffffffff8117db28>] ? cp_new_stat+0xf8/0x110
:[271149.778364]  [<ffffffff81188b11>] user_path_at+0x11/0x20
:[271149.778376]  [<ffffffff8117dd4a>] vfs_fstatat+0x3a/0x70
:[271149.778388]  [<ffffffff8117dd9e>] vfs_lstat+0x1e/0x20
:[271149.778400]  [<ffffffff8117df3a>] sys_newlstat+0x1a/0x40
:[271149.778412]  [<ffffffff81183c72>] ? path_put+0x22/0x30
:[271149.778426]  [<ffffffff810cdd62>] ? audit_syscall_entry+0x242/0x360
:[271149.778441]  [<ffffffff815e9d82>] system_call_fastpath+0x16/0x1b
Comment 1 Serge Pavlovsky 2012-04-21 09:01:59 EDT
Created attachment 579168 [details]
File: smolt_data
Comment 2 Josh Boyer 2012-04-21 10:45:04 EDT
*** Bug 814937 has been marked as a duplicate of this bug. ***
Comment 3 Josh Boyer 2012-04-21 10:45:25 EDT
Can you recreate this with a 3.3.2 or newer kernel?
Comment 4 Serge Pavlovsky 2012-04-21 11:55:41 EDT
i do not know how to provoke it, so i will wait for new abrt report
Comment 5 Dave Jones 2012-04-24 09:55:14 EDT
might also be worth you running memtest86, as memory corruption could have explained this.

had you been using hibernate ?
Comment 6 Dave Jones 2012-07-16 15:16:35 EDT
different syscall entry point, but same end result.
same as bug 783152

*** This bug has been marked as a duplicate of bug 783152 ***