Bug 819242

Summary: [ALL_LANG] Many available Finnish and other translations missing from the UI
Product: [Fedora] Fedora Reporter: Ville-Pekka Vainio <vpvainio>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 19CC: aalam, anaconda-maint-list, awilliam, domingobecker, gguerrer, g.kaviyarasu, hpeters, i18n-bugs, jonathan, juhaninumminen0, noriko, piotrdrag, ptr, vanmeeuwen+fedora, xset1980
Target Milestone: ---Keywords: i18n, Translation
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: F19L10nTestday
Fixed In Version: anaconda-18.3 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-05-30 01:25:27 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 958376    
Bug Blocks:    

Description Ville-Pekka Vainio 2012-05-05 21:20:11 UTC
I've tested this with the anaconda version in Fedora 17.TC3.

Many translations which are available in the fi.po file are missing from the UI. I've taken screenshots, which are at http://vpv.fedorapeople.org/misc/anaconda-17/

The buttons in the bottom of the screen are all missing translations (Back, Next etc.) These should probably come from GTK?

The "Please name this computer" screen is missing translations completely. The translations are available in the fi.po file.

The time zone screen is missing translations almost completely. The translations are available in the fi.po file. (For example, "System clock uses UTC").

The root account screen is missing the translation of the description. The translation is available in the fi.po file.

"The password fails the dictionary check" string is not in the fi.po file at all and is thus not translated. Notice that the Cancel button in that window is not translated but the Use anyway button is, which seems to support my finding that GTK translations are probably not being used at all.

The "Use LVM" etc. check boxes are not translated. The other two are available in the fi.po file but the "Review and modify..." string is missing even from the fi.po file.

The strings concerning repos and package selection are not translated. The translations are available in the fi.po file.

I know this report may be too late in the release cycle and Finnish is a small language, but I would appreciate it if you could check that translations are handled properly in general in Anaconda 17.

Comment 1 Ville-Pekka Vainio 2012-05-12 17:13:42 UTC
This is not any better in TC5.

Comment 2 A S Alam 2012-06-08 17:06:36 UTC
I tested following locales and most locales are missing Translation including

Chinese (Traditional/Simplified)

there was https://fedoraproject.org/wiki/Test_Day:2012-04-05_L10n_I18n_Installation anaconda test day to help translation testing. 
May be need to confirm with Beta release if changes are there or not.

Although it is late, but this bug can be used as reference in future release.

Comment 3 Domingo Becker 2012-06-08 22:00:02 UTC
(In reply to comment #2)
> there was
> https://fedoraproject.org/wiki/Test_Day:2012-04-05_L10n_I18n_Installation
> anaconda test day to help translation testing. 

In this test day I reported es_ES was fully translated with the exception of a string related to smolt at the end.

es_ES translations in F17 GA DVD (i386 and x86_64) looks like it went back to year 2006.

Or translations were not included when anaconda for beta was built or perhaps some race condition in a parallel build of the package caused this issue.


Domingo Becker (es)

Comment 4 Peter Bojtos 2012-06-25 17:17:11 UTC
The problem is really strange. The translated and untranslated strings are coming from the same XML (glade) file, however some of them doesn't want to appear in the preferred language.

Another strange thing: if I run anaconda, kill it from command line (Alt + F2) and restart if, the untranslated strings problem disappears, so it should be a locale problem instead of a missing file problem.

Comment 5 Peter Bojtos 2012-06-27 08:54:43 UTC
I've finally found out, where the problem come from. When the squashfs of the installer were generated, the file /usr/lib/locale/locale-archive remained empty, while /usr/lib/locale/locale-archive.tmpl contains it's content.

Unpacking the squashfs, modifying the ext4 filesystem file in it and recreating the squashfs solved the problem for me.

Comment 6 Chris Lumens 2012-08-03 19:46:41 UTC
This should be fixed in the new ui included with anaconda-18.3.

Comment 7 xset1980 2012-09-21 03:29:54 UTC
related: bug 858644

Comment 8 Noriko Mizumoto 2013-04-12 00:53:22 UTC
Through test day event for F19, it has still been observed the string not localized in anaconda, and I like to report it here. Version is now reset to F19.

F19 L10N QA Test Day 2013-04-11
Version: anaconda-19.14-1.fc19.x86_64
Language: ja, de, es

Date&Time section: 
Region and City dropdown menus are not localized.

Storage section: 
Almost all of strings not localized.

Root Password section:
Partially not localized.

User Creation: Entire section not localized.

Please advise if this needs to be filed in separate bug.

Comment 9 Adam Williamson 2013-05-30 01:25:27 UTC
I think it would be best to file new bugs for specific missing translation issues at this point, rather than keep necro'ing a bug that dates to the old UI and hence completely different code.

FWIW, I tested Beta in Japanese; the region and city dropdowns on date/time are not localized (I'm not sure if this is intentional or not) but the storage section, root password spoke and user creation spoke all look to be translated.