Bug 8251

Summary: Hangs when loading shared lib symbols
Product: [Retired] Red Hat Raw Hide Reporter: Brian Ryner <bryner>
Component: gdbAssignee: Nalin Dahyabhai <nalin>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 1.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-01-07 19:01:23 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Brian Ryner 2000-01-07 01:42:37 UTC
In gdb-4.18-6, I am seeing problems when loading shared library symbols,
from certain libraries especially.  This is when using the "sharedlibrary"
command from inside gdb.  gdb just hangs while reading the symbols.
gdb-4.18-4 does NOT seem to have this problem.  It may or may not be
related to the fact that I just switched CPU's in my machine, from a
Pentium/MMX 233 to an AMD K6-2/400.  I had been successfully using 4.18-6
on this program (mozilla) prior to changing the CPU, but I've also updated
the code since then, so either one could be to blame.

Comment 1 Jim Kingdon 2000-01-07 19:01:59 UTC
Not a lot to be done without a test case.  Feel to submit one, either
here in bugzilla (as an attachment) or directly to the GDB maintainers
at http://sourceware.cygnus.com/gdb/