Bug 8251 - Hangs when loading shared lib symbols
Summary: Hangs when loading shared lib symbols
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gdb (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-01-07 01:42 UTC by Brian Ryner
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-07 19:01:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brian Ryner 2000-01-07 01:42:37 UTC
In gdb-4.18-6, I am seeing problems when loading shared library symbols,
from certain libraries especially.  This is when using the "sharedlibrary"
command from inside gdb.  gdb just hangs while reading the symbols.
gdb-4.18-4 does NOT seem to have this problem.  It may or may not be
related to the fact that I just switched CPU's in my machine, from a
Pentium/MMX 233 to an AMD K6-2/400.  I had been successfully using 4.18-6
on this program (mozilla) prior to changing the CPU, but I've also updated
the code since then, so either one could be to blame.

Comment 1 Jim Kingdon 2000-01-07 19:01:59 UTC
Not a lot to be done without a test case.  Feel to submit one, either
here in bugzilla (as an attachment) or directly to the GDB maintainers
at http://sourceware.cygnus.com/gdb/


Note You need to log in before you can comment on or make changes to this bug.