This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 826855

Summary: Installation Error:POSTIN scriptlet failure in rpm package glusterfs-geo-replication-3.3.0qa45-1.el6.x86_64
Product: Red Hat Gluster Storage Reporter: pushpesh sharma <psharma>
Component: buildAssignee: Amar Tumballi <amarts>
Status: CLOSED DUPLICATE QA Contact: Sudhir D <sdharane>
Severity: medium Docs Contact:
Priority: medium    
Version: 2.0CC: bbandari, ckannan, gluster-bugs, grajaiya, kkeithle, ndevos, phil, shaines, vraman
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
See Also: https://bugzilla.redhat.com/show_bug.cgi?id=819130
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-10-11 03:54:42 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description pushpesh sharma 2012-05-31 02:57:25 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Take  a fresh rhs2.0, and downloded gluster3.3_qa_45 build
2.Install it using: 
yum install glusterfs-*

3.
  
Actual results:


Expected results:
Running Transaction
  Installing : glusterfs-3.3.0qa45-1.el6.x86_64                                                                                                 1/9
  Installing : glusterfs-fuse-3.3.0qa45-1.el6.x86_64                                                                                            2/9
  Installing : libibverbs-1.1.5-3.el6.x86_64                                                                                                    3/9
  Installing : rsync-3.0.6-5.el6_0.1.x86_64                                                                                                     4/9
  Installing : glusterfs-geo-replication-3.3.0qa45-1.el6.x86_64                                                                                 5/9
Non-fatal POSTIN scriptlet failure in rpm package glusterfs-geo-replication-3.3.0qa45-1.el6.x86_64
warning: %post(glusterfs-geo-replication-3.3.0qa45-1.el6.x86_64) scriptlet failed, exit status 127
  Installing : glusterfs-rdma-3.3.0qa45-1.el6.x86_64                                                                                            6/9
  Installing : glusterfs-server-3.3.0qa45-1.el6.x86_64                                                                                          7/9
  Installing : glusterfs-devel-3.3.0qa45-1.el6.x86_64                                                                                           8/9
  Installing : glusterfs-debuginfo-3.3.0qa45-1.el6.x86_64                                                                                       9/9
Installed products updated.
 
Installed:
  glusterfs.x86_64 0:3.3.0qa45-1.el6            glusterfs-debuginfo.x86_64 0:3.3.0qa45-1.el6           glusterfs-devel.x86_64 0:3.3.0qa45-1.el6   
  glusterfs-fuse.x86_64 0:3.3.0qa45-1.el6       glusterfs-geo-replication.x86_64 0:3.3.0qa45-1.el6     glusterfs-rdma.x86_64 0:3.3.0qa45-1.el6     
  glusterfs-server.x86_64 0:3.3.0qa45-1.el6
Comment 2 Amar Tumballi 2012-07-05 03:04:06 EDT
'Requires' field for that particular package needs to have 'glusterfs-server' in there to solve the issue.
Comment 3 Kaleb KEITHLEY 2012-07-05 07:56:25 EDT
see https://bugzilla.redhat.com/show_bug.cgi?id=819130
Comment 5 Chandrasekar Kannan 2012-07-10 17:49:19 EDT
test, please ignore
Comment 6 Chandrasekar Kannan 2012-07-10 17:49:37 EDT
test, please ignore
Comment 7 Chandrasekar Kannan 2012-07-10 17:52:27 EDT
test, please ignore
Comment 9 Niels de Vos 2012-10-11 03:54:42 EDT
gluserfs-geo-replication was installed before the /etc/init.d/glusterd service was available (glusterfs-server was installed later). This caused the %post scriptlet for glusterfs-geo-replication to exit with an error (it tried to restart a non-existing service).

I am confident that this will be fixed with bug 766640.

*** This bug has been marked as a duplicate of bug 766640 ***