Bug 819130 - Merge in the Fedora spec changes to build one single unified spec
Merge in the Fedora spec changes to build one single unified spec
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: build (Show other bugs)
3.4.0-beta
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Kaleb KEITHLEY
:
: 976124 (view as bug list)
Depends On:
Blocks: 918917 952693 1039965
  Show dependency treegraph
 
Reported: 2012-05-04 20:58 EDT by Joe Julian
Modified: 2015-12-01 11:45 EST (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 950083 1039965 (view as bug list)
Environment:
Last Closed: 2013-07-24 13:28:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Julian 2012-05-04 20:58:55 EDT
I'll be merging in the spec changes from Fedora. This should be used for 3.1, 3.2 and 3.3.
Comment 1 Vijay Bellur 2013-02-17 22:32:16 EST
CHANGE: http://review.gluster.org/4454 (glusterfs.spec.in: resync with Fedora glusterfs.spec) merged in master by Anand Avati (avati@redhat.com)
Comment 2 Vijay Bellur 2013-02-18 01:50:32 EST
CHANGE: http://review.gluster.org/4532 (LinuxRPM/Makefile: fix backquote which was triggering recursive make) merged in master by Anand Avati (avati@redhat.com)
Comment 3 Vijay Bellur 2013-02-19 13:21:25 EST
CHANGE: http://review.gluster.org/4547 (glusterfs.spec.in: resync with Fedora glusterfs.spec) merged in master by Anand Avati (avati@redhat.com)
Comment 4 Vijay Bellur 2013-03-22 14:55:24 EDT
CHANGE: http://review.gluster.org/4674 (glusterfs.spec.in: sync with fedora glusterfs.spec) merged in master by Anand Avati (avati@redhat.com)
Comment 5 Vijay Bellur 2013-03-26 15:04:52 EDT
REVIEW: http://review.gluster.org/4724 (glusterfs.spec.in: resync with Fedora glusterfs.spec) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 6 Vijay Bellur 2013-03-26 15:32:48 EDT
REVIEW: http://review.gluster.org/4725 (glusterfs.spec.in: resync with Fedora glusterfs.spec) posted (#1) for review on release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 7 Vijay Bellur 2013-03-26 21:29:17 EDT
COMMIT: http://review.gluster.org/4725 committed in release-3.4 by Anand Avati (avati@redhat.com) 
------
commit 87d03fa7f48af6500cb8277db96ee7f6c690ea1c
Author: Krishnan Parthasarathi <kparthas@redhat.com>
Date:   Wed Feb 27 17:55:47 2013 +0530

    glusterd: Removed fd leaks in glusterfs_start utility function
    
    PROBLEM:
        The FILE* associated with the pidfile was leaked if
        pmap_registry_search on the brickinfo' path failed.
    
    FIX:
        Eliminates the use of the FILE* that was leaked. Uses
        glusterd_is_service_running utility function in place
        of the earlier attempt to check for the same.
    
    Change-Id: I94082bd5a94b8a6340f8cc11726d3264e364efe6
    BUG: 916549
    Signed-off-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Reviewed-on: http://review.gluster.org/4596
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 8 Vijay Bellur 2013-03-28 11:43:13 EDT
REVIEW: http://review.gluster.org/4742 (glusterfs.spec.in: sync with fedora glusterfs.spec) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 9 Vijay Bellur 2013-03-28 11:58:16 EDT
REVIEW: http://review.gluster.org/4743 (glusterfs.spec.in: sync with fedora glusterfs.spec) posted (#1) for review on release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 10 Vijay Bellur 2013-03-28 17:28:29 EDT
COMMIT: http://review.gluster.org/4742 committed in master by Anand Avati (avati@redhat.com) 
------
commit 2cd9b31a5f032af807dea7b3d1b40592444154b5
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Thu Mar 28 11:41:25 2013 -0400

    glusterfs.spec.in: sync with fedora glusterfs.spec
    
    add --without ufo
    
    Change-Id: If1b77003ded537f9664fa6ad677d48d118516c64
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    BUG: 819130
    Reviewed-on: http://review.gluster.org/4742
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: Luis Pabon <lpabon@redhat.com>
    Reviewed-by: Luis Pabon <lpabon@redhat.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 11 Vijay Bellur 2013-03-28 17:28:51 EDT
COMMIT: http://review.gluster.org/4743 committed in release-3.4 by Anand Avati (avati@redhat.com) 
------
commit 2cd9b31a5f032af807dea7b3d1b40592444154b5
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Thu Mar 28 11:41:25 2013 -0400

    glusterfs.spec.in: sync with fedora glusterfs.spec
    
    add --without ufo
    
    Change-Id: If1b77003ded537f9664fa6ad677d48d118516c64
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    BUG: 819130
    Reviewed-on: http://review.gluster.org/4742
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: Luis Pabon <lpabon@redhat.com>
    Reviewed-by: Luis Pabon <lpabon@redhat.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 12 Kaleb KEITHLEY 2013-04-01 10:52:40 EDT
merged (cherry pick) from master to release-3.4
Comment 13 Anand Avati 2013-04-10 15:21:03 EDT
REVIEW: http://review.gluster.org/4805 (build: add BuildRequires librdmacm-devel) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 14 Anand Avati 2013-04-10 15:30:33 EDT
REVIEW: http://review.gluster.org/4806 (build: add BuildRequires librdmacm-devel) posted (#1) for review on release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 15 Anand Avati 2013-04-12 03:20:45 EDT
COMMIT: http://review.gluster.org/4806 committed in release-3.4 by Anand Avati (avati@redhat.com) 
------
commit 432ce7e60fb58d3cbb019ab3159b7d393afaaed6
Author: Niels de Vos <ndevos@redhat.com>
Date:   Wed Apr 10 17:51:37 2013 +0200

    build: really disable fusermount if you say so
    
    There is no logic in configure.ac that provides a $disable_fusermount
    variable. So, use the $enable_fusermount variable instead.
    
    Follow-up-for: http://review.gluster.org/4773
    Change-Id: I81cdbd0045409d0036438d542ca6dc1934f784e4
    BUG: 948205
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/4803
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Reviewed-by: Sachidananda Urs <sacchi@gmail.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 16 Anand Avati 2013-04-23 13:04:30 EDT
REVIEW: http://review.gluster.org/4877 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#2) for review on release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 17 Anand Avati 2013-04-23 16:24:50 EDT
REVIEW: http://review.gluster.org/4877 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#3) for review on release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 18 Anand Avati 2013-04-25 13:42:34 EDT
REVIEW: http://review.gluster.org/4877 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#4) for review on release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 19 Anand Avati 2013-04-26 11:17:30 EDT
COMMIT: http://review.gluster.org/4877 committed in release-3.4 by Anand Avati (avati@redhat.com) 
------
commit 7f162316f074f19cfecca9197060e4e687658345
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Tue Apr 23 12:57:40 2013 -0400

    build: sync glusterfs.spec.in with Fedora glusterfs.spec
    
    BUG: 819130
    Change-Id: I96aeb8fbe8b79bbc058ff9a45167d822abb576ed
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/4877
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
Comment 20 Anand Avati 2013-06-07 10:06:15 EDT
REVIEW: http://review.gluster.org/5179 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#1) for review on release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 21 Anand Avati 2013-06-07 11:49:12 EDT
REVIEW: http://review.gluster.org/5179 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#2) for review on release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 22 Anand Avati 2013-06-07 12:58:40 EDT
REVIEW: http://review.gluster.org/5179 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#3) for review on release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 23 Anand Avati 2013-06-07 13:44:56 EDT
REVIEW: http://review.gluster.org/5179 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#4) for review on release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 24 Anand Avati 2013-06-07 13:55:34 EDT
REVIEW: http://review.gluster.org/5179 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#5) for review on release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 25 Anand Avati 2013-06-07 15:32:12 EDT
REVIEW: http://review.gluster.org/5179 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#6) for review on release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 26 Anand Avati 2013-06-07 15:39:02 EDT
REVIEW: http://review.gluster.org/5179 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#7) for review on release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 27 Anand Avati 2013-06-07 16:03:33 EDT
REVIEW: http://review.gluster.org/5179 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#8) for review on release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 28 Anand Avati 2013-06-07 16:05:04 EDT
REVIEW: http://review.gluster.org/5179 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#9) for review on release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 29 Anand Avati 2013-06-07 16:51:38 EDT
REVIEW: http://review.gluster.org/5179 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#10) for review on release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 30 Anand Avati 2013-06-08 09:17:11 EDT
REVIEW: http://review.gluster.org/5179 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#11) for review on release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 31 Anand Avati 2013-06-12 14:29:42 EDT
REVIEW: http://review.gluster.org/5179 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#12) for review on release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 32 Anand Avati 2013-06-17 13:48:27 EDT
REVIEW: http://review.gluster.org/5179 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#13) for review on release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 33 Anand Avati 2013-06-19 10:12:44 EDT
REVIEW: http://review.gluster.org/5179 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#14) for review on release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 34 Kaleb KEITHLEY 2013-06-20 13:09:06 EDT
*** Bug 976124 has been marked as a duplicate of this bug. ***
Comment 35 Anand Avati 2013-06-21 08:49:20 EDT
REVIEW: http://review.gluster.org/5179 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#15) for review on release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 36 Anand Avati 2013-06-21 09:25:58 EDT
REVIEW: http://review.gluster.org/5179 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#16) for review on release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 37 Anand Avati 2013-06-21 13:33:13 EDT
COMMIT: http://review.gluster.org/5179 committed in release-3.4 by Anand Avati (avati@redhat.com) 
------
commit 159938575b43ce9af503c74560e044ee69d1395c
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Fri Jun 7 09:46:12 2013 -0400

    build: sync glusterfs.spec.in with Fedora glusterfs.spec
    
    (This is the release-3.4 branch.)
    
     * remove G4S/UFO from community packaging. The Fedora/EPEL packaging
       will follow suit once the glusterfs-openstack-swift packaging
       materializes from the G4S team. Note that for the time being 'make dist'
       still creates a UFO tarball from the .../ufo directory for use by
       fedora packaging.
     * add glusterfs-api and glusterfs-api-devel sub-packages
     * add extras/systemd/glusterd.service. Use it (or extras/init.d/glusterd)
       instead of the Fedora versions.
     * restores ability to build glusterfs RPMs from the dist tarball with
       'rpmbuild {-ts,-tb,-ta} glusterfs-XXX.tar.gz'
     * reverse {--with,--without}_fusermount in sync with fedora .spec and
       master branch
     * other minor cleanups mostly to sync with fedora .spec and to build
       from the dist tarball. Any differences will be resolved in the fedora
       .spec in the next release (i.e. beta4 or GA).
     * this is nominally for "the impending merge of .../api from master" but
       should be independent of that change.
    
    (still deciding whether to add the fedora glusterfsd.{init,service) files
    here or remove them from fedora.)
    
    BUG: 819130
    Change-Id: I90c7355ca02239995b1df7646e3cd10ec227bcc5
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/5179
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 38 Anand Avati 2013-06-26 07:31:45 EDT
REVIEW: http://review.gluster.org/5254 (rpm: move the mount/api xlator to the glusterfs-api sub-package) posted (#1) for review on release-3.4 by Niels de Vos (ndevos@redhat.com)
Comment 39 Anand Avati 2013-06-26 09:36:12 EDT
COMMIT: http://review.gluster.org/5254 committed in release-3.4 by Vijay Bellur (vbellur@redhat.com) 
------
commit 162b6684beb3d567a1cd9d05efa790460ece684b
Author: Niels de Vos <ndevos@redhat.com>
Date:   Wed Jun 26 13:25:22 2013 +0200

    rpm: move the mount/api xlator to the glusterfs-api sub-package
    
    The main glusterfs package included the xlator/api.so file which caused
    a dependency on the glusterfs-api package:
    
      # rpm -i glusterfs-3.4.0-0.6.beta3.el6.x86_64.rpm
      error: Failed dependencies:
      libgfapi.so.0()(64bit) is needed by glusterfs-3.4.0-0.6.beta3.el6.x86_64
    
    Moving the mount/api xlator to the glusterfs-api package will prevent
    the automatic dependency generator to add the dependency to the main
    package.
    
    Change-Id: I333c6b61dfc239a7b0beca313aa5928f4e197937
    BUG: 819130
    Reported-by: Vijay Bellur <vbellur@redhat.com>
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/5254
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 40 Anand Avati 2013-06-27 10:34:44 EDT
REVIEW: http://review.gluster.org/5263 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#1) for review on release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 41 Anand Avati 2013-06-27 10:43:36 EDT
REVIEW: http://review.gluster.org/5263 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#2) for review on release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 42 Anand Avati 2013-06-27 11:34:54 EDT
REVIEW: http://review.gluster.org/5263 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#3) for review on release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 43 Anand Avati 2013-06-27 11:50:34 EDT
REVIEW: http://review.gluster.org/5263 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#4) for review on release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 44 Anand Avati 2013-06-27 14:12:17 EDT
REVIEW: http://review.gluster.org/5263 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#5) for review on release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 45 Anand Avati 2013-06-28 07:49:21 EDT
REVIEW: http://review.gluster.org/5270 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#1) for review on release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 46 Anand Avati 2013-06-28 12:24:37 EDT
COMMIT: http://review.gluster.org/5270 committed in release-3.4 by Vijay Bellur (vbellur@redhat.com) 
------
commit b6d0be85435f508cf6b343ba5d103e3238f65084
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Thu Jun 27 10:44:44 2013 -0400

    build: sync glusterfs.spec.in with Fedora glusterfs.spec
    
    (this is the release-3.4 branch)
    
    * fix the hardening fix for shlibs
    * use %{__sed} macro
    * better short ChangeLog
    * fix hard-coded path in extras/systemd/glusterd.service in, use @prefix@
    
    Change-Id: I267244b68a97cbcd6f6ab62fc322c78db45023bb
    BUG: 819130
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/5270
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 47 Anand Avati 2013-07-30 14:03:55 EDT
REVIEW: http://review.gluster.org/5437 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#1) for review on release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 48 Anand Avati 2013-07-31 07:36:05 EDT
REVIEW: http://review.gluster.org/5437 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#2) for review on release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 49 Anand Avati 2013-07-31 14:39:17 EDT
REVIEW: http://review.gluster.org/5437 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#3) for review on release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 50 Anand Avati 2013-08-01 06:01:00 EDT
COMMIT: http://review.gluster.org/5437 committed in release-3.4 by Vijay Bellur (vbellur@redhat.com) 
------
commit 03d9369ae9e69491911adbc4f16570fa1dedaa1e
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Tue Jul 30 14:00:46 2013 -0400

    build: sync glusterfs.spec.in with Fedora glusterfs.spec
    
    (this is the release-3.4 branch)
    
    * Sync with latest Fedora updates
    * add glusterfs-libs RPM for RHEL6.5 oVirt/qemu-kvm, see BZ 916645
    
    BUG: 819130
    Change-Id: If5816f9b6a9478f6663c1de4d14a9f8341da9e84
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/5437
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
Comment 51 Anand Avati 2013-08-07 08:41:18 EDT
REVIEW: http://review.gluster.org/5520 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 52 Anand Avati 2013-08-07 09:14:06 EDT
REVIEW: http://review.gluster.org/5521 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#1) for review on release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 53 Anand Avati 2013-08-08 13:50:46 EDT
COMMIT: http://review.gluster.org/5521 committed in release-3.4 by Anand Avati (avati@redhat.com) 
------
commit a7a9328221419febecea1fc4119005b420c39285
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Wed Aug 7 09:11:48 2013 -0400

    build: sync glusterfs.spec.in with Fedora glusterfs.spec
    
    (this is the release-3.4 branch)
    
    * add necessary requires
    * add -cli subpackage
    * fix other minor differences with Fedora glusterfs.spec
    
    Change-Id: I86eb38a1cc52cdcd25f62c75fae28dbd9539195e
    BUG: 819130
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/5521
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 54 Anand Avati 2013-10-09 07:56:12 EDT
REVIEW: http://review.gluster.org/6058 (ld: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#1) for review on release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 55 Anand Avati 2013-10-09 08:00:05 EDT
REVIEW: http://review.gluster.org/6058 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#2) for review on release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 56 Anand Avati 2013-10-11 15:34:41 EDT
COMMIT: http://review.gluster.org/6058 committed in release-3.4 by Anand Avati (avati@redhat.com) 
------
commit b7f894fd0e46bcffca534265b95a4171ea59be4e
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Wed Oct 9 07:54:27 2013 -0400

    build: sync glusterfs.spec.in with Fedora glusterfs.spec
    
    (this is the release-3.4 branch)
    
    sync with Fedora glusterfs.spec 3.4.1-2+
    
    Change-Id: I13e7161dca969804415045a47e37705819fe173d
    BUG: 819130
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/6058
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>

Note You need to log in before you can comment on or make changes to this bug.