Bug 82690

Summary: USB mouse and touchpad cause keyboard to lock up
Product: [Retired] Red Hat Linux Reporter: L.L. <lfl77>
Component: kernelAssignee: Arjan van de Ven <arjanv>
Status: CLOSED DUPLICATE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0CC: zaitcev
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:51:22 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description L.L. 2003-01-24 22:12:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020913

Description of problem:

If a USB mouse is installed, touching the touchpad
causes the keyboard to lock up hard (it can only function
again if you reboot the computer).  The USB mouse continues
to work fine.  The touchpad never moves the cursor.

I am running Psyche on a Dell Inspiron 5000 with a Celeron 500 MHz
and 128 MB ram.

This is probably related to Bug 70696 for RH 7.3.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Boot with USB mouse plugged in
2.Touch the built in touchpad
3.Observe that the keyboard is frozen.

Actual Results:  
The keyboard is frozen.

Expected Results:  
The keyboard should have continued to function.
Also, when I had entries for "/dev/mouse" and "/dev/input/mice"
side by side in XF86Config, the touchpad and USB mouse should 
both have been functional.  This worked under RH 7.0.

Additional info:

When I boot with a USB mouse plugged in and it's autodetected,
the USB mouse works fine.  However, the second anything touches 
the built-in touchpad, the keyboard locks up, whether or not X is running. 
Under X, the USB mouse continues to work perfectly, but 
the keyboard no longer functions even after one exits X and returns 
to the console.  Only rebooting seems to restore the keyboard function.
   I edited XF86Config, unplugged the external mouse and rebooted.  On the
reboot, I changed the mouse configuration to "generic 2-button mouse".  The
touchpad then worked fine (obviously the external mouse did not) and the
keyboard did not lock up.  I then tried switching back to the USB mouse with the
built in redhat mouse config tool but that led back to the original problem.
   I tried the kernel that shipped with Psyche as well as the -19.8.0 updated
version, and they both behaved the same way.
   I have not tried using a PS/2 external mouse instead.  I'll email 
again once I do.

Hope this is helpful.

Comment 1 Pete Zaitcev 2003-02-27 05:04:32 UTC

*** This bug has been marked as a duplicate of 82678 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:51:22 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.