Bug 82690 - USB mouse and touchpad cause keyboard to lock up
USB mouse and touchpad cause keyboard to lock up
Status: CLOSED DUPLICATE of bug 82678
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2003-01-24 17:12 EST by L.L.
Modified: 2007-04-18 12:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:51:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description L.L. 2003-01-24 17:12:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020913

Description of problem:

If a USB mouse is installed, touching the touchpad
causes the keyboard to lock up hard (it can only function
again if you reboot the computer).  The USB mouse continues
to work fine.  The touchpad never moves the cursor.

I am running Psyche on a Dell Inspiron 5000 with a Celeron 500 MHz
and 128 MB ram.

This is probably related to Bug 70696 for RH 7.3.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Boot with USB mouse plugged in
2.Touch the built in touchpad
3.Observe that the keyboard is frozen.

Actual Results:  
The keyboard is frozen.

Expected Results:  
The keyboard should have continued to function.
Also, when I had entries for "/dev/mouse" and "/dev/input/mice"
side by side in XF86Config, the touchpad and USB mouse should 
both have been functional.  This worked under RH 7.0.

Additional info:

When I boot with a USB mouse plugged in and it's autodetected,
the USB mouse works fine.  However, the second anything touches 
the built-in touchpad, the keyboard locks up, whether or not X is running. 
Under X, the USB mouse continues to work perfectly, but 
the keyboard no longer functions even after one exits X and returns 
to the console.  Only rebooting seems to restore the keyboard function.
   I edited XF86Config, unplugged the external mouse and rebooted.  On the
reboot, I changed the mouse configuration to "generic 2-button mouse".  The
touchpad then worked fine (obviously the external mouse did not) and the
keyboard did not lock up.  I then tried switching back to the USB mouse with the
built in redhat mouse config tool but that led back to the original problem.
   I tried the kernel that shipped with Psyche as well as the -19.8.0 updated
version, and they both behaved the same way.
   I have not tried using a PS/2 external mouse instead.  I'll email 
again once I do.

Hope this is helpful.
Comment 1 Pete Zaitcev 2003-02-27 00:04:32 EST

*** This bug has been marked as a duplicate of 82678 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:51:22 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.