Bug 827734

Summary: non booting rawhide kernels and now breaking last booting kernel
Product: [Fedora] Fedora Reporter: Paulo Andrade <paulo.cesar.pereira.de.andrade>
Component: device-mapper-multipathAssignee: LVM and device-mapper development team <lvm-team>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: high    
Version: rawhideCC: agk, bmarzins, dwysocha, fdinitto, heinzm, lvm-team, mbroz, msnitzer, prockai
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: All   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-06-04 18:06:36 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Paulo Andrade 2012-06-02 17:31:18 UTC
Attempting to run %post scripts manually:

# /sbin/new-kernel-pkg -v --package kernel --mkinitrd --dracut --depmod --update 3.5.0-0.rc0.git11.1.fc18.x86_64
initrdfile is /boot/initramfs-3.5.0-0.rc0.git11.1.fc18.x86_64.img
running depmod for 3.5.0-0.rc0.git11.1.fc18.x86_64
creating initrd: dracut  -f /boot/initramfs-3.5.0-0.rc0.git11.1.fc18.x86_64.img 3.5.0-0.rc0.git11.1.fc18.x86_64
F: installkernel failed in module multipath
mkinitrd failed

First message when booting is about needing to change

/usr/lib/udev/rules.d/40-multipath.rules:40

to not use RUN but listen to udev events.

Now, after a few yum update runs from time to time (I recently
started using rawhide), the boot the previous good kernel, I also
need to enter root password in systemd login, and so something like:

# cd /dev/VolGroup/
# ln -sf ../dm-2 VolGroup-lv_home
# ^D

for it to be able to mount /home, and to be able to boot, but
not sure if not caused by another issue.

Comment 1 Paulo Andrade 2012-06-02 17:32:18 UTC
Correction, the line in /usr/lib/udev/rules.d/40-multipath.rules
is 16, not 40:

RUN+="socket:/org/kernel/dm/multipath_event"

Comment 2 Paulo Andrade 2012-06-04 05:12:21 UTC
Not sure if related or side effect, but changing
/etc/selinux/config SELINUX=enforcing to
SELINUX=permissive made sound work again, and
no longer need to cd /dev/mapper and make the
symbolic link when booting (in the first comment
I wrongly said /dev/VolGroup).

Comment 3 Paulo Andrade 2012-06-04 18:06:36 UTC

*** This bug has been marked as a duplicate of bug 826689 ***