Bug 827734 - non booting rawhide kernels and now breaking last booting kernel
non booting rawhide kernels and now breaking last booting kernel
Status: CLOSED DUPLICATE of bug 826689
Product: Fedora
Classification: Fedora
Component: device-mapper-multipath (Show other bugs)
rawhide
All All
high Severity medium
: ---
: ---
Assigned To: LVM and device-mapper development team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-02 13:31 EDT by Paulo Andrade
Modified: 2012-06-04 14:06 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-04 14:06:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paulo Andrade 2012-06-02 13:31:18 EDT
Attempting to run %post scripts manually:

# /sbin/new-kernel-pkg -v --package kernel --mkinitrd --dracut --depmod --update 3.5.0-0.rc0.git11.1.fc18.x86_64
initrdfile is /boot/initramfs-3.5.0-0.rc0.git11.1.fc18.x86_64.img
running depmod for 3.5.0-0.rc0.git11.1.fc18.x86_64
creating initrd: dracut  -f /boot/initramfs-3.5.0-0.rc0.git11.1.fc18.x86_64.img 3.5.0-0.rc0.git11.1.fc18.x86_64
F: installkernel failed in module multipath
mkinitrd failed

First message when booting is about needing to change

/usr/lib/udev/rules.d/40-multipath.rules:40

to not use RUN but listen to udev events.

Now, after a few yum update runs from time to time (I recently
started using rawhide), the boot the previous good kernel, I also
need to enter root password in systemd login, and so something like:

# cd /dev/VolGroup/
# ln -sf ../dm-2 VolGroup-lv_home
# ^D

for it to be able to mount /home, and to be able to boot, but
not sure if not caused by another issue.
Comment 1 Paulo Andrade 2012-06-02 13:32:18 EDT
Correction, the line in /usr/lib/udev/rules.d/40-multipath.rules
is 16, not 40:

RUN+="socket:/org/kernel/dm/multipath_event"
Comment 2 Paulo Andrade 2012-06-04 01:12:21 EDT
Not sure if related or side effect, but changing
/etc/selinux/config SELINUX=enforcing to
SELINUX=permissive made sound work again, and
no longer need to cd /dev/mapper and make the
symbolic link when booting (in the first comment
I wrongly said /dev/VolGroup).
Comment 3 Paulo Andrade 2012-06-04 14:06:36 EDT

*** This bug has been marked as a duplicate of bug 826689 ***

Note You need to log in before you can comment on or make changes to this bug.