Bug 83163

Summary: grip-3.0.4-3 won't build; wants libghttp
Product: [Retired] Red Hat Raw Hide Reporter: sean <seandarcy>
Component: gripAssignee: Bill Nottingham <notting>
Status: CLOSED WORKSFORME QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 1.0CC: rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-01-31 00:44:10 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description sean 2003-01-30 21:40:27 UTC
Description of problem: 
grip won't build. Can't find a method in libghttp. I've used the most recent
libghttp from rawhide:


............
checking for ghttp_request_new in -lghttp... no
configure: error: libhttp is required
error: Bad exit status from /var/tmp/rpm-tmp.12946 (%build)
 
 
RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.12946 (%build)
[root@amd1900 rawhide]# ldconfig -v | grep ghttp
        libghttp.so.1 -> libghttp.so.1.0.0
[root@amd1900 rawhide]# rpm -qif /usr/lib/libghttp.so.1.0.0
Name        : libghttp                     Relocations: (not relocateable)
Version     : 1.0.9                             Vendor: (none)
Release     : 7                             Build Date: Thu 30 Jan 2003 04:28:49
PM EST
Install Date: Thu 30 Jan 2003 04:29:14 PM EST      Build Host: amd1900
Group       : System Environment/Libraries   Source RPM: libghttp-1.0.9-7.src.rpm
Size        : 88128                            License: LGPL
Signature   : (none)
URL         : http://www.gnome.org/
Summary     : GNOME HTTP client library.
Description :
The GNOME library for making HTTP 1.1 requests.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:

Comment 1 Bill Nottingham 2003-01-30 21:43:15 UTC
Do you have libghttp-devel installed?

Comment 2 sean 2003-01-31 00:44:10 UTC
I do now.

Thanks.